php5: update version to 5.3.4
* fix build with libiconv * update apc extension git-svn-id: svn://svn.openwrt.org/openwrt/packages@24774 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
939a313afe
commit
00116b4ac8
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=php
|
PKG_NAME:=php
|
||||||
PKG_VERSION:=5.3.1
|
PKG_VERSION:=5.3.4
|
||||||
PKG_RELEASE:=4
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
PKG_SOURCE_URL:=http://www.php.net/distributions/
|
||||||
PKG_MD5SUM:=63e97ad450f0f7259e785100b634c797
|
PKG_MD5SUM:=2c069d8f690933e3bf6a8741ed818150
|
||||||
|
|
||||||
PKG_FIXUP:=libtool no-autoreconf
|
PKG_FIXUP:=libtool no-autoreconf
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
@ -390,7 +390,7 @@ PKG_CONFIGURE_OPTS:= \
|
|||||||
--disable-phar
|
--disable-phar
|
||||||
|
|
||||||
ifneq ($(SDK),)
|
ifneq ($(SDK),)
|
||||||
PKG_BUILD_DEPENDS:=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libpthread libsqlite3 libpcre libxml2
|
PKG_BUILD_DEPENDS+=libopenssl zlib libcurl libgd libgmp libopenldap libmysqlclient libpq libsqlite2 libpthread libsqlite3 libpcre libxml2 libiconv
|
||||||
# force PKG_CONFIGURE_{LIBS,OPTS} below when built in the SDK
|
# force PKG_CONFIGURE_{LIBS,OPTS} below when built in the SDK
|
||||||
CONFIG_PACKAGE_php5-cli:=m
|
CONFIG_PACKAGE_php5-cli:=m
|
||||||
CONFIG_PACKAGE_php5-cgi:=m
|
CONFIG_PACKAGE_php5-cgi:=m
|
||||||
@ -469,7 +469,7 @@ else
|
|||||||
endif
|
endif
|
||||||
|
|
||||||
ifneq ($(CONFIG_PACKAGE_php5-mod-iconv),)
|
ifneq ($(CONFIG_PACKAGE_php5-mod-iconv),)
|
||||||
PKG_CONFIGURE_OPTS+= --with-iconv=shared,"$(STAGING_DIR)/usr/lib/libiconv"
|
PKG_CONFIGURE_OPTS+= --with-iconv=shared,"$(STAGING_DIR)/usr"
|
||||||
else
|
else
|
||||||
PKG_CONFIGURE_OPTS+= --without-iconv
|
PKG_CONFIGURE_OPTS+= --without-iconv
|
||||||
endif
|
endif
|
||||||
|
@ -1,21 +0,0 @@
|
|||||||
diff -Naur php-5.3.1.orig/configure php-5.3.1/configure
|
|
||||||
--- php-5.3.1.orig/configure 2009-11-18 21:11:57.000000000 +0100
|
|
||||||
+++ php-5.3.1/configure 2010-01-15 23:43:10.000000000 +0100
|
|
||||||
@@ -14712,7 +14712,7 @@
|
|
||||||
ac_libs=$LIBS
|
|
||||||
LIBS="$LIBS -ldl"
|
|
||||||
if test "$cross_compiling" = yes; then
|
|
||||||
- found=no
|
|
||||||
+ found=yes
|
|
||||||
else
|
|
||||||
cat > conftest.$ac_ext <<EOF
|
|
||||||
#line 14719 "configure"
|
|
||||||
@@ -54494,7 +54494,7 @@
|
|
||||||
_SAVE_CPPFLAGS=$CPPFLAGS
|
|
||||||
_SAVE_LIBS=$LIBS
|
|
||||||
CPPFLAGS="$CPPFLAGS -I$LDAP_INCDIR"
|
|
||||||
- LIBS="$LIBS $LDAP_SHARED_LIBADD"
|
|
||||||
+ LIBS="$LIBS $LDAP_SHARED_LIBADD -lsasl2"
|
|
||||||
|
|
||||||
echo $ac_n "checking for 3 arg ldap_set_rebind_proc""... $ac_c" 1>&6
|
|
||||||
echo "configure:54501: checking for 3 arg ldap_set_rebind_proc" >&5
|
|
File diff suppressed because it is too large
Load Diff
Loading…
x
Reference in New Issue
Block a user