Update bind to 9.5.0 p1 (#3744)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11802 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c215b33873
commit
00579d7a05
@ -9,14 +9,14 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=bind
|
||||
PKG_VERSION:=9.4.1
|
||||
PKG_VERSION:=9.5.0-P1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:= \
|
||||
ftp://ftp.isc.org/isc/bind9/$(PKG_VERSION) \
|
||||
http://www.mirrorservice.org/sites/ftp.isc.org/isc/bind9/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=09b54d35036cb0423b2e618f21766285
|
||||
PKG_MD5SUM:=a4f9dd6d205d24ec89fa4e44d8188197
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
@ -90,6 +90,7 @@ CONFIGURE_ARGS += \
|
||||
--disable-threads \
|
||||
--with-openssl="$(STAGING_DIR)/usr" \
|
||||
--with-libtool \
|
||||
--with-libxml2=no \
|
||||
, \
|
||||
BUILD_CC="$(TARGET_CC)" \
|
||||
|
||||
|
@ -1,8 +1,8 @@
|
||||
Index: bind-9.4.1/configure
|
||||
Index: bind-9.5.0-P1/configure
|
||||
===================================================================
|
||||
--- bind-9.4.1.orig/configure 2007-06-26 21:11:45.000000000 +0200
|
||||
+++ bind-9.4.1/configure 2007-06-26 21:12:33.000000000 +0200
|
||||
@@ -5262,8 +5262,7 @@
|
||||
--- bind-9.5.0-P1.orig/configure 2008-05-06 02:33:33.000000000 +0100
|
||||
+++ bind-9.5.0-P1/configure 2008-07-12 08:23:25.000000000 +0100
|
||||
@@ -6369,8 +6369,7 @@
|
||||
else
|
||||
test "$cross_compiling" = yes &&
|
||||
{ { echo "$as_me:$LINENO: error: cannot check for file existence when cross compiling" >&5
|
||||
@ -12,18 +12,18 @@ Index: bind-9.4.1/configure
|
||||
if test -r "$devrandom"; then
|
||||
eval "$as_ac_File=yes"
|
||||
else
|
||||
@@ -24165,176 +24164,6 @@
|
||||
@@ -25119,195 +25118,6 @@
|
||||
# which provides some (all?) of the desired functions.
|
||||
#
|
||||
|
||||
-echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
|
||||
-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6
|
||||
-{ echo "$as_me:$LINENO: checking for inet_ntop with IPv6 support" >&5
|
||||
-echo $ECHO_N "checking for inet_ntop with IPv6 support... $ECHO_C" >&6; }
|
||||
-if test "$cross_compiling" = yes; then
|
||||
- echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
|
||||
-echo "${ECHO_T}assuming inet_ntop needed" >&6
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
- { echo "$as_me:$LINENO: result: assuming inet_ntop needed" >&5
|
||||
-echo "${ECHO_T}assuming inet_ntop needed" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
@ -40,44 +40,55 @@ Index: bind-9.4.1/configure
|
||||
-char a[16],b[64]; return(inet_ntop(AF_INET6, a, b, sizeof(b)) == (char*)0);}
|
||||
-_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>&5
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
- (eval "$ac_link") 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- { (case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
- (eval "$ac_try") 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6
|
||||
- ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
|
||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6; }
|
||||
- ISC_PLATFORM_NEEDNTOP="#undef ISC_PLATFORM_NEEDNTOP"
|
||||
-else
|
||||
- echo "$as_me: program exited with status $ac_status" >&5
|
||||
-echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
-{ echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_ntop.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_ntop.c"
|
||||
- ISC_PLATFORM_NEEDNTOP="#define ISC_PLATFORM_NEEDNTOP 1"
|
||||
-fi
|
||||
-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-
|
||||
-
|
||||
-
|
||||
-# On NetBSD 1.4.2 and maybe others, inet_pton() incorrectly accepts
|
||||
-# addresses with less than four octets, like "1.2.3". Also leading
|
||||
-# zeros should also be rejected.
|
||||
-
|
||||
-echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
|
||||
-echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6
|
||||
-{ echo "$as_me:$LINENO: checking for working inet_pton with IPv6 support" >&5
|
||||
-echo $ECHO_N "checking for working inet_pton with IPv6 support... $ECHO_C" >&6; }
|
||||
-if test "$cross_compiling" = yes; then
|
||||
- echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
|
||||
-echo "${ECHO_T}assuming target platform has working inet_pton" >&6
|
||||
- { echo "$as_me:$LINENO: result: assuming target platform has working inet_pton" >&5
|
||||
-echo "${ECHO_T}assuming target platform has working inet_pton" >&6; }
|
||||
- ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
|
||||
-else
|
||||
- cat >conftest.$ac_ext <<_ACEOF
|
||||
@ -96,36 +107,47 @@ Index: bind-9.4.1/configure
|
||||
- (inet_pton(AF_INET6, "::1.2.3.4", a) != 1)); }
|
||||
-_ACEOF
|
||||
-rm -f conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>&5
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
- (eval "$ac_link") 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } && { ac_try='./conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- { (case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
- (eval "$ac_try") 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6
|
||||
- ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
|
||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6; }
|
||||
- ISC_PLATFORM_NEEDPTON="#undef ISC_PLATFORM_NEEDPTON"
|
||||
-else
|
||||
- echo "$as_me: program exited with status $ac_status" >&5
|
||||
-echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-( exit $ac_status )
|
||||
-echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
|
||||
- ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
|
||||
-{ echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_pton.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_pton.c"
|
||||
- ISC_PLATFORM_NEEDPTON="#define ISC_PLATFORM_NEEDPTON 1"
|
||||
-fi
|
||||
-rm -f core *.core gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-rm -f core *.core core.conftest.* gmon.out bb.out conftest$ac_exeext conftest.$ac_objext conftest.$ac_ext
|
||||
-fi
|
||||
-
|
||||
-echo "$as_me:$LINENO: checking for inet_aton" >&5
|
||||
-echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6
|
||||
-
|
||||
-
|
||||
-{ echo "$as_me:$LINENO: checking for inet_aton" >&5
|
||||
-echo $ECHO_N "checking for inet_aton... $ECHO_C" >&6; }
|
||||
-cat >conftest.$ac_ext <<_ACEOF
|
||||
-/* confdefs.h. */
|
||||
-_ACEOF
|
||||
@ -145,41 +167,38 @@ Index: bind-9.4.1/configure
|
||||
-}
|
||||
-_ACEOF
|
||||
-rm -f conftest.$ac_objext conftest$ac_exeext
|
||||
-if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
|
||||
- (eval $ac_link) 2>conftest.er1
|
||||
-if { (ac_try="$ac_link"
|
||||
-case "(($ac_try" in
|
||||
- *\"* | *\`* | *\\*) ac_try_echo=\$ac_try;;
|
||||
- *) ac_try_echo=$ac_try;;
|
||||
-esac
|
||||
-eval "echo \"\$as_me:$LINENO: $ac_try_echo\"") >&5
|
||||
- (eval "$ac_link") 2>conftest.er1
|
||||
- ac_status=$?
|
||||
- grep -v '^ *+' conftest.er1 >conftest.err
|
||||
- rm -f conftest.er1
|
||||
- cat conftest.err >&5
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); } &&
|
||||
- { ac_try='test -z "$ac_c_werror_flag"
|
||||
- || test ! -s conftest.err'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; } &&
|
||||
- { ac_try='test -s conftest$ac_exeext'
|
||||
- { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
|
||||
- (eval $ac_try) 2>&5
|
||||
- ac_status=$?
|
||||
- echo "$as_me:$LINENO: \$? = $ac_status" >&5
|
||||
- (exit $ac_status); }; }; then
|
||||
- echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6
|
||||
- ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
|
||||
- (exit $ac_status); } && {
|
||||
- test -z "$ac_c_werror_flag" ||
|
||||
- test ! -s conftest.err
|
||||
- } && test -s conftest$ac_exeext &&
|
||||
- $as_test_x conftest$ac_exeext; then
|
||||
- { echo "$as_me:$LINENO: result: yes" >&5
|
||||
-echo "${ECHO_T}yes" >&6; }
|
||||
- ISC_PLATFORM_NEEDATON="#undef ISC_PLATFORM_NEEDATON"
|
||||
-else
|
||||
- echo "$as_me: failed program was:" >&5
|
||||
-sed 's/^/| /' conftest.$ac_ext >&5
|
||||
-
|
||||
-echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
|
||||
- ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
|
||||
- { echo "$as_me:$LINENO: result: no" >&5
|
||||
-echo "${ECHO_T}no" >&6; }
|
||||
- ISC_EXTRA_OBJS="$ISC_EXTRA_OBJS inet_aton.$O"
|
||||
- ISC_EXTRA_SRCS="$ISC_EXTRA_SRCS inet_aton.c"
|
||||
- ISC_PLATFORM_NEEDATON="#define ISC_PLATFORM_NEEDATON 1"
|
||||
-fi
|
||||
-rm -f conftest.err conftest.$ac_objext \
|
||||
-
|
||||
-rm -f core conftest.err conftest.$ac_objext conftest_ipa8_conftest.oo \
|
||||
- conftest$ac_exeext conftest.$ac_ext
|
||||
-
|
||||
-
|
||||
@ -189,12 +208,12 @@ Index: bind-9.4.1/configure
|
||||
#
|
||||
# Look for a 4.4BSD-style sa_len member in struct sockaddr.
|
||||
#
|
||||
Index: bind-9.4.1/lib/bind/configure
|
||||
Index: bind-9.5.0-P1/lib/bind/configure
|
||||
===================================================================
|
||||
--- bind-9.4.1.orig/lib/bind/configure 2007-06-26 21:11:45.000000000 +0200
|
||||
+++ bind-9.4.1/lib/bind/configure 2007-06-26 21:12:33.000000000 +0200
|
||||
@@ -4461,6 +4461,7 @@
|
||||
if eval "test \"\${$as_ac_File+set}\" = set"; then
|
||||
--- bind-9.5.0-P1.orig/lib/bind/configure 2008-04-29 00:51:46.000000000 +0100
|
||||
+++ bind-9.5.0-P1/lib/bind/configure 2008-06-08 15:16:17.000000000 +0100
|
||||
@@ -5292,6 +5292,7 @@
|
||||
if { as_var=$as_ac_File; eval "test \"\${$as_var+set}\" = set"; }; then
|
||||
echo $ECHO_N "(cached) $ECHO_C" >&6
|
||||
else
|
||||
+cross_compiling=no
|
||||
|
Loading…
x
Reference in New Issue
Block a user