[packages] xtables-addons: update to v1.41
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29988 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
2091be2585
commit
021b7dff3f
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2009-2011 OpenWrt.org
|
# Copyright (C) 2009-2012 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/kernel.mk
|
include $(INCLUDE_DIR)/kernel.mk
|
||||||
|
|
||||||
PKG_NAME:=xtables-addons
|
PKG_NAME:=xtables-addons
|
||||||
PKG_VERSION:=1.31
|
PKG_VERSION:=1.41
|
||||||
PKG_RELEASE:=3
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_MD5SUM:=97ac895a67df67c28def98763023d51b
|
PKG_MD5SUM:=a8de5e5e5823aefcbab210159f122564
|
||||||
PKG_SOURCE_URL:=@SF/xtables-addons
|
PKG_SOURCE_URL:=@SF/xtables-addons
|
||||||
PKG_BUILD_DEPENDS:=iptables
|
PKG_BUILD_DEPENDS:=iptables
|
||||||
PKG_INSTALL:=1
|
PKG_INSTALL:=1
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=autoreconf
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
@ -106,7 +106,6 @@ $(eval $(call BuildTemplate,chaos,CHAOS,xt_CHAOS,xt_CHAOS,47,+kmod-ipt-compat-xt
|
|||||||
$(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
|
$(eval $(call BuildTemplate,condition,Condition,xt_condition,xt_condition,46,))
|
||||||
$(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
|
$(eval $(call BuildTemplate,delude,DELUDE,xt_DELUDE,xt_DELUDE,46,+kmod-ipt-compat-xtables))
|
||||||
$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
|
$(eval $(call BuildTemplate,tarpit,TARPIT,xt_TARPIT,xt_TARPIT,46,+kmod-ipt-compat-xtables))
|
||||||
#$(eval $(call BuildTemplate,tee,TEE,xt_TEE,xt_TEE,46,+kmod-ipt-compat-xtables))
|
|
||||||
$(eval $(call BuildTemplate,ipp2p,IPP2P,xt_ipp2p,xt_ipp2p,46,))
|
$(eval $(call BuildTemplate,ipp2p,IPP2P,xt_ipp2p,xt_ipp2p,46,))
|
||||||
$(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost $(if $(CONFIG_IPV6),ip6table_rawpost),50,+kmod-ipt-compat-xtables))
|
$(eval $(call BuildTemplate,rawpost,RAWPOST,,iptable_rawpost $(if $(CONFIG_IPV6),ip6table_rawpost),50,+kmod-ipt-compat-xtables))
|
||||||
$(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,46,+kmod-ipt-compat-xtables))
|
$(eval $(call BuildTemplate,rawnat,RAWNAT,xt_RAWDNAT xt_RAWSNAT,xt_RAWNAT,46,+kmod-ipt-compat-xtables))
|
||||||
|
@ -1,22 +1,22 @@
|
|||||||
--- a/configure
|
--- a/configure
|
||||||
+++ b/configure
|
+++ b/configure
|
||||||
@@ -10811,7 +10811,7 @@ if grep -q "CentOS release 5\." /etc/red
|
@@ -11693,7 +11693,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
||||||
fi;
|
if test -n "$kbuilddir"; then
|
||||||
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking kernel version that we will build against" >&5
|
||||||
$as_echo_n "checking kernel version that we will build against... " >&6; }
|
$as_echo_n "checking kernel version that we will build against... " >&6; }
|
||||||
-krel="$(make -sC ${kbuilddir} kernelrelease)";
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
||||||
+krel="$(make -sC ${kbuilddir} kernelversion)";
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
||||||
krel="${krel%%-*}";
|
kmajor="${krel%%[^0-9]*}";
|
||||||
kmajor="${krel%%.*}";
|
kmajor="$(($kmajor+0))";
|
||||||
krel="${krel#*.}";
|
krel="${krel:${#kmajor}}";
|
||||||
--- a/configure.ac
|
--- a/configure.ac
|
||||||
+++ b/configure.ac
|
+++ b/configure.ac
|
||||||
@@ -49,7 +49,7 @@ if grep -q "CentOS release 5\." /etc/red
|
@@ -44,7 +44,7 @@ regular_CFLAGS="-Wall -Waggregate-return
|
||||||
echo "WARNING: This distribution's shipped kernel is not supported.";
|
|
||||||
fi;
|
if test -n "$kbuilddir"; then
|
||||||
AC_MSG_CHECKING([kernel version that we will build against])
|
AC_MSG_CHECKING([kernel version that we will build against])
|
||||||
-krel="$(make -sC ${kbuilddir} kernelrelease)";
|
- krel="$(make -sC "$kbuilddir" M=$PWD kernelrelease)";
|
||||||
+krel="$(make -sC ${kbuilddir} kernelversion)";
|
+ krel="$(make -sC "$kbuilddir" M=$PWD kernelversion)";
|
||||||
krel="${krel%%-*}";
|
kmajor="${krel%%[[^0-9]]*}";
|
||||||
kmajor="${krel%%.*}";
|
kmajor="$(($kmajor+0))";
|
||||||
krel="${krel#*.}";
|
krel="${krel:${#kmajor}}";
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/configure.ac 2010-11-05 19:42:22.000000000 +0100
|
--- a/configure.ac
|
||||||
+++ b/configure.ac 2011-01-08 17:36:12.000000000 +0100
|
+++ b/configure.ac
|
||||||
@@ -28,7 +28,7 @@
|
@@ -31,7 +31,7 @@ PKG_CHECK_MODULES([libmnl], [libmnl >= 1
|
||||||
|
|
||||||
AC_ARG_WITH([xtlibdir],
|
AC_ARG_WITH([xtlibdir],
|
||||||
AS_HELP_STRING([--with-xtlibdir=PATH],
|
AS_HELP_STRING([--with-xtlibdir=PATH],
|
||||||
|
@ -1315,7 +1315,7 @@
|
|||||||
+module_exit(fini);
|
+module_exit(fini);
|
||||||
--- a/extensions/Kbuild
|
--- a/extensions/Kbuild
|
||||||
+++ b/extensions/Kbuild
|
+++ b/extensions/Kbuild
|
||||||
@@ -33,6 +33,7 @@ obj-${build_lscan} += xt_lscan.o
|
@@ -34,6 +34,7 @@ obj-${build_lscan} += xt_lscan.o
|
||||||
obj-${build_pknock} += pknock/
|
obj-${build_pknock} += pknock/
|
||||||
obj-${build_psd} += xt_psd.o
|
obj-${build_psd} += xt_psd.o
|
||||||
obj-${build_quota2} += xt_quota2.o
|
obj-${build_quota2} += xt_quota2.o
|
||||||
@ -1325,7 +1325,7 @@
|
|||||||
-include ${M}/Kbuild.*
|
-include ${M}/Kbuild.*
|
||||||
--- a/mconfig
|
--- a/mconfig
|
||||||
+++ b/mconfig
|
+++ b/mconfig
|
||||||
@@ -26,3 +26,4 @@ build_lscan=m
|
@@ -27,3 +27,4 @@ build_lscan=m
|
||||||
build_pknock=m
|
build_pknock=m
|
||||||
build_psd=m
|
build_psd=m
|
||||||
build_quota2=m
|
build_quota2=m
|
||||||
|
Loading…
x
Reference in New Issue
Block a user