lttng-tools: moved to github
Signed-off-by: Nicolas Thill <nico@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@44326 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c95e44d17d
commit
02ae331977
@ -1,47 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=lttng-tools
|
|
||||||
PKG_VERSION:=2.1.0
|
|
||||||
PKG_RELEASE:=1
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
|
||||||
PKG_SOURCE_URL:=https://lttng.org/files/$(PKG_NAME)
|
|
||||||
PKG_MD5SUM:=cfc35db9eb2d4ae09a65c006a70204f6
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
|
|
||||||
PKG_USE_MIPS16:=0
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/lttng-tools
|
|
||||||
SECTION:=devel
|
|
||||||
CATEGORY:=Development
|
|
||||||
DEPENDS:=+lttng-ust +libpopt
|
|
||||||
TITLE:=LTTng tracing tools
|
|
||||||
URL:=https://lttng.org/
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_LDFLAGS += -lurcu-bp
|
|
||||||
|
|
||||||
define Package/lttng-tools/description
|
|
||||||
LTTng Userspace Tracing Library
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/lttng-tools/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/liblttng-ctl.so.* $(1)/usr/lib/
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lttng $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/lttng* $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,lttng-tools))
|
|
@ -1,44 +0,0 @@
|
|||||||
Make sync_file_range() usage optional
|
|
||||||
|
|
||||||
Under uClibc, sync_file_range() is not available under all
|
|
||||||
architectures, so we fall back to fdatasync() in this case.
|
|
||||||
|
|
||||||
Inspired by the patch done by Thomas Petazzoni for the
|
|
||||||
2.0-pre25 version.
|
|
||||||
|
|
||||||
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
||||||
---
|
|
||||||
configure.ac | 2 +-
|
|
||||||
src/common/compat/fcntl.h | 5 +++++
|
|
||||||
2 files changed, 6 insertions(+), 1 deletion(-)
|
|
||||||
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -150,7 +150,7 @@ AS_IF([test "x$lttng_ust_support" = "xye
|
|
||||||
)
|
|
||||||
])
|
|
||||||
AM_CONDITIONAL([HAVE_LIBLTTNG_UST_CTL], [test "x$lttng_ust_ctl_found" = xyes])
|
|
||||||
-AC_CHECK_FUNCS([sched_getcpu sysconf])
|
|
||||||
+AC_CHECK_FUNCS([sched_getcpu sysconf sync_file_range])
|
|
||||||
|
|
||||||
# check for dlopen
|
|
||||||
AC_CHECK_LIB([dl], [dlopen],
|
|
||||||
@@ -394,4 +394,3 @@ AS_IF([test "x$consumerd_only" = "xno"],
|
|
||||||
])
|
|
||||||
|
|
||||||
AS_ECHO()
|
|
||||||
-
|
|
||||||
--- a/src/common/compat/compat-fcntl.c
|
|
||||||
+++ b/src/common/compat/compat-fcntl.c
|
|
||||||
@@ -23,7 +23,11 @@
|
|
||||||
int compat_sync_file_range(int fd, off64_t offset, off64_t nbytes,
|
|
||||||
unsigned int flags)
|
|
||||||
{
|
|
||||||
+#ifdef HAVE_SYNC_FILE_RANGE
|
|
||||||
return sync_file_range(fd, offset, nbytes, flags);
|
|
||||||
+#else
|
|
||||||
+ return fdatasync(fd);
|
|
||||||
+#endif
|
|
||||||
}
|
|
||||||
|
|
||||||
#endif /* __linux__ */
|
|
Loading…
x
Reference in New Issue
Block a user