[package] add netio bandwidth measurement tool (#8668)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@33045 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
582b2e3011
commit
035b8eda21
4
net/netio/Config.in
Normal file
4
net/netio/Config.in
Normal file
@ -0,0 +1,4 @@
|
||||
menu "Configuration"
|
||||
depends on PACKAGE_uclibcxx
|
||||
|
||||
endmenu
|
41
net/netio/Makefile
Normal file
41
net/netio/Makefile
Normal file
@ -0,0 +1,41 @@
|
||||
#
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=netio
|
||||
PKG_VERSION:=1.31
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)$(subst .,,$(PKG_VERSION)).zip
|
||||
PKG_SOURCE_URL:=http://www.ars.de/ars/ars.nsf/f24a6a0b94c22d82862566960071bf5a/aa577bc4be573b05c125706d004c75b5/%24FILE/
|
||||
PKG_MD5SUM:=6b81e3c71b9dfa3bd60c53fa82e89085
|
||||
|
||||
include $(INCLUDE_DIR)/uclibc++.mk
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
PKG_UNPACK:=mkdir -p $(PKG_BUILD_DIR); unzip $(DL_DIR)/$(PKG_SOURCE) -d $(PKG_BUILD_DIR)
|
||||
|
||||
define Package/netio
|
||||
$(call Package/netio/Default)
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=$(CXX_DEPENDS) +libpthread
|
||||
TITLE:=Network throughput benchmark
|
||||
URL:=http://www.ars.de/ars/ars.nsf/docs/netio
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) linux CC="$(TARGET_CC)"
|
||||
endef
|
||||
|
||||
define Package/netio/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,netio))
|
11
net/netio/patches/001-Makefile.patch
Normal file
11
net/netio/patches/001-Makefile.patch
Normal file
@ -0,0 +1,11 @@
|
||||
--- a/Makefile 2011-01-17 17:15:11.000000000 +0100
|
||||
+++ b/Makefile 2010-10-14 15:03:42.000000000 +0200
|
||||
@@ -84,7 +84,7 @@
|
||||
$(MAKE) all CC="gcc -O -s" O=.o X= \
|
||||
CFLAGS="-DUNIX" LFLAGS="" LIBS="-lsocket -lpthread -lnsl" OUT=-o
|
||||
linux:
|
||||
- $(MAKE) all CC="gcc -O -s" O=.o X= \
|
||||
+ $(MAKE) all CC="$(CC) -O -s" O=.o X= \
|
||||
CFLAGS="-DUNIX" LFLAGS="" LIBS="-lpthread" OUT=-o
|
||||
macosx:
|
||||
$(MAKE) all CC="gcc -O" O=.o X= \
|
Loading…
x
Reference in New Issue
Block a user