rrs:
* Fix menu * Cleanup Makefile * Refresh patches git-svn-id: svn://svn.openwrt.org/openwrt/packages@8224 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
863819e657
commit
03be4444dd
@ -10,32 +10,31 @@ include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rrs
|
||||
PKG_VERSION:=1.70
|
||||
PKG_RELEASE:=1
|
||||
PKG_RELEASE:=2
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.cycom.se/uploads/36/19
|
||||
PKG_MD5SUM:=b400d03c0e39e3e78a7327ba78f789f0
|
||||
PKG_CAT:=zcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/rrs/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+uclibcxx
|
||||
MENU:=1
|
||||
TITLE:=A reverse (connecting) remote shell
|
||||
URL:=http://www.cycom.se/dl/rrs/
|
||||
endef
|
||||
|
||||
define Package/rrs
|
||||
$(call Package/rrs/Default)
|
||||
DEPENDS+= +libopenssl
|
||||
DEPENDS:=+uclibcxx
|
||||
TITLE+= (with SSL support)
|
||||
endef
|
||||
|
||||
define Package/rrs-nossl
|
||||
$(call Package/rrs/Default)
|
||||
DEPENDS:=rrs
|
||||
TITLE+= (without SSL support)
|
||||
endef
|
||||
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruN rrs-1.70-old/rrs.c rrs-1.70-new/rrs.c
|
||||
--- rrs-1.70-old/rrs.c 2004-05-30 02:32:03.000000000 +0200
|
||||
+++ rrs-1.70-new/rrs.c 2005-10-12 12:41:24.000000000 +0200
|
||||
Index: rrs-1.70/rrs.c
|
||||
===================================================================
|
||||
--- rrs-1.70.orig/rrs.c 2007-07-30 14:30:24.000000000 +0200
|
||||
+++ rrs-1.70/rrs.c 2007-07-30 14:30:24.000000000 +0200
|
||||
@@ -920,7 +920,7 @@
|
||||
close(slave_fd);
|
||||
signal(SIGHUP, SIG_DFL);
|
||||
|
@ -1,6 +1,7 @@
|
||||
diff -ruN rrs-1.70-old/rrs.c rrs-1.70-new/rrs.c
|
||||
--- rrs-1.70-old/rrs.c 2006-12-18 11:41:42.000000000 +0100
|
||||
+++ rrs-1.70-new/rrs.c 2006-12-18 11:53:43.000000000 +0100
|
||||
Index: rrs-1.70/rrs.c
|
||||
===================================================================
|
||||
--- rrs-1.70.orig/rrs.c 2007-07-30 14:30:24.000000000 +0200
|
||||
+++ rrs-1.70/rrs.c 2007-07-30 14:30:25.000000000 +0200
|
||||
@@ -1826,9 +1826,12 @@
|
||||
}
|
||||
rrs_ssl = TLSv1;
|
||||
|
Loading…
x
Reference in New Issue
Block a user