[packages] dsniff: fix build

Signed-off-by: Peter Wagner <tripolar@gmx.at>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@38710 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
tripolar 2013-11-10 18:18:14 +00:00
parent 1e99bc0eaa
commit 04af3ac897
2 changed files with 14 additions and 2 deletions

View File

@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=dsniff PKG_NAME:=dsniff
PKG_VERSION:=2.4b1 PKG_VERSION:=2.4b1
PKG_RELEASE:=2 PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta PKG_SOURCE_URL:=http://www.monkey.org/~dugsong/dsniff/beta
@ -22,7 +22,7 @@ include $(INCLUDE_DIR)/package.mk
define Package/dsniff define Package/dsniff
SECTION:=net SECTION:=net
CATEGORY:=Network CATEGORY:=Network
DEPENDS:=+libpcap +libnids +libnet0 +libopenssl +libgdbm $(LIBRPC_DEPENDS) @BROKEN DEPENDS:=+libpcap +libnids +libnet1 +libopenssl +libgdbm $(LIBRPC_DEPENDS)
TITLE:=A collection of tools for network auditing and penetration testing TITLE:=A collection of tools for network auditing and penetration testing
URL:=http://www.monkey.org/~dugsong/dsniff/ URL:=http://www.monkey.org/~dugsong/dsniff/
endef endef

View File

@ -0,0 +1,12 @@
diff --git a/nfs_prot.x b/nfs_prot.x
index 1111dcc..f7392eb 100644
--- a/nfs_prot.x
+++ b/nfs_prot.x
@@ -193,7 +193,6 @@ const NFS3_WRITEVERFSIZE = 8;
typedef u_int64_t uint64;
typedef int64_t int64;
typedef unsigned int uint32;
-typedef int int32;
typedef string filename3<>;
typedef string nfspath3<>;
typedef uint64 fileid3;