[package] minidlna: update to 1.0.21

010-genconfig-checks.patch adjusts two configure checks to use ICONV_PREFIX and INTL_PREFIX. These changes were already made previously elsewhere in the build process and looks like it was just overlooked here.

040-configuration-tweak.patch was to rebase.

Minidlna's changes were primarily bug fixes and compatibility with newer ffmpeg.

Signed-off-by: Ian Leonard <antonlacon@gmail.com>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@28031 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2011-08-17 10:13:21 +00:00
parent 89475e5d61
commit 0554fbc984
3 changed files with 22 additions and 4 deletions

View File

@ -1,4 +1,4 @@
#
#
# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=minidlna
PKG_VERSION:=1.0.20
PKG_VERSION:=1.0.21
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)_$(PKG_VERSION)_src.tar.gz
PKG_SOURCE_URL:=@SF/minidlna
PKG_MD5SUM:=1c5230cc6dec7592eca4c63c526eadb7
PKG_MD5SUM:=a53e0008ad225843a1782e4af6e5bf0b
PKG_BUILD_PARALLEL:=0

View File

@ -39,3 +39,21 @@
if [ -n "$MISSING" ]; then
echo -e "\nERROR! Cannot continue."
echo -e "The following required libraries are either missing, or are missing development headers:\n"
@@ -184,7 +184,7 @@ fi
echo "" >> ${CONFIGFILE}
echo "/* Enable if the system iconv.h exists. ID3 tag reading in various character sets will not work properly otherwise. */" >> ${CONFIGFILE}
-if [ -f /usr/include/iconv.h ]; then
+if [ -f ${ICONV_PREFIX}/include/iconv.h ]; then
echo "#define HAVE_ICONV_H" >> ${CONFIGFILE}
else
echo -e "\nWARNING!! Iconv support not found. ID3 tag reading may not work."
@@ -193,7 +193,7 @@ fi
echo "" >> ${CONFIGFILE}
echo "/* Enable if the system libintl.h exists for NLS support. */" >> ${CONFIGFILE}
-if [ -f /usr/include/libintl.h ]; then
+if [ -f ${INTL_PREFIX}/include/libintl.h ]; then
echo "#define ENABLE_NLS" >> ${CONFIGFILE}
else
echo "/*#define ENABLE_NLS*/" >> ${CONFIGFILE}

View File

@ -3,7 +3,7 @@
@@ -2,7 +2,7 @@
port=8200
# network interface to bind to (this is the only interface that will serve files)
# network interfaces to serve, comma delimited
-#network_interface=eth0
+network_interface=br-lan