package haproxy: fix gcc 4.7 warning

git-svn-id: svn://svn.openwrt.org/openwrt/packages@39172 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
heil 2013-12-27 23:37:51 +00:00
parent 68da3fd839
commit 05749252d4
2 changed files with 34 additions and 1 deletions

View File

@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=haproxy
PKG_VERSION:=1.4.24
PKG_RELEASE:=10
PKG_RELEASE:=11
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://haproxy.1wt.eu/download/1.4/src

View File

@ -0,0 +1,33 @@
From 3b6ebfec1b72148c9628525f6ebe2e6d184960b1 Mon Sep 17 00:00:00 2001
From: Willy Tarreau <w@1wt.eu>
Date: Fri, 6 Dec 2013 22:20:57 +0100
Subject: [PATCH 11/11] BUILD: proto_tcp: remove a harmless warning
The "pol" variable was not used and gcc 4.7 emits a warning on it.
---
src/proto_tcp.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/src/proto_tcp.c b/src/proto_tcp.c
index 0158a02..d279669 100644
--- a/src/proto_tcp.c
+++ b/src/proto_tcp.c
@@ -870,7 +870,6 @@ static int tcp_parse_tcp_req(char **args, int section_type, struct proxy *curpx,
if (!strcmp(args[1], "content")) {
int action;
int warn = 0;
- int pol = ACL_COND_NONE;
struct acl_cond *cond;
struct tcp_rule *rule;
@@ -891,7 +890,6 @@ static int tcp_parse_tcp_req(char **args, int section_type, struct proxy *curpx,
return -1;
}
- pol = ACL_COND_NONE;
cond = NULL;
if (strcmp(args[3], "if") == 0 || strcmp(args[3], "unless") == 0) {
--
1.8.1.5