chaosvpn: moved to github

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@47525 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
hauke 2015-11-19 20:52:25 +00:00
parent 7b9328fdd5
commit 063f7e3f0e
5 changed files with 0 additions and 116 deletions

View File

@ -1,48 +0,0 @@
#
# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=chaosvpn
PKG_VERSION:=2.0
PKG_RELEASE:=3
PKG_SOURCE:=${PKG_NAME}-${PKG_VERSION}.tar.gz
PKG_SOURCE_URL:=http://github.com/downloads/ryd/chaosvpn/
PKG_MD5SUM:=4263202d65bf4ab0d1356b149d7c53af
include $(INCLUDE_DIR)/package.mk
define Package/chaosvpn
SECTION:=net
CATEGORY:=Network
TITLE:=Config generator for chaos vpn
SUBMENU:=VPN
DEPENDS:=+ip +tinc +kmod-tun +libopenssl
URL:=https://wiki.hamburg.ccc.de/index.php/ChaosVPN::DebianHowto
MAINTAINER:=Christopher J. Pilkington <cjp@0x1.net>
endef
define Package/chaosvpn/description
Configure tincd for the chaosvpn network
endef
MAKE_FLAGS += \
COPT="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(TARGET_LDFLAGS)"
define Package/chaosvpn/install
$(INSTALL_DIR) $(1)/etc/tinc/chaos/ $(1)/usr/sbin/ $(1)/etc/init.d/ $(1)/etc/hotplug.d/iface/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/chaosvpn $(1)/usr/sbin/
#$(INSTALL_DATA) $(PKG_BUILD_DIR)/chaosvpn.conf $(1)/etc/tinc/
sed -e 's/"\/sbin\/ip /"\/usr\/sbin\/ip /' <$(PKG_BUILD_DIR)/chaosvpn.conf >$(1)/etc/tinc/chaosvpn.conf
$(INSTALL_BIN) ./files/chaosvpn_config.sh $(1)/usr/sbin/
$(INSTALL_BIN) ./files/chaosvpn.init $(1)/etc/init.d/chaosvpn
$(INSTALL_BIN) ./files/chaosvpn.hotplug $(1)/etc/hotplug.d/iface/40-chaosvpn
endef
$(eval $(call BuildPackage,chaosvpn))

View File

@ -1,3 +0,0 @@
[ "$INTERFACE" == "wan" ] || return
[ "$ACTION" == "ifup" ] && /etc/init.d/chaosvpn restart

View File

@ -1,21 +0,0 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2010-2011 OpenWrt.org
START=99
SERVICE_DAEMONIZE=1
start()
{
/usr/sbin/chaosvpn_config.sh
[ $? = 0 ] || {
logger "not starting chaosvpn, check your config"
exit 1
}
service_start /usr/sbin/chaosvpn -f -c /etc/tinc/chaosvpn.conf
}
stop()
{
service_stop /usr/sbin/chaosvpn
}

View File

@ -1,14 +0,0 @@
#!/bin/sh
[ -f "/etc/tinc/chaos/rsa_key.pub" -a -f "/etc/tinc/chaos/rsa_key.priv" ] || {
echo "please generate rsa key pair"
echo "tincd -n chaos --generate-keys=2048"
exit 1
}
C=`grep unconfigured_please_change_me /etc/tinc/chaosvpn.conf | wc -l`
[ "$C" = "0" ] || {
echo "/etc/tinc/chaosvpn.conf is not configured yet"
exit 1
}
exit 0

View File

@ -1,30 +0,0 @@
--- a/Makefile 2010-07-17 14:20:07.000000000 -0400
+++ b/Makefile 2010-07-17 18:50:30.000000000 -0400
@@ -1,10 +1,7 @@
-CC?=gcc
-INCLUDES?=-I/usr/local/include
-LIBDIRS?=-L/usr/local/lib
-CFLAGS?=-std=c99 -D_POSIX_C_SOURCE=2 -D_BSD_SOURCE -D_FILE_OFFSET_BITS=64 -O2 -Wall -g $(INCLUDES)
-LIB?=-lz -lcrypto
-LEX?=flex
-YACC?=yacc
+CC := gcc
+LIBS := -lssl -lz -lcrypto
+LEX := flex
+YACC := yacc
PREFIX?=/usr
TINCDIR?=/etc/tinc
@@ -21,10 +18,10 @@
GITDEBVERSION=$(shell debian/scripts/calcdebversion )
$(NAME): main.o $(OBJ) $(HEADERS)
- $(CC) -o $@ main.o $(OBJ) $(LIB) $(LIBDIRS)
+ $(CC) $(COPT) -o $@ main.o $(OBJ) $(LIBS) $(LIB)
%.o: %.c $(HEADERS)
- $(CC) $(CFLAGS) -o $(patsubst %.c,%.o,$<) -c $<
+ $(CC) $(COPT) -o $(patsubst %.c,%.o,$<) -c $<
lex.yy.o: lex.yy.c y.tab.h