update to RC4

git-svn-id: svn://svn.openwrt.org/openwrt/packages@7060 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
thepeople 2007-04-26 22:41:26 +00:00
parent ba0f4f5211
commit 06471aaab8
3 changed files with 38 additions and 12 deletions

View File

@ -9,9 +9,9 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=miniupnpd PKG_NAME:=miniupnpd
PKG_VERSION:=1.0-RC3 PKG_VERSION:=1.0-RC4
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_MD5SUM:=4aa5e9d6281bbec5b8dd0b386f35a153 PKG_MD5SUM:=de6fd266bf15c4f6781895d19c8efbca
PKG_SOURCE_URL:=http://miniupnp.tuxfamily.org/files PKG_SOURCE_URL:=http://miniupnp.tuxfamily.org/files
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz

View File

@ -1,15 +1,15 @@
diff -ur miniupnpd.old/Makefile.openwrt miniupnpd.dev/Makefile.openwrt --- miniupnpd-1.0-RC4/Makefile.openwrt.orig 2007-04-26 14:46:51.000000000 -0500
--- miniupnpd.old/Makefile.openwrt 2007-03-24 18:44:00.062407944 +0100 +++ miniupnpd-1.0-RC4/Makefile.openwrt 2007-04-26 14:52:55.000000000 -0500
+++ miniupnpd.dev/Makefile.openwrt 2007-03-24 18:43:43.659901504 +0100 @@ -2,7 +2,7 @@
@@ -2,7 +2,6 @@
# http://miniupnp.free.fr/ # http://miniupnp.free.fr/
# Author : Thomas Bernard # Author : Thomas Bernard
# for use with GNU Make # for use with GNU Make
-include $(TOPDIR)/rules.mk -include $(TOPDIR)/rules.mk
+
#CFLAGS = -Wall -O -D_GNU_SOURCE -g #CFLAGS = -Wall -O -D_GNU_SOURCE -g
#CFLAGS = -Wall -Os -D_GNU_SOURCE #CFLAGS = -Wall -Os -D_GNU_SOURCE
#CC = mipsel-linux-gcc #CC = mipsel-linux-gcc
@@ -11,17 +10,15 @@ @@ -11,7 +11,7 @@
CFLAGS += -D_GNU_SOURCE CFLAGS += -D_GNU_SOURCE
RM = rm -f RM = rm -f
INSTALL = install INSTALL = install
@ -18,9 +18,7 @@ diff -ur miniupnpd.old/Makefile.openwrt miniupnpd.dev/Makefile.openwrt
BASEOBJS = miniupnpd.o upnphttp.o upnpdescgen.o upnpsoap.o \ BASEOBJS = miniupnpd.o upnphttp.o upnpdescgen.o upnpsoap.o \
upnpreplyparse.o minixml.o \ upnpreplyparse.o minixml.o \
upnpredirect.o getifaddr.o daemonize.o upnpglobalvars.o \ @@ -20,8 +20,6 @@
- options.o
+ options.o upnppermissions.o
LNXOBJS = linux/getifstats.o linux/iptcrdr.o LNXOBJS = linux/getifstats.o linux/iptcrdr.o
@ -29,7 +27,7 @@ diff -ur miniupnpd.old/Makefile.openwrt miniupnpd.dev/Makefile.openwrt
TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o TESTUPNPDESCGENOBJS = testupnpdescgen.o upnpdescgen.o
EXECUTABLES = miniupnpd testupnpdescgen EXECUTABLES = miniupnpd testupnpdescgen
@@ -38,6 +35,7 @@ @@ -38,6 +36,7 @@
@echo no install for now... @echo no install for now...
miniupnpd: $(BASEOBJS) $(LNXOBJS) $(LIBS) miniupnpd: $(BASEOBJS) $(LNXOBJS) $(LIBS)
@ -37,7 +35,19 @@ diff -ur miniupnpd.old/Makefile.openwrt miniupnpd.dev/Makefile.openwrt
testupnpdescgen: $(TESTUPNPDESCGENOBJS) testupnpdescgen: $(TESTUPNPDESCGENOBJS)
@@ -69,3 +67,4 @@ @@ -59,13 +58,14 @@
upnphttp.o: upnphttp.h upnpdescgen.h miniupnpdpath.h upnpsoap.h
upnpdescgen.o: upnpdescgen.h miniupnpdpath.h upnpglobalvars.h
upnpsoap.o: upnpglobalvars.h upnphttp.h upnpsoap.h upnpreplyparse.h
-upnpsoap.o: upnpredirect.h openbsd/getifstats.h
+upnpsoap.o: upnpredirect.h getifstats.h
upnpreplyparse.o: upnpreplyparse.h minixml.h
minixml.o: minixml.h
upnpredirect.o: upnpredirect.h upnpglobalvars.h openbsd/obsdrdr.h
daemonize.o: daemonize.h
upnpglobalvars.o: upnpglobalvars.h
-linux/getifstats.o: openbsd/getifstats.h
+linux/getifstats.o: getifstats.h
linux/iptcrdr.o: linux/iptcrdr.h linux/iptcrdr.o: linux/iptcrdr.h
testupnpdescgen.o: upnpdescgen.h testupnpdescgen.o: upnpdescgen.h
upnpdescgen.o: upnpdescgen.h miniupnpdpath.h upnpglobalvars.h upnpdescgen.o: upnpdescgen.h miniupnpdpath.h upnpglobalvars.h

View File

@ -0,0 +1,16 @@
--- miniupnpd-1.0-RC4/config.h.openwrt.orig 2006-12-02 09:25:26.000000000 -0600
+++ miniupnpd-1.0-RC4/config.h.openwrt 2007-04-26 14:20:19.000000000 -0500
@@ -5,9 +5,13 @@
#ifndef __CONFIG_H__
#define __CONFIG_H__
+#define UPNP_VERSION "20070228"
+
#define OS_NAME "OpenWRT"
/* OS/version */
#define OS_VERSION "OpenWRT/WhiteRussian"
#define OS_URL "http://openwrt.org/"
+#define LOG_MINIUPNPD LOG_DAEMON
+
#endif