add mdadm package
git-svn-id: svn://svn.openwrt.org/openwrt/packages@13309 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
fb7e092155
commit
066815916c
43
utils/mdadm/Makefile
Normal file
43
utils/mdadm/Makefile
Normal file
@ -0,0 +1,43 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2008 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=mdadm
|
||||||
|
PKG_VERSION:=2.6.7.2
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
PKG_MD5SUM:=e4badb4a8ded4344ba0fa785883955d8
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
|
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/mdadm
|
||||||
|
SECTION:=utils
|
||||||
|
CATEGORY:=Utilities
|
||||||
|
TITLE:=A tool for managing Soft RAID under Linux
|
||||||
|
URL:=http://www.kernel.org/pub/linux/utils/raid/mdadm/
|
||||||
|
DEPENDS:=@LINUX_2_6
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
CC="$(TARGET_CC)" \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS) -DUCLIBC -DHAVE_STDINT_H" \
|
||||||
|
LDFLAGS="$(TARGET_LDFLAGS)" \
|
||||||
|
mdadm mdassemble
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/mdadm/install
|
||||||
|
$(INSTALL_DIR) $(1)/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mdadm $(1)/sbin
|
||||||
|
$(INSTALL_BIN) $(PKG_BUILD_DIR)/mdassemble $(1)/sbin
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,mdadm))
|
24
utils/mdadm/patches/001-makefile-fixes.patch
Normal file
24
utils/mdadm/patches/001-makefile-fixes.patch
Normal file
@ -0,0 +1,24 @@
|
|||||||
|
Only in mdadm-2.6.7.2: .prepared_52c8003c1cfc25b1e96897208f1a6856
|
||||||
|
Only in mdadm-2.6.7.2.orig/: .prepared_b70de0be5a277506820fdcd9a21e9deb
|
||||||
|
diff -ur mdadm-2.6.7.2.orig/Makefile mdadm-2.6.7.2/Makefile
|
||||||
|
--- mdadm-2.6.7.2.orig/Makefile 2008-11-21 18:21:35.000000000 +0100
|
||||||
|
+++ mdadm-2.6.7.2/Makefile 2008-11-21 19:13:54.000000000 +0100
|
||||||
|
@@ -52,7 +52,7 @@
|
||||||
|
CONFFILE2 = $(SYSCONFDIR)/mdadm/mdadm.conf
|
||||||
|
MAILCMD =/usr/sbin/sendmail -t
|
||||||
|
CONFFILEFLAGS = -DCONFFILE=\"$(CONFFILE)\" -DCONFFILE2=\"$(CONFFILE2)\"
|
||||||
|
-CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS)
|
||||||
|
+#CFLAGS = $(CWFLAGS) $(CXFLAGS) -DSendmail=\""$(MAILCMD)"\" $(CONFFILEFLAGS)
|
||||||
|
|
||||||
|
# If you want a static binary, you might uncomment these
|
||||||
|
# LDFLAGS = -static
|
||||||
|
@@ -124,7 +124,7 @@
|
||||||
|
|
||||||
|
mdassemble : $(ASSEMBLE_SRCS) mdadm.h
|
||||||
|
rm -f $(OBJS)
|
||||||
|
- $(DIET_GCC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
+ $(CC) $(ASSEMBLE_FLAGS) -o mdassemble $(ASSEMBLE_SRCS) $(STATICSRC)
|
||||||
|
|
||||||
|
mdassemble.static : $(ASSEMBLE_SRCS) mdadm.h
|
||||||
|
rm -f $(OBJS)
|
||||||
|
Only in mdadm-2.6.7.2: mdadm
|
Loading…
x
Reference in New Issue
Block a user