[patchteam] This patch bumps the sslh package to v1.10. - Signed-off by: Jonathan McCrohan <jmccrohan@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29428 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
aa5e8d5763
commit
06f53405a3
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=sslh
|
PKG_NAME:=sslh
|
||||||
PKG_VERSION:=1.9
|
PKG_VERSION:=1.10
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://rutschle.net/tech/
|
PKG_SOURCE_URL:=http://rutschle.net/tech/
|
||||||
PKG_MD5SUM:=1c0193853ef35f80e3e4b1a744832cd1
|
PKG_MD5SUM:=bc34e9a4770d634633e70589c72708cc
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
@ -19,6 +19,9 @@ config 'sslh' 'default'
|
|||||||
# tinc defaults to 'localhost:655'
|
# tinc defaults to 'localhost:655'
|
||||||
# --tinc <tinchost>:<tincport>
|
# --tinc <tinchost>:<tincport>
|
||||||
option 'tinc' ''
|
option 'tinc' ''
|
||||||
|
# xmpp defaults to 'localhost:5222'
|
||||||
|
# --xmpp <xmpphost>:<xmppport>
|
||||||
|
option 'xmpp' ''
|
||||||
# timeout (for ssh, then ssl is assumed) defaults to 2
|
# timeout (for ssh, then ssl is assumed) defaults to 2
|
||||||
# -t
|
# -t
|
||||||
option 'timeout' ''
|
option 'timeout' ''
|
||||||
|
@ -31,10 +31,13 @@ start_instance() {
|
|||||||
# E) tinc parameter
|
# E) tinc parameter
|
||||||
config_get val "${section}" tinc
|
config_get val "${section}" tinc
|
||||||
[ -n "${val}" ] && append args "--tinc ${val}"
|
[ -n "${val}" ] && append args "--tinc ${val}"
|
||||||
# F) timeout (before a connection is considered to be SSH)
|
# F) xmpp parameter
|
||||||
|
config_get val "${section}" xmpp
|
||||||
|
[ -n "${val}" ] && append args "--xmpp ${val}"
|
||||||
|
# G) timeout (before a connection is considered to be SSH)
|
||||||
config_get val "${section}" timeout
|
config_get val "${section}" timeout
|
||||||
[ -n "${val}" ] && append args "-t ${val}"
|
[ -n "${val}" ] && append args "-t ${val}"
|
||||||
# G) verbose parameter
|
# H) verbose parameter
|
||||||
local verbosed
|
local verbosed
|
||||||
config_get_bool verbosed "${section}" verbose 0
|
config_get_bool verbosed "${section}" verbose 0
|
||||||
[ "${verbosed}" -ne 0 ] && append args "-v"
|
[ "${verbosed}" -ne 0 ] && append args "-v"
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -27,16 +27,12 @@
|
@@ -32,16 +32,12 @@ all: sslh $(MAN) echosrv
|
||||||
$(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -c $<
|
$(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -c $<
|
||||||
|
|
||||||
|
|
||||||
@ -9,21 +9,21 @@
|
|||||||
|
|
||||||
sslh-fork: $(OBJS) sslh-fork.o Makefile common.h
|
sslh-fork: $(OBJS) sslh-fork.o Makefile common.h
|
||||||
$(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
|
$(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -o sslh-fork sslh-fork.o $(OBJS) $(LIBS)
|
||||||
strip sslh-fork
|
#strip sslh-fork
|
||||||
|
|
||||||
-sslh-select: $(OBJS) sslh-select.o Makefile common.h
|
-sslh-select: $(OBJS) sslh-select.o Makefile common.h
|
||||||
- $(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -o sslh-select sslh-select.o $(OBJS) $(LIBS)
|
- $(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -o sslh-select sslh-select.o $(OBJS) $(LIBS)
|
||||||
- strip sslh-select
|
- #strip sslh-select
|
||||||
-
|
-
|
||||||
|
echosrv: $(OBJS) echosrv.o
|
||||||
|
$(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
|
||||||
|
|
||||||
$(MAN): sslh.pod Makefile
|
@@ -65,7 +61,7 @@ uninstall:
|
||||||
pod2man --section=8 --release=$(VERSION) --center=" " sslh.pod | gzip -9 - > $(MAN)
|
|
||||||
@@ -58,7 +54,7 @@
|
|
||||||
update-rc.d sslh remove
|
update-rc.d sslh remove
|
||||||
|
|
||||||
clean:
|
clean:
|
||||||
- rm -f sslh-fork sslh-select $(MAN) *.o
|
- rm -f sslh-fork sslh-select echosrv $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
|
||||||
+ rm -f sslh-fork $(MAN) *.o
|
+ rm -f sslh-fork echosrv $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
|
||||||
|
|
||||||
tags:
|
tags:
|
||||||
ctags -T *.[ch]
|
ctags -T *.[ch]
|
||||||
|
Loading…
x
Reference in New Issue
Block a user