[PATCH-v6] samba 3.0.37 update

Samba3 patch is updated again so it applies after the new serive function
update (#29075).
I just tested it on my router and everything (still) seems to work.
So please commit it.
Through all versions these things are added to the original package in the
repositories:

 * Updates samba3 package to version 3.0.37
 * Splits nmbd and mountcifs into separate packages
 * Added settings to remove printing support and to make smbd even smaller
 * Removed LDAP, Kerebos and AD support
 * Added iconv support

Signed-off-by: Maarten Bezemer <m.m.bezemer@utwente.nl>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29343 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2011-11-27 18:28:39 +00:00
parent f6702af6a1
commit 07234b4379
12 changed files with 1503 additions and 7152 deletions

View File

@ -1,4 +1,23 @@
config SAMBA3_DEBUG
config SAMBA3_CONFIG_DEBUG
bool "Enable Logging for samba3"
depends PACKAGE_samba3
default n
help
Enables debugging support (will make binaries *much* bigger)
Also increases MAX_DEBUG_LEVEL to get more messages (also increases binary sizes!)
config SAMBA3_CONFIG_SMALLER
bool "Make samba3 even smaller"
depends PACKAGE_samba3
default y
help
Removes support for ???
Saves about 18kB for smbd, about 16kB for nmbd and about 17kB for smbpasswd
config SAMBA3_CONFIG_NO_PRINTING
bool "Remove shared printing support"
depends PACKAGE_samba3
default y
help
Removes shared printing support.
Saves about 18kB for smbd, about 15kB for nmbd and about 18kB for smbpasswd

View File

@ -7,30 +7,60 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=samba3
PKG_VERSION:=3.0.24
PKG_RELEASE:=9
PKG_VERSION:=3.0.37
PKG_RELEASE:=1
PKG_MD5SUM:=89273f67a6d8067cbbecefaa13747153
PKG_MD5SUM:=11ed2bfef4090bd5736b194b43f67289
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/samba/old-versions/
PKG_SOURCE:=samba-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(BUILD_DIR)/samba-$(PKG_VERSION)/
PKG_BUILD_DIR:=$(BUILD_DIR)/samba-$(PKG_VERSION)
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/nls.mk
TARGET_CFLAGS+=$(if $(CONFIG_SAMBA3_DEBUG),-DSAMBA_DEBUG)
define Package/samba3
define Package/samba3/Default
SECTION:=net
CATEGORY:=Network
SUBMENU:=Filesystem
TITLE:=samba3
DEPENDS:=+libpthread
URL:=http://www.samba.org/
endef
define Package/samba3/Description
Samba3 - made small with patches taken from AVM GPL releases and freetz
define Package/samba3
$(call Package/samba3/Default)
TITLE:=SMB server for file and printer sharing
DEPENDS:=+libpthread +libpopt $(ICONV_DEPENDS)
endef
define Package/samba3-nmbd
$(call Package/samba3/Default)
TITLE:=NetBIOS name server
DEPENDS:=+samba3
endef
define Package/samba3-mountcifs
$(call Package/samba3/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE:=Mount utility for samba shares
endef
define Package/samba3/description
SMB server for file and printer sharing
Also contains a SMB password utility (smbpasswd)
Made small with patches taken from AVM GPL releases and freetz
endef
define Package/samba3-nmbd/description
NetBIOS name server
Made small with patches taken from AVM GPL releases and freetz
endef
define Package/cifsmount/description
An user space helper utility for mounting remote CIFS shares.
endef
define Package/samba3/conffiles
@ -42,31 +72,43 @@ define Package/samba3/config
source "$(SOURCE)/Config.in"
endef
define Build/Prepare/LFS
endef
TARGET_CFLAGS+=$(if $(CONFIG_SAMBA3_CONFIG_DEBUG),-DSAMBA_DEBUG,-DMAX_DEBUG_LEVEL=2)
TARGET_CFLAGS+=$(if $(CONFIG_SAMBA3_CONFIG_SMALLER),-DAVM_SMALLER)
TARGET_CFLAGS+=$(if $(CONFIG_SAMBA3_CONFIG_NO_PRINTING),-DAVM_NO_PRINTING)
CONFIGURE_PATH:=source
CONFIGURE_ARGS+= \
$(if $(CONFIG_SAMBA3_CONFIG_DEBUG),--enable-debug) \
--without-krb5 \
--without-ads \
--without-ldap \
--enable-largefile \
--with-configdir=/etc/samba \
--with-libiconv=$(ICONV_PREFIX) \
--with-privatedir=/etc/samba
define Build/Prepare
$(call Build/Prepare/Default)
endef
# Make sure we tell the configure script that we support negative enum values and want to use setresuid
CONFIGURE_VARS+= \
SMB_BUILD_CC_NEGATIVE_ENUM_VALUES=yes \
samba_cv_USE_SETEUID=no \
samba_cv_have_setresuid=yes \
samba_cv_USE_SETRESUID=yes \
samba_cv_HAVE_C99_VSNPRINTF=yes \
samba_cv_have_longlong=yes \
ac_cv_type_long_long=yes \
define Build/Configure
[ -f "$(PKG_BUILD_DIR)/source/include/config.h.save" ] || \
$(CP) $(PKG_BUILD_DIR)/source/include/config.h \
$(PKG_BUILD_DIR)/source/include/config.h.save
cat \
$(PKG_BUILD_DIR)/source/include/config.h.save \
./files/config-lfs.h >> $(PKG_BUILD_DIR)/source/include/config.h
$(Build/Configure/Default)
endef
MAKE_PATH=source
MAKE_FLAGS += \
$(if $(CONFIG_SAMBA3_CONFIG_NO_PRINTING),OWRT_NO_PRINTING=1) \
$(if $(CONFIG_SAMBA3_CONFIG_SMALLER),OWRT_SMALLER=1)
define Build/Compile
CC="$(TARGET_CC)" \
CFLAGS="$(TARGET_CFLAGS)" \
CPPFLAGS="$(TARGET_CPPFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
$(MAKE) -C $(PKG_BUILD_DIR)/source \
$(TARGET_CONFIGURE_OPTS) \
all bin/smbpasswd
# Ugly fix for parallel building (without this some generated files will be missing upon clean build)
$(call Build/Compile/Default, proto_exists)
$(call Build/Compile/Default, \
$(if $(CONFIG_PACKAGE_samba3),bin/smbd bin/smbpasswd) \
$(if $(CONFIG_PACKAGE_samba3-nmbd),bin/nmbd) \
$(if $(CONFIG_PACKAGE_samba3-mountcifs),bin/mount.cifs bin/umount.cifs) \
)
endef
define Package/samba3/install
@ -78,7 +120,21 @@ define Package/samba3/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbpasswd $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/smbd $(1)/usr/sbin/
endef
define Package/samba3-nmbd/install
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/samba-nmbd.init $(1)/etc/init.d/samba-nmbd
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/nmbd $(1)/usr/sbin/
endef
define Package/samba3-mountcifs/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/mount.cifs $(1)/usr/sbin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/source/bin/umount.cifs $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,samba3))
$(eval $(call BuildPackage,samba3-nmbd))
$(eval $(call BuildPackage,samba3-mountcifs))

View File

@ -1,56 +0,0 @@
#undef HAVE_CREAT64
#define HAVE_CREAT64 1
#undef HAVE_FSEEKO64
#define HAVE_FSEEKO64 1
#undef HAVE_FSTAT64
#define HAVE_FSTAT64 1
#undef HAVE_FTELLO64
#define HAVE_FTELLO64 1
#undef HAVE_FTRUNCATE64
#define HAVE_FTRUNCATE64 1
#undef HAVE_LSEEK64
#define HAVE_LSEEK64 1
#undef HAVE_LSTAT64
#define HAVE_LSTAT64 1
#undef HAVE_OPEN64
#define HAVE_OPEN64 1
#undef HAVE_PREAD64
#define HAVE_PREAD64 1
#undef HAVE_PWRITE64
#define HAVE_PWRITE64 1
#undef HAVE_READDIR64
#define HAVE_READDIR64 1
#undef HAVE_STAT64
#define HAVE_STAT64 1
#undef HAVE_STRUCT_FLOCK64
#define HAVE_STRUCT_FLOCK64 1
#undef SIZEOF_LONG_LONG
#define SIZEOF_LONG_LONG 8
#undef SIZEOF_OFF_T
#define SIZEOF_OFF_T 8
#undef _FILE_OFFSET_BITS
#define _FILE_OFFSET_BITS 64
#undef _GNU_SOURCE
#define _GNU_SOURCE 1
#undef _LARGEFILE_SOURCE
#define _LARGEFILE_SOURCE 1
#undef _LARGEFILE64_SOURCE
#define _LARGEFILE64_SOURCE 1

View File

@ -60,10 +60,8 @@ start() {
config_foreach smb_header samba
config_foreach smb_add_share sambashare
service_start /usr/sbin/smbd -D
service_start /usr/sbin/nmbd -D
}
stop() {
service_stop /usr/sbin/smbd
service_stop /usr/sbin/nmbd
}

View File

@ -14,3 +14,4 @@
guest account = nobody
invalid users = root
smb passwd file = /etc/samba/smbpasswd
interfaces = br-lan

File diff suppressed because it is too large Load Diff

View File

@ -1,55 +1,7 @@
Index: samba-3.0.24/source/Makefile
Index: samba-3.0.37/source/popt/popt.c
===================================================================
--- samba-3.0.24.orig/source/Makefile 2008-08-07 11:15:02.000000000 +0200
+++ samba-3.0.24/source/Makefile 2008-08-07 11:18:28.000000000 +0200
@@ -10,8 +10,6 @@
SOURCEROOT=$(shell pwd)/../../../..
SHAREDLIBS=$(SOURCEROOT)/sharedlibs
-include ${SHAREDLIBS}/ar7def.mk
-
# AR7
# prefix=/usr/local/samba
prefix=/var/samba
@@ -22,25 +20,27 @@
LIBS= -lcrypt -ldl -lpthread
# AR7
# CC=gcc
-CC=${TARGET}-gcc
+CC?=${TARGET}-gcc
RANLIB = ${TARGET}-ranlib
AR = ${TARGET}-ar
SHLD=${CC} ${CFLAGS}
# AR7
# CFLAGS= -O -D_SAMBA_BUILD_
-CFLAGS= -Os -D_SAMBA_BUILD_ -DAVM_NO_PRINTING
-CFLAGS+= -DAVM_NO_POPT
+CFLAPGS?=
+CFLAGS+= -Os -D_SAMBA_BUILD_ -DAVM_NO_PRINTING
+#CFLAGS+= -DAVM_NO_POPT
CFLAGS+= -DAVM_SMALLER
-
+#CFLAGS+= -DSAMBA_DEBUG
# uncomment this to get debugs
# CFLAGS += -DSAMBA_DEBUG
# AR7
# CPPFLAGS= -D_LARGEFILE64_SOURCE -D_FILE_OFFSET_BITS=64 -D_GNU_SOURCE
-CPPFLAGS= -D_GNU_SOURCE
+CPPFLAGS?= -D_GNU_SOURCE
+CPPFLAGS+= -D_GNU_SOURCE
EXEEXT=
-LDFLAGS=
+LDFLAGS?=
AR=ar
LDSHFLAGS=-shared -Wl,-Bsymbolic
WINBIND_NSS_LDSHFLAGS=-shared -Wl,-Bsymbolic
Index: samba-3.0.24/source/popt/popt.c
===================================================================
--- samba-3.0.24.orig/source/popt/popt.c 2008-08-07 11:15:00.000000000 +0200
+++ samba-3.0.24/source/popt/popt.c 2008-08-07 11:15:02.000000000 +0200
--- samba-3.0.37.orig/source/popt/popt.c 2011-04-11 23:35:04.000000000 +0200
+++ samba-3.0.37/source/popt/popt.c 2011-04-11 23:35:10.000000000 +0200
@@ -10,13 +10,14 @@
#include "system.h"
@ -67,7 +19,7 @@ Index: samba-3.0.24/source/popt/popt.c
#ifdef MYDEBUG
/*@unchecked@*/
@@ -384,7 +385,7 @@
@@ -388,7 +389,7 @@
sprintf(s, "%s/%s", con->execPath, item->argv[0]);
argv[argc] = s;
} else {
@ -76,30 +28,21 @@ Index: samba-3.0.24/source/popt/popt.c
}
if (argv[argc++] == NULL) return POPT_ERROR_NOARG;
@@ -1235,4 +1236,3 @@
@@ -1246,4 +1247,3 @@
return numargs;
}
-/*@=boundswrite@*/
Index: samba-3.0.24/source/smbd/server.c
Index: samba-3.0.37/source/modules/vfs_default.c
===================================================================
--- samba-3.0.24.orig/source/smbd/server.c 2008-08-07 11:15:02.000000000 +0200
+++ samba-3.0.24/source/smbd/server.c 2008-08-07 11:15:02.000000000 +0200
@@ -47,7 +47,7 @@
void _fLog(char *fmt, ...)
{
va_list va;
- FILE *fp = fopen("/var/tmp/smbd.log", "a");
+ FILE *fp = fopen("/var/log/smbd.log", "a");
time_t t = time(0); /* LOG */
--- samba-3.0.37.orig/source/modules/vfs_default.c 2011-04-11 23:35:08.000000000 +0200
+++ samba-3.0.37/source/modules/vfs_default.c 2011-04-11 23:35:10.000000000 +0200
@@ -977,7 +977,7 @@
if (!fp) return;
@@ -63,7 +63,7 @@
void _fDebug(char *fmt, ...)
{
va_list va;
- FILE *fp = fopen("/var/tmp/smbd.log", "a");
+ FILE *fp = fopen("/var/log/smbd.log", "a");
time_t t = time(0); /* LOG */
START_PROFILE(syscall_linux_setlease);
if (!fp) return;
-#ifdef LINUX
+#if defined(LINUX) && defined(HAVE_KERNEL_OPLOCKS_LINUX)
/* first set the signal handler */
if(linux_set_lease_sighandler(fd) == -1)
return -1;

View File

@ -1,57 +1,39 @@
Index: samba-3.0.24/source/Makefile
Index: samba-3.0.37/source/Makefile.in
===================================================================
--- samba-3.0.24.orig/source/Makefile 2008-08-06 23:33:20.000000000 +0200
+++ samba-3.0.24/source/Makefile 2008-08-06 23:34:48.000000000 +0200
@@ -12,7 +12,7 @@
# AR7
# prefix=/usr/local/samba
-prefix=/var/samba
+prefix=
exec_prefix=${prefix}
# AR7
@@ -108,11 +108,11 @@
# These can be overridden by command line switches (see smbd(8))
--- samba-3.0.37.orig/source/Makefile.in 2009-09-30 14:21:56.000000000 +0200
+++ samba-3.0.37/source/Makefile.in 2011-04-03 20:35:19.000000000 +0200
@@ -92,7 +92,7 @@
# or in smb.conf (see smb.conf(5))
LOGFILEBASE = ${VARDIR}
-CONFIGFILE = $(CONFIGDIR)/smb.conf
LOGFILEBASE = @logfilebase@
CONFIGFILE = $(CONFIGDIR)/smb.conf
-LMHOSTSFILE = $(CONFIGDIR)/lmhosts
+CONFIGFILE = /etc/samba/smb.conf
+LMHOSTSFILE = /etc/lmhosts
# This is where smbpasswd et al go
-PRIVATEDIR = ${prefix}/private
+PRIVATEDIR = /etc/samba/
SMB_PASSWD_FILE = $(PRIVATEDIR)/smbpasswd
PRIVATE_DIR = $(PRIVATEDIR)
@@ -121,10 +121,10 @@
SWATDIR = ${prefix}/swat
# the directory where lock files go
-LOCKDIR = ${VARDIR}/locks
+LOCKDIR = ${VARDIR}/lock
# the directory where pid files go
-PIDDIR = ${VARDIR}/locks
+PIDDIR = ${VARDIR}/lock
LIBSMBCLIENT=bin/libsmbclient.a bin/libsmbclient.so
LIBSMBCLIENT_MAJOR=0
Index: samba-3.0.24/source/lib/util.c
PRIVATEDIR = @privatedir@
Index: samba-3.0.37/source/configure
===================================================================
--- samba-3.0.24.orig/source/lib/util.c 2008-08-06 23:41:58.000000000 +0200
+++ samba-3.0.24/source/lib/util.c 2008-08-06 23:42:10.000000000 +0200
@@ -300,11 +300,7 @@
char *p;
if ((p = getenv("TMPDIR")))
return p;
-#if 1 /* AR7 */
- return "/var/tmp";
-#else
return "/tmp";
-#endif
}
--- samba-3.0.37.orig/source/configure 2009-09-30 15:08:58.000000000 +0200
+++ samba-3.0.37/source/configure 2011-04-03 20:35:20.000000000 +0200
@@ -1536,8 +1536,8 @@
--with-fhs Use FHS-compliant paths (default=no)
--with-privatedir=DIR Where to put smbpasswd ($ac_default_prefix/private)
--with-rootsbindir=DIR Which directory to use for root sbin ($ac_default_prefix/sbin)
- --with-lockdir=DIR Where to put lock files ($ac_default_prefix/var/locks)
- --with-piddir=DIR Where to put pid files ($ac_default_prefix/var/locks)
+ --with-lockdir=DIR Where to put lock files ($ac_default_prefix/var/lock)
+ --with-piddir=DIR Where to put pid files ($ac_default_prefix/var/run)
--with-swatdir=DIR Where to put SWAT files ($ac_default_prefix/swat)
--with-configdir=DIR Where to put configuration files ($libdir)
--with-logfilebase=DIR Where to put log files ($VARDIR)
@@ -2295,8 +2295,8 @@
/****************************************************************************
rootsbindir="\${SBINDIR}"
-lockdir="\${VARDIR}/locks"
-piddir="\${VARDIR}/locks"
+lockdir="\${VARDIR}/lock"
+piddir="\${VARDIR}/run"
test "${mandir}" || mandir="\${prefix}/man"
logfilebase="\${VARDIR}"
privatedir="\${prefix}/private"

View File

@ -1,23 +1,23 @@
Index: samba-3.0.24/source/Makefile
Index: samba-3.0.37/source/Makefile.in
===================================================================
--- samba-3.0.24.orig/source/Makefile 2008-08-07 15:56:45.000000000 +0200
+++ samba-3.0.24/source/Makefile 2008-08-07 15:56:45.000000000 +0200
@@ -1015,9 +1015,9 @@
--- samba-3.0.37.orig/source/Makefile.in 2011-08-08 23:40:18.004444730 +0200
+++ samba-3.0.37/source/Makefile.in 2011-08-08 23:40:19.054444730 +0200
@@ -538,10 +538,7 @@
MY_PASS_OBJ = libsmb/smbdes.o lib/md4.o lib/arc4.o
PASSWD_UTIL_OBJ = utils/passwd_util.o
-bin/smbpasswd: utils/avm_smbpasswd.o $(MY_PASS_OBJ)
+bin/smbpasswd: utils/owrt_smbpasswd.o $(MY_PASS_OBJ)
@echo Linking $@
- @$(CC) $(FLAGS) -o $@ utils/avm_smbpasswd.o $(MY_PASS_OBJ) \
+ @$(CC) $(FLAGS) -o $@ utils/owrt_smbpasswd.o $(MY_PASS_OBJ) \
-L$(TARGETFS)/lib
-SMBPASSWD_OBJ = utils/smbpasswd.o $(PASSWD_UTIL_OBJ) $(PASSCHANGE_OBJ) \
- $(PARAM_OBJ) $(SECRETS_OBJ) $(LIBSMB_OBJ) $(PASSDB_OBJ) \
- $(GROUPDB_OBJ) $(LIB_NONSMBD_OBJ) $(KRBCLIENT_OBJ) \
- $(POPT_LIB_OBJ) $(SMBLDAP_OBJ) $(RPC_PARSE_OBJ) $(LIBMSRPC_GEN_OBJ) $(LIBMSRPC_OBJ)
+SMBPASSWD_OBJ = utils/owrt_smbpasswd.o lib/md4.o
Index: samba-3.0.24/source/utils/owrt_smbpasswd.c
PDBEDIT_OBJ = utils/pdbedit.o $(PASSWD_UTIL_OBJ) $(PARAM_OBJ) $(PASSDB_OBJ) \
$(LIBSAMBA_OBJ) $(LIB_NONSMBD_OBJ) $(GROUPDB_OBJ) \
Index: samba-3.0.37/source/utils/owrt_smbpasswd.c
===================================================================
--- /dev/null 1970-01-01 00:00:00.000000000 +0000
+++ samba-3.0.24/source/utils/owrt_smbpasswd.c 2008-08-07 15:58:25.000000000 +0200
+++ samba-3.0.37/source/utils/owrt_smbpasswd.c 2011-08-08 23:40:19.064444730 +0200
@@ -0,0 +1,195 @@
+/*
+ * Copyright (C) John Crispin <blogic@openwrt.org>

View File

@ -1,27 +0,0 @@
Index: samba-3.0.24/source/include/config.h
===================================================================
--- samba-3.0.24.orig/source/include/config.h 2008-08-08 17:43:08.000000000 +0200
+++ samba-3.0.24/source/include/config.h 2008-08-08 17:44:02.000000000 +0200
@@ -821,7 +821,7 @@
#define HAVE_MKTIME 1
/* Whether mmap works */
-#define HAVE_MMAP 1
+/* #define HAVE_MMAP 1 */
/* Define to 1 if you have the <mntent.h> header file. */
#define HAVE_MNTENT_H 1
Index: samba-3.0.24/source/tdb/Makefile
===================================================================
--- samba-3.0.24.orig/source/tdb/Makefile 2008-08-08 17:42:47.000000000 +0200
+++ samba-3.0.24/source/tdb/Makefile 2008-08-08 17:44:15.000000000 +0200
@@ -2,7 +2,8 @@
# Makefile for tdb directory
#
-CFLAGS = -DSTANDALONE -DTDB_DEBUG -g -DHAVE_MMAP=1
+CFLAGS = -DSTANDALONE -DTDB_DEBUG -g
+#-DHAVE_MMAP=1
CC = gcc
ADMINPROGS = tdbdump tdbbackup

View File

@ -1,28 +1,23 @@
--- a/source/include/config.h
+++ b/source/include/config.h
@@ -986,13 +986,13 @@
/* #undef HAVE_ROOT */
Index: samba-3.0.37/source/configure
===================================================================
--- samba-3.0.37.orig/source/configure 2011-04-03 20:35:20.000000000 +0200
+++ samba-3.0.37/source/configure 2011-04-03 20:36:51.000000000 +0200
@@ -22548,6 +22548,17 @@
{ $as_echo "$as_me:$LINENO: result: $ac_header_preproc" >&5
$as_echo "$ac_header_preproc" >&6; }
/* Define to 1 if you have the <rpcsvc/nis.h> header file. */
-#define HAVE_RPCSVC_NIS_H 1
+/* #define HAVE_RPCSVC_NIS_H 1 */
/* Define to 1 if you have the <rpcsvc/ypclnt.h> header file. */
-#define HAVE_RPCSVC_YPCLNT_H 1
+/* #define HAVE_RPCSVC_YPCLNT_H 1 */
/* Define to 1 if you have the <rpcsvc/yp_prot.h> header file. */
-#define HAVE_RPCSVC_YP_PROT_H 1
+/* #define HAVE_RPCSVC_YP_PROT_H 1 */
/* Whether there is a conflicting AUTH_ERROR define in rpc/rpc.h */
/* #undef HAVE_RPC_AUTH_ERROR_CONFLICT */
@@ -1001,7 +1001,7 @@
/* #undef HAVE_RPC_NETTYPE_H */
/* Define to 1 if you have the <rpc/rpc.h> header file. */
-#define HAVE_RPC_RPC_H 1
+/* #define HAVE_RPC_RPC_H 1 */
/* Whether mkstemp is secure */
#define HAVE_SECURE_MKSTEMP 1
+# Force disable RPC
+$as_echo "test=$ac_header" >&6
+if test "$ac_header" = "rpc/rpc.h"; then
+ if test "$ac_header_compiler" = "yes" -o "$ac_header_preproc" = "yes"; then
+ $as_echo "RPC support force disabled by OpenWRT patch" >&5
+ $as_echo "RPC support force disabled by OpenWRT patch" >&6
+ fi
+fi
+ac_header_compiler=no
+ac_header_preproc=no
+
# So? What about this header?
case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
yes:no: )

View File

@ -1,12 +0,0 @@
--- a/source/include/config.h
+++ b/source/include/config.h
@@ -1848,8 +1848,7 @@
#define SIZEOF_LONG 4
/* The size of the 'off_t' type */
-/* AR7 #define SIZEOF_OFF_T 8 */
-#define SIZEOF_OFF_T 4 /* AR7 */
+/* #define SIZEOF_OFF_T 8 */
/* The size of a `short', as computed by sizeof. */
#define SIZEOF_SHORT 2