[packages] dhcp4: update to 4.2.4 and rename to dhcp
git-svn-id: svn://svn.openwrt.org/openwrt/packages@32476 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5456e18732
commit
074b88e5b0
132
net/dhcp/Makefile
Normal file
132
net/dhcp/Makefile
Normal file
@ -0,0 +1,132 @@
|
||||
#
|
||||
# Copyright (C) 2006-2012 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dhcp
|
||||
PKG_VERSION:=4.2.4
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=c244cefe663d43100af757d8ff625a1f
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/dhcp/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
SUBMENU:=IP Addresses and Names
|
||||
TITLE:=ISC's DHCP
|
||||
URL:=https://www.isc.org/software/dhcp
|
||||
endef
|
||||
|
||||
define Package/dhcp-relay
|
||||
$(call Package/dhcp/Default)
|
||||
TITLE+= relay
|
||||
endef
|
||||
|
||||
define Package/dhcp-relay/description
|
||||
provides a means for relaying DHCP and BOOTP requests from a subnet to which
|
||||
no DHCP server is directly connected to one or more DHCP servers on other
|
||||
subnets.
|
||||
endef
|
||||
|
||||
define Package/dhcp-client
|
||||
$(call Package/dhcp/Default)
|
||||
TITLE+= client
|
||||
endef
|
||||
|
||||
define Package/dhcp-client/description
|
||||
provides a means for configuring one or more network interfaces using the
|
||||
Dynamic Host Configuration Protocol, BOOTP protocol, or if these protocols
|
||||
fail, by statically assigning an address.
|
||||
endef
|
||||
|
||||
define Package/dhcp-server
|
||||
$(call Package/dhcp/Default)
|
||||
TITLE+= server
|
||||
endef
|
||||
|
||||
define Package/dhcp-server/description
|
||||
implements the Dynamic Host Configuration Protocol (DHCP) and the Internet
|
||||
Bootstrap Protocol (BOOTP).
|
||||
endef
|
||||
|
||||
define Package/dhcp-omshell
|
||||
$(call Package/dhcp/Default)
|
||||
DEPENDS:= +dhcp-server
|
||||
TITLE+= omshell
|
||||
endef
|
||||
|
||||
define Package/dhcp-omshell/description
|
||||
provides an interactive way to connect to, query, and possibly change, the ISC
|
||||
DHCP Server's state via OMAPI, the Object Management API.
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += \
|
||||
--disable-tracing \
|
||||
--enable-paranoia \
|
||||
--disable-dependency-tracking \
|
||||
ac_cv_file__dev_random=yes
|
||||
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
CONFIGURE_ARGS += --enable-dhcpv6
|
||||
else
|
||||
CONFIGURE_ARGS += --disable-dhcpv6
|
||||
endif
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
BUILD_CC="$(HOSTCC_NOCACHE)" \
|
||||
host_alias="$(GNU_TARGET_NAME)" \
|
||||
target_alias="$(GNU_TARGET_NAME)" \
|
||||
build_alias="$(GNU_HOST_NAME)" \
|
||||
ac_cv_file__dev_random=yes \
|
||||
all install-exec
|
||||
endef
|
||||
|
||||
define Package/dhcp-relay/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/dhcp-server/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) ./files/dhcpd.init $(1)/etc/init.d/dhcpd
|
||||
$(INSTALL_BIN) ./files/dhcpd.conf $(1)/etc
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
$(INSTALL_BIN) ./files/dhcpd6.init $(1)/etc/init.d/dhcpd6
|
||||
$(INSTALL_BIN) ./files/dhcpd6.conf $(1)/etc
|
||||
endif
|
||||
endef
|
||||
|
||||
define Package/dhcp-client/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhclient $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) ./files/dhclient-script $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) ./files/dhclient.init $(1)/etc/init.d/dhclient
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
$(INSTALL_BIN) ./files/dhclient6.init $(1)/etc/init.d/dhclient6
|
||||
$(INSTALL_BIN) ./files/dhclient6.conf $(1)/etc
|
||||
endif
|
||||
endef
|
||||
|
||||
define Package/dhcp-omshell/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/omshell $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dhcp-relay))
|
||||
$(eval $(call BuildPackage,dhcp-server))
|
||||
$(eval $(call BuildPackage,dhcp-client))
|
||||
$(eval $(call BuildPackage,dhcp-omshell))
|
@ -1,4 +1,5 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=60
|
||||
|
||||
lease_file=/var/dhclient.leases
|
||||
@ -7,27 +8,23 @@ pid_file=/var/run/dhclient.pid
|
||||
script_file=/usr/sbin/dhclient-script
|
||||
|
||||
start() {
|
||||
echo Starting isc-dhclient
|
||||
|
||||
/usr/sbin/dhclient -q -nw -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file `/sbin/uci get network.wan.ifname`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " isc-dhclient failed to start"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo Stopping isc-dhclient
|
||||
if [ -e $pid_file ]; then
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " PID " `cat $pid_file` not found
|
||||
echo " Is the DHCP client running?"
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
else
|
||||
echo " $pid_file not found"
|
||||
if [ ! -e $pid_file ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
}
|
@ -1,4 +1,5 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=60
|
||||
|
||||
lease_file=/var/dhclient6.leases
|
||||
@ -7,27 +8,23 @@ pid_file=/var/run/dhclient6.pid
|
||||
script_file=/usr/sbin/dhclient-script
|
||||
|
||||
start() {
|
||||
echo Starting isc-dhclient
|
||||
|
||||
/usr/sbin/dhclient -q -nw -6 -cf $config_file -lf $lease_file -pf $pid_file -sf $script_file `/sbin/uci get network.wan.ifname`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " isc-dhclient failed to start"
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo Stopping isc-dhclient
|
||||
if [ -e $pid_file ]; then
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " PID " `cat $pid_file` not found
|
||||
echo " Is the DHCP client running?"
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
else
|
||||
echo " $pid_file not found"
|
||||
if [ ! -e $pid_file ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
}
|
33
net/dhcp/files/dhcpd.init
Normal file
33
net/dhcp/files/dhcpd.init
Normal file
@ -0,0 +1,33 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=65
|
||||
|
||||
lease_file=/var/dhcpd.leases
|
||||
config_file=/etc/dhcpd.conf
|
||||
pid_file=/var/run/dhcpd.pid
|
||||
|
||||
start() {
|
||||
if [ ! -e $lease_file ]; then
|
||||
touch $lease_file
|
||||
fi
|
||||
|
||||
/usr/sbin/dhcpd -q -cf $config_file -lf $lease_file -pf $pid_file
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
if [ ! -e $pid_file ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
}
|
33
net/dhcp/files/dhcpd6.init
Normal file
33
net/dhcp/files/dhcpd6.init
Normal file
@ -0,0 +1,33 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
|
||||
START=65
|
||||
|
||||
lease_file=/var/dhcpd6.leases
|
||||
config_file=/etc/dhcpd6.conf
|
||||
pid_file=/var/run/dhcpd6.pid
|
||||
|
||||
start() {
|
||||
if [ ! -e $lease_file ]; then
|
||||
touch $lease_file
|
||||
fi
|
||||
|
||||
/usr/sbin/dhcpd -q -6 -cf $config_file -lf $lease_file -pf $pid_file
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
if [ ! -e $pid_file ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
return 1
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
}
|
24
net/dhcp/patches/000-compile.patch
Normal file
24
net/dhcp/patches/000-compile.patch
Normal file
@ -0,0 +1,24 @@
|
||||
--- a/bind/Makefile
|
||||
+++ b/bind/Makefile
|
||||
@@ -61,9 +61,12 @@ all:
|
||||
echo Bind export libraries already installed ; \
|
||||
else \
|
||||
echo Building BIND Export libraries - this takes some time. ;\
|
||||
+ (cd ${bindsrcdir}/lib/export/dns ; \
|
||||
+ echo building gen using ${BUILD_CC} in `pwd` ; \
|
||||
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen) ; \
|
||||
(cd ${bindsrcdir}/lib/export ; \
|
||||
echo building in `pwd` ; \
|
||||
- MAKE=${GMAKE} ${GMAKE} > ${binddir}/build.log) ; \
|
||||
+ $(MAKE) DESTDIR="" install > ${binddir}/build.log) ; \
|
||||
\
|
||||
echo Installing BIND Export libraries to ${binddir}. ; \
|
||||
(cd ${bindsrcdir}/lib/export ; \
|
||||
@@ -77,6 +80,7 @@ clean:
|
||||
|
||||
# Include the following so that this Makefile is happy when the parent
|
||||
# tries to use them.
|
||||
+install-exec:
|
||||
|
||||
distdir:
|
||||
|
@ -1,7 +0,0 @@
|
||||
config DHCP4_ENABLE_IPV6
|
||||
bool "Enable IPv6 capabilities (DHCPv6)"
|
||||
depends on PACKAGE_kmod-ipv6 && PACKAGE_dhcp4
|
||||
default y
|
||||
help
|
||||
Enables IPv6 features in all built DHCP4 packages
|
||||
|
@ -1,176 +0,0 @@
|
||||
#
|
||||
# Copyright (C) 2006-2008 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# This makefile is loosely based on a version for 4.1.0 that was designed to be OpenWRT friendly.
|
||||
#
|
||||
# $Id: Makefile 1 2011-12-17 17:42:34Z Olipro $
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dhcp
|
||||
PKG_VERSION:=4.2.3-P1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=ftp://ftp.isc.org/isc/dhcp/$(PKG_VERSION)
|
||||
PKG_MD5SUM:=04599f1557a5cafd10d7745267a68c8b
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_BUILD_PARALLEL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/dhcp4/Default
|
||||
SECTION:=net
|
||||
CATEGORY:=Network
|
||||
URL:=http://www.isc.org/
|
||||
endef
|
||||
|
||||
define Package/dhcp4
|
||||
$(call Package/dhcp4/Default)
|
||||
TITLE:=ISC DHCP-${PKG_VERSION}
|
||||
# PKG_HOST_ONLY:=1
|
||||
MENU:=1
|
||||
endef
|
||||
|
||||
define Package/dhcp4/config
|
||||
source "$(SOURCE)/Config.in"
|
||||
endef
|
||||
|
||||
define Package/dhcp4/description
|
||||
-
|
||||
This is the latest available version of the ISC DHCP suite. Generally speaking, you are unlikely
|
||||
to have any need of this application; it has a considerably larger filesize than dnsmasq and thus
|
||||
you should only be selecting this package because you need features only available in this suite.
|
||||
|
||||
endef
|
||||
|
||||
define Package/dhcp4-relay
|
||||
$(call Package/dhcp4/Default)
|
||||
DEPENDS:=@PACKAGE_dhcp4
|
||||
TITLE:=ISC DHCP Relay
|
||||
endef
|
||||
|
||||
define Package/dhcp4-relay/description
|
||||
The DHCP relay agent is for relaying DHCP messages between separate network segments.
|
||||
|
||||
This is the latest available version of the ISC DHCP suite. Generally speaking, you are unlikely
|
||||
to have any need of this application; it has a considerably larger filesize than dnsmasq and thus
|
||||
you should only be selecting this package because you need features only available in this suite.
|
||||
|
||||
endef
|
||||
|
||||
define Package/dhcp4-server
|
||||
$(call Package/dhcp4/Default)
|
||||
DEPENDS:=@PACKAGE_dhcp4
|
||||
TITLE:=ISC DHCP Server
|
||||
endef
|
||||
|
||||
define Package/dhcp4-server/description
|
||||
The ISC DHCP server provides comprehensive DHCP configuration and functionality for network
|
||||
hosts that have a complimentary DHCP client running.
|
||||
|
||||
This is the latest available version of the ISC DHCP suite. Generally speaking, you are unlikely
|
||||
to have any need of this application; it has a considerably larger filesize than dnsmasq and thus
|
||||
you should only be selecting this package because you need features only available in this suite.
|
||||
|
||||
endef
|
||||
|
||||
define Package/dhcp4-client
|
||||
$(call Package/dhcp4/Default)
|
||||
DEPENDS:=@PACKAGE_dhcp4
|
||||
TITLE:=ISC DHCP Client
|
||||
endef
|
||||
|
||||
define Package/dhcp4-client/description
|
||||
The ISC DHCP client receives configuration information from a DHCP server and configures the host
|
||||
accordingly.
|
||||
|
||||
This is the latest available version of the ISC DHCP suite. Generally speaking, you are unlikely
|
||||
to have any need of this application; it has a considerably larger filesize than dnsmasq and thus
|
||||
you should only be selecting this package because you need features only available in this suite.
|
||||
|
||||
endef
|
||||
|
||||
define Package/dhcp4-omshell
|
||||
$(call Package/dhcp4/Default)
|
||||
DEPENDS:=@PACKAGE_dhcp4
|
||||
TITLE:=ISC DHCP OmShell
|
||||
endef
|
||||
|
||||
define Package/dhcp4-omshell/description
|
||||
The ISC OmShell utility enables you to change the configuration of a running DHCP instance
|
||||
without having to endure the hassle of manually modifying the configuration file then
|
||||
killing and restarting it.
|
||||
|
||||
This is the latest available version of the ISC DHCP suite. Generally speaking, you are unlikely
|
||||
to have any need of this application; it has a considerably larger filesize than dnsmasq and thus
|
||||
you should only be selecting this package because you need features only available in this suite.
|
||||
|
||||
endef
|
||||
|
||||
CONFIGURE_ARGS += ac_cv_file__dev_random=yes --disable-tracing --enable-paranoia --disable-dependency-tracking
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
CONFIGURE_ARGS += --enable-dhcpv6
|
||||
else
|
||||
CONFIGURE_ARGS += --disable-dhcpv6
|
||||
endif
|
||||
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
CROSS_COMPILE="$(GNU_TARGET_NAME)" BUILD_CC="$(HOSTCC)" CC="$(TARGET_CC)" host_alias="$(GNU_TARGET_NAME)" target_alias="$(GNU_TARGET_NAME)" build_alias="$(GNU_HOST_NAME)" \
|
||||
ac_cv_file__dev_random=yes \
|
||||
all install-exec
|
||||
endef
|
||||
|
||||
define Package/dhcp4/install
|
||||
|
||||
endef
|
||||
|
||||
define Package/dhcp4-relay/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcrelay $(1)/usr/sbin/
|
||||
endef
|
||||
|
||||
define Package/dhcp4-server/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
# $(INSTALL_DIR) $(1)/usr/lib
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhcpd $(1)/usr/sbin/
|
||||
#Libs appear to be unnecessary
|
||||
# $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/*.a $(1)/usr/lib
|
||||
$(INSTALL_BIN) ./files/dhcpd.init $(1)/etc/init.d/dhcpd
|
||||
$(INSTALL_BIN) ./files/dhcpd.conf $(1)/etc
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
$(INSTALL_BIN) ./files/dhcpd6.init $(1)/etc/init.d/dhcpd6
|
||||
$(INSTALL_BIN) ./files/dhcpd6.conf $(1)/etc
|
||||
endif
|
||||
endef
|
||||
|
||||
define Package/dhcp4-client/install
|
||||
$(INSTALL_DIR) $(1)/usr/sbin
|
||||
$(INSTALL_DIR) $(1)/etc/init.d
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/dhclient $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) ./files/dhclient-script $(1)/usr/sbin/
|
||||
$(INSTALL_BIN) ./files/dhclient.init $(1)/etc/init.d/dhclient
|
||||
ifeq ($(CONFIG_DHCP4_ENABLE_IPV6),y)
|
||||
$(INSTALL_BIN) ./files/dhclient6.init $(1)/etc/init.d/dhclient6
|
||||
$(INSTALL_BIN) ./files/dhclient6.conf $(1)/etc
|
||||
endif
|
||||
endef
|
||||
|
||||
define Package/dhcp4-omshell/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/omshell $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,dhcp4))
|
||||
$(eval $(call BuildPackage,dhcp4-relay))
|
||||
$(eval $(call BuildPackage,dhcp4-server))
|
||||
$(eval $(call BuildPackage,dhcp4-client))
|
||||
$(eval $(call BuildPackage,dhcp4-omshell))
|
@ -1,37 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
START=65
|
||||
|
||||
lease_file=/var/dhcpd.leases
|
||||
config_file=/etc/dhcpd.conf
|
||||
pid_file=/var/run/dhcpd.pid
|
||||
|
||||
start() {
|
||||
echo Starting isc-dhcpd
|
||||
|
||||
if [ ! -e $lease_file ]; then
|
||||
echo " Creating $lease_file"
|
||||
touch $lease_file
|
||||
fi
|
||||
|
||||
/usr/sbin/dhcpd -q -cf $config_file -lf $lease_file -pf $pid_file
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " isc-dhcpd failed to start"
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo Stopping isc-dhcpd
|
||||
if [ -e $pid_file ]; then
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " PID " `cat $pid_file` not found
|
||||
echo " Is the DHCP server running?"
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
else
|
||||
echo " $pid_file not found"
|
||||
fi
|
||||
}
|
@ -1,37 +0,0 @@
|
||||
#!/bin/sh /etc/rc.common
|
||||
START=65
|
||||
|
||||
lease_file=/var/dhcpd6.leases
|
||||
config_file=/etc/dhcpd6.conf
|
||||
pid_file=/var/run/dhcpd6.pid
|
||||
|
||||
start() {
|
||||
echo Starting isc-dhcpd
|
||||
|
||||
if [ ! -e $lease_file ]; then
|
||||
echo " Creating $lease_file"
|
||||
touch $lease_file
|
||||
fi
|
||||
|
||||
/usr/sbin/dhcpd -q -6 -cf $config_file -lf $lease_file -pf $pid_file
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " isc-dhcpd failed to start"
|
||||
fi
|
||||
}
|
||||
|
||||
stop() {
|
||||
echo Stopping isc-dhcpd
|
||||
if [ -e $pid_file ]; then
|
||||
kill -9 `cat $pid_file`
|
||||
|
||||
if [ $? -ne 0 ]; then
|
||||
echo " PID " `cat $pid_file` not found
|
||||
echo " Is the DHCP server running?"
|
||||
fi
|
||||
|
||||
rm $pid_file
|
||||
else
|
||||
echo " $pid_file not found"
|
||||
fi
|
||||
}
|
@ -1,28 +0,0 @@
|
||||
--- a/bind/Makefile 2011-11-28 23:08:15.000000000 +0000
|
||||
+++ b/bind/Makefile 2011-12-17 16:27:20.784433502 +0000
|
||||
@@ -49,13 +49,16 @@
|
||||
|
||||
# Build the export libraries
|
||||
@echo Building BIND Export libraries - this takes some time.
|
||||
+ @(cd ${bindsrcdir}/lib/export/dns ; \
|
||||
+ echo building gen using ${BUILD_CC} in `pwd` ; \
|
||||
+ $(MAKE) CC=${BUILD_CC} CFLAGS="-O2" LIBS="" gen)
|
||||
@(cd ${bindsrcdir}/lib/export ; \
|
||||
echo building in `pwd` ; \
|
||||
MAKE=${GMAKE} ${GMAKE} > ${binddir}/build.log)
|
||||
|
||||
@echo Installing BIND Export libraries to ${binddir}.
|
||||
@(cd ${bindsrcdir}/lib/export ; \
|
||||
- MAKE=${GMAKE} ${GMAKE} install > ${binddir}/install.log)
|
||||
+ $(MAKE) DESTDIR="" install > ${binddir}/install.log)
|
||||
|
||||
clean:
|
||||
@echo Cleaning BIND export library.
|
||||
@@ -64,6 +67,7 @@
|
||||
|
||||
# Include the following so that this Makefile is happy when the parent
|
||||
# tries to use them.
|
||||
+install-exec:
|
||||
|
||||
distdir:
|
||||
|
Loading…
x
Reference in New Issue
Block a user