[packages] fwknop: update to 2.0, use new startup commands

Signed-off-by: Jonathan Bennett <jbscience87@gmail.com>


git-svn-id: svn://svn.openwrt.org/openwrt/packages@31824 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
swalker 2012-05-20 01:45:42 +00:00
parent 40133cd17e
commit 077acd8e04
3 changed files with 22 additions and 5 deletions

View File

@ -1,5 +1,5 @@
#
# Copyright (C) 2011 OpenWrt.org
# Copyright (C) 2011-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=fwknop
PKG_VERSION:=2.0.0rc4
PKG_VERSION:=2.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://www.cipherdyne.org/fwknop/download
PKG_MD5SUM:=4f5d45187429ca56d3b444ab96c57fb6
PKG_MD5SUM:=96de4c5a4ae75a8618ef80269c6a70ad
PKG_INSTALL:=1

View File

@ -1,6 +1,6 @@
--- a/server/fwknopd.conf
+++ b/server/fwknopd.conf
@@ -30,7 +30,12 @@
@@ -29,7 +29,12 @@
# Define the ethernet interface on which we will sniff packets.
# Default if not set is eth0.
#
@ -14,7 +14,7 @@
# By default fwknopd does not put the pcap interface into promiscuous mode.
# Set this to 'Y' to enable promiscuous sniffing.
@@ -239,8 +244,13 @@
@@ -252,8 +257,13 @@
# The IPT_FORWARD_ACCESS variable is only used if ENABLE_IPT_FORWARDING is
# enabled.
#

View File

@ -0,0 +1,17 @@
--- a/extras/openwrt/package/fwknop/files/fwknopd.init
+++ b/extras/openwrt/package/fwknop/files/fwknopd.init
@@ -8,12 +8,12 @@ FWKNOPD_BIN=/usr/sbin/fwknopd
start()
{
- $FWKNOPD_BIN
+ service_start $FWKNOPD_BIN
}
stop()
{
- $FWKNOPD_BIN -K
+ service_stop $FWKNOPD_BIN -K
}
restart()