[package] update tor to 0.2.1.20 (#6279)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@18652 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9a474fd18b
commit
078b2e3bb0
@ -8,21 +8,21 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=tor
|
PKG_NAME:=tor
|
||||||
PKG_VERSION:=0.2.1.19
|
PKG_VERSION:=0.2.1.20
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.torproject.org/dist/
|
PKG_SOURCE_URL:=http://www.torproject.org/dist/
|
||||||
PKG_MD5SUM:=2c0ca9bf5d0cfb771f4d6bec9c4360ca
|
PKG_MD5SUM:=0d62ee2332fdd95de43debac7435df19
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
define Package/tor
|
define Package/tor
|
||||||
SECTION:=net
|
SECTION:=net
|
||||||
CATEGORY:=Network
|
CATEGORY:=Network
|
||||||
DEPENDS:=+libevent +libopenssl +libpthread +zlib
|
DEPENDS:=+libevent +libopenssl +libpthread
|
||||||
TITLE:=An anonymous Internet communication system
|
TITLE:=An anonymous Internet communication system
|
||||||
URL:=http://tor.eff.org/
|
URL:=http://www.torproject.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/tor/description
|
define Package/tor/description
|
||||||
@ -67,7 +67,7 @@ if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/group)" ]; then
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
|
if [ -z "$$(grep ^\\$${name}: $${IPKG_INSTROOT}/etc/passwd)" ]; then
|
||||||
echo "adding user $name to /etc/passwd"
|
echo "adding user $$name to /etc/passwd"
|
||||||
echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
|
echo "$${name}:x:$${id}:$${id}:$${name}:/tmp/.$${name}:/bin/false" >> $${IPKG_INSTROOT}/etc/passwd
|
||||||
fi
|
fi
|
||||||
endef
|
endef
|
||||||
@ -89,11 +89,11 @@ endef
|
|||||||
|
|
||||||
define Package/tor/install
|
define Package/tor/install
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
$(INSTALL_DIR) $(1)/usr/sbin
|
||||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/or/tor $(1)/usr/sbin/
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/tor $(1)/usr/sbin/
|
||||||
$(INSTALL_DIR) $(1)/etc/init.d
|
$(INSTALL_DIR) $(1)/etc/init.d
|
||||||
$(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
|
$(INSTALL_BIN) ./files/tor.init $(1)/etc/init.d/tor
|
||||||
$(INSTALL_DIR) $(1)/etc/tor
|
$(INSTALL_DIR) $(1)/etc/tor
|
||||||
$(INSTALL_DATA) ./files/torrc $(1)/etc/tor/torrc
|
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/tor/torrc.sample $(1)/etc/tor/torrc
|
||||||
endef
|
endef
|
||||||
|
|
||||||
$(eval $(call BuildPackage,tor))
|
$(eval $(call BuildPackage,tor))
|
||||||
|
@ -14,7 +14,7 @@ RUN_GROUP=$BIN
|
|||||||
start() {
|
start() {
|
||||||
[ -f $DEFAULT ] && . $DEFAULT
|
[ -f $DEFAULT ] && . $DEFAULT
|
||||||
[ -d $LIB_D ] || mkdir -p $LOG_D
|
[ -d $LIB_D ] || mkdir -p $LOG_D
|
||||||
[ -d $LIB_D ] || ( mkdir -p $LIB_D && chown $RUN_USER:$RUN_GROUP $LIB_D )
|
[ -d $LIB_D ] || ( mkdir -p $LIB_D && chown $RUN_USER:$RUN_GROUP $LIB_D && chmod 0700 $LIB_D )
|
||||||
[ -d $RUN_D ] || mkdir -p $RUN_D
|
[ -d $RUN_D ] || mkdir -p $RUN_D
|
||||||
[ -f $PID_F ] || ( touch $PID_F && chown $RUN_USER:$RUN_GROUP $PID_F )
|
[ -f $PID_F ] || ( touch $PID_F && chown $RUN_USER:$RUN_GROUP $PID_F )
|
||||||
$BIN $OPTIONS
|
$BIN $OPTIONS
|
||||||
|
@ -1,153 +0,0 @@
|
|||||||
## Configuration file for a typical Tor user
|
|
||||||
## Last updated 22 December 2007 for Tor 0.2.0.14-alpha.
|
|
||||||
## (May or may not work for much older or much newer versions of Tor.)
|
|
||||||
##
|
|
||||||
## Lines that begin with "## " try to explain what's going on. Lines
|
|
||||||
## that begin with just "#" are disabled commands: you can enable them
|
|
||||||
## by removing the "#" symbol.
|
|
||||||
##
|
|
||||||
## See the man page, or https://www.torproject.org/tor-manual-dev.html,
|
|
||||||
## for more options you can use in this file.
|
|
||||||
##
|
|
||||||
## Tor will look for this file in various places based on your platform:
|
|
||||||
## http://wiki.noreply.org/noreply/TheOnionRouter/TorFAQ#torrc
|
|
||||||
|
|
||||||
|
|
||||||
## Replace this with "SocksPort 0" if you plan to run Tor only as a
|
|
||||||
## server, and not make any local application connections yourself.
|
|
||||||
SocksPort 9050 # what port to open for local application connections
|
|
||||||
SocksListenAddress 127.0.0.1 # accept connections only from localhost
|
|
||||||
#SocksListenAddress 192.168.0.1:9100 # listen on this IP:port also
|
|
||||||
|
|
||||||
## Entry policies to allow/deny SOCKS requests based on IP address.
|
|
||||||
## First entry that matches wins. If no SocksPolicy is set, we accept
|
|
||||||
## all (and only) requests from SocksListenAddress.
|
|
||||||
#SocksPolicy accept 192.168.0.0/16
|
|
||||||
#SocksPolicy reject *
|
|
||||||
|
|
||||||
## Logs go to stdout at level "notice" unless redirected by something
|
|
||||||
## else, like one of the below lines. You can have as many Log lines as
|
|
||||||
## you want.
|
|
||||||
##
|
|
||||||
## We advise using "notice" in most cases, since anything more verbose
|
|
||||||
## may provide sensitive information to an attacker who obtains the logs.
|
|
||||||
##
|
|
||||||
## Send all messages of level 'notice' or higher to /var/log/tor/notices.log
|
|
||||||
#Log notice file /var/log/tor/notices.log
|
|
||||||
## Send every possible message to /var/log/tor/debug.log
|
|
||||||
#Log debug file /var/log/tor/debug.log
|
|
||||||
## Use the system log instead of Tor's logfiles
|
|
||||||
#Log notice syslog
|
|
||||||
## To send all messages to stderr:
|
|
||||||
#Log debug stderr
|
|
||||||
|
|
||||||
## Uncomment this to start the process in the background... or use
|
|
||||||
## --runasdaemon 1 on the command line. This is ignored on Windows;
|
|
||||||
## see the FAQ entry if you want Tor to run as an NT service.
|
|
||||||
RunAsDaemon 1
|
|
||||||
|
|
||||||
## The directory for keeping all the keys/etc. By default, we store
|
|
||||||
## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
|
|
||||||
DataDirectory /var/lib/tor
|
|
||||||
|
|
||||||
## The port on which Tor will listen for local connections from Tor
|
|
||||||
## controller applications, as documented in control-spec.txt.
|
|
||||||
#ControlPort 9051
|
|
||||||
|
|
||||||
############### This section is just for location-hidden services ###
|
|
||||||
|
|
||||||
## Once you have configured a hidden service, you can look at the
|
|
||||||
## contents of the file ".../hidden_service/hostname" for the address
|
|
||||||
## to tell people.
|
|
||||||
##
|
|
||||||
## HiddenServicePort x y:z says to redirect requests on port x to the
|
|
||||||
## address y:z.
|
|
||||||
|
|
||||||
#HiddenServiceDir /var/lib/tor/hidden_service/
|
|
||||||
#HiddenServicePort 80 127.0.0.1:80
|
|
||||||
|
|
||||||
#HiddenServiceDir /var/lib/tor/other_hidden_service/
|
|
||||||
#HiddenServicePort 80 127.0.0.1:80
|
|
||||||
#HiddenServicePort 22 127.0.0.1:22
|
|
||||||
|
|
||||||
################ This section is just for relays #####################
|
|
||||||
#
|
|
||||||
## See https://www.torproject.org/docs/tor-doc-relay for details.
|
|
||||||
|
|
||||||
## A unique handle for your server.
|
|
||||||
#Nickname ididnteditheconfig
|
|
||||||
|
|
||||||
## The IP or FQDN for your server. Leave commented out and Tor will guess.
|
|
||||||
#Address noname.example.com
|
|
||||||
|
|
||||||
## Define these to limit the bandwidth usage of relayed (server)
|
|
||||||
## traffic. Your own traffic is still unthrottled.
|
|
||||||
## Note that RelayBandwidthRate must be at least 20 KB.
|
|
||||||
#RelayBandwidthRate 100 KBytes # Throttle traffic to 100KB/s (800Kbps)
|
|
||||||
#RelayBandwidthBurst 200 KBytes # But allow bursts up to 200KB/s (1600Kbps)
|
|
||||||
|
|
||||||
## Contact info to be published in the directory, so we can contact you
|
|
||||||
## if your server is misconfigured or something else goes wrong.
|
|
||||||
#ContactInfo Random Person <nobody AT example dot com>
|
|
||||||
## You might also include your PGP or GPG fingerprint if you have one:
|
|
||||||
#ContactInfo 1234D/FFFFFFFF Random Person <nobody AT example dot com>
|
|
||||||
|
|
||||||
## Required: what port to advertise for Tor connections.
|
|
||||||
#ORPort 9001
|
|
||||||
## If you need to listen on a port other than the one advertised
|
|
||||||
## in ORPort (e.g. to advertise 443 but bind to 9090), uncomment the
|
|
||||||
## line below too. You'll need to do ipchains or other port forwarding
|
|
||||||
## yourself to make this work.
|
|
||||||
#ORListenAddress 0.0.0.0:9090
|
|
||||||
|
|
||||||
## Uncomment this to mirror directory information for others. Please do
|
|
||||||
## if you have enough bandwidth.
|
|
||||||
#DirPort 9030 # what port to advertise for directory connections
|
|
||||||
## If you need to listen on a port other than the one advertised
|
|
||||||
## in DirPort (e.g. to advertise 80 but bind to 9091), uncomment the line
|
|
||||||
## below too. You'll need to do ipchains or other port forwarding yourself
|
|
||||||
## to make this work.
|
|
||||||
#DirListenAddress 0.0.0.0:9091
|
|
||||||
|
|
||||||
## Uncomment this if you run more than one Tor server, and add the
|
|
||||||
## nickname of each Tor server you control, even if they're on different
|
|
||||||
## networks. You declare it here so Tor clients can avoid using more than
|
|
||||||
## one of your servers in a single circuit. See
|
|
||||||
## http://wiki.noreply.org/noreply/TheOnionRouter/TorFAQ#MultipleServers
|
|
||||||
#MyFamily nickname1,nickname2,...
|
|
||||||
|
|
||||||
## A comma-separated list of exit policies. They're considered first
|
|
||||||
## to last, and the first match wins. If you want to _replace_
|
|
||||||
## the default exit policy, end this with either a reject *:* or an
|
|
||||||
## accept *:*. Otherwise, you're _augmenting_ (prepending to) the
|
|
||||||
## default exit policy. Leave commented to just use the default, which is
|
|
||||||
## available in the man page or at https://www.torproject.org/documentation.html
|
|
||||||
##
|
|
||||||
## Look at https://www.torproject.org/faq-abuse.html#TypicalAbuses
|
|
||||||
## for issues you might encounter if you use the default exit policy.
|
|
||||||
##
|
|
||||||
## If certain IPs and ports are blocked externally, e.g. by your firewall,
|
|
||||||
## you should update your exit policy to reflect this -- otherwise Tor
|
|
||||||
## users will be told that those destinations are down.
|
|
||||||
##
|
|
||||||
#ExitPolicy accept *:6660-6667,reject *:* # allow irc ports but no more
|
|
||||||
#ExitPolicy accept *:119 # accept nntp as well as default exit policy
|
|
||||||
#ExitPolicy reject *:* # no exits allowed
|
|
||||||
#
|
|
||||||
################ This section is just for bridge relays ##############
|
|
||||||
#
|
|
||||||
## Bridge relays (or "bridges" ) are Tor relays that aren't listed in the
|
|
||||||
## main directory. Since there is no complete public list of them, even if an
|
|
||||||
## ISP is filtering connections to all the known Tor relays, they probably
|
|
||||||
## won't be able to block all the bridges. Unlike running an exit relay,
|
|
||||||
## running a bridge relay just passes data to and from the Tor network --
|
|
||||||
## so it shouldn't expose the operator to abuse complaints.
|
|
||||||
|
|
||||||
#ORPort 443
|
|
||||||
#BridgeRelay 1
|
|
||||||
#RelayBandwidthRate 50KBytes
|
|
||||||
#ExitPolicy reject *:*
|
|
||||||
|
|
||||||
User tor
|
|
||||||
Group tor
|
|
||||||
PidFile /var/run/tor.pid
|
|
22
net/tor/patches/001-torrc.patch
Normal file
22
net/tor/patches/001-torrc.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
--- a/src/config/torrc.sample.in
|
||||||
|
+++ b/src/config/torrc.sample.in
|
||||||
|
@@ -44,11 +44,11 @@ SocksListenAddress 127.0.0.1 # accept co
|
||||||
|
## Uncomment this to start the process in the background... or use
|
||||||
|
## --runasdaemon 1 on the command line. This is ignored on Windows;
|
||||||
|
## see the FAQ entry if you want Tor to run as an NT service.
|
||||||
|
-#RunAsDaemon 1
|
||||||
|
+RunAsDaemon 1
|
||||||
|
|
||||||
|
## The directory for keeping all the keys/etc. By default, we store
|
||||||
|
## things in $HOME/.tor on Unix, and in Application Data\tor on Windows.
|
||||||
|
-#DataDirectory @LOCALSTATEDIR@/lib/tor
|
||||||
|
+DataDirectory @LOCALSTATEDIR@/lib/tor
|
||||||
|
|
||||||
|
## The port on which Tor will listen for local connections from Tor
|
||||||
|
## controller applications, as documented in control-spec.txt.
|
||||||
|
@@ -154,3 +154,5 @@ SocksListenAddress 127.0.0.1 # accept co
|
||||||
|
#BridgeRelay 1
|
||||||
|
#ExitPolicy reject *:*
|
||||||
|
|
||||||
|
+User tor
|
||||||
|
+PidFile @LOCALSTATEDIR@/run/tor.pid
|
Loading…
x
Reference in New Issue
Block a user