update mpc to v0.15, patch by Jan Willies
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14542 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
3bb7109034
commit
07f0f30d16
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=mpc
|
||||
PKG_VERSION:=0.14
|
||||
PKG_VERSION:=0.15
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/musicpd
|
||||
PKG_MD5SUM:=f4218602342cf322872a41dfe0cc72e1
|
||||
PKG_MD5SUM:=48897aeb3a7ee5c64f30e56789f105a8
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
12
sound/mpc/patches/001-uclibc.patch
Normal file
12
sound/mpc/patches/001-uclibc.patch
Normal file
@ -0,0 +1,12 @@
|
||||
--- ./src/main.c.orig 2009-02-02 02:04:11.000000000 +0100
|
||||
+++ ./src/main.c 2009-02-17 19:48:55.000000000 +0100
|
||||
@@ -190,7 +190,8 @@
|
||||
static struct command *
|
||||
find_command(const char *name)
|
||||
{
|
||||
- for (unsigned i = 0; mpc_table[i].command != NULL; ++i)
|
||||
+ unsigned i = 0;
|
||||
+ for (i = 0; mpc_table[i].command != NULL; ++i)
|
||||
if (strcmp(name, mpc_table[i].command) == 0)
|
||||
return &mpc_table[i];
|
||||
|
Loading…
x
Reference in New Issue
Block a user