utils/smartmontools: update package to version 5.40 (closes #8116)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@23582 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
6fc88664c1
commit
08eaf829dd
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=smartmontools
|
||||
PKG_VERSION:=5.38
|
||||
PKG_VERSION:=5.40
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/smartmontools
|
||||
PKG_MD5SUM:=a282846532ecbd6b4a28072373b3a70b
|
||||
PKG_MD5SUM:=0f0be0239914ad87830a4fff594bda5b
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -35,19 +35,27 @@ endef
|
||||
# uses GNU configure
|
||||
|
||||
define Build/Configure
|
||||
(cd $(PKG_BUILD_DIR); ./autogen.sh );
|
||||
$(call Build/Configure/Default,, \
|
||||
ac_libc_have_working_snprintf=yes \
|
||||
(cd $(PKG_BUILD_DIR); \
|
||||
./autogen.sh \
|
||||
./configure \
|
||||
CC="$(TARGET_CC)" \
|
||||
CXX="$(TARGET_CXX)" \
|
||||
CPP="$(TARGET_CPP)" \
|
||||
CXXFLAGS="$$$$CXXFLAGS -fno-builtin -fno-rtti -nostdinc++" \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/include/uClibc++ -I$(LINUX_DIR)/include" \
|
||||
LDFLAGS="$$$$LDFLAGS" \
|
||||
LIBS="-nodefaultlibs -luClibc++ -lm $(LIBGCC_S) -lc" \
|
||||
--prefix=/usr \
|
||||
--build=$(GNU_BUILD_NAME) \
|
||||
--host=$(GNU_HOST_NAME) \
|
||||
--target=$(GNU_TARGET_NAME) \
|
||||
);
|
||||
$(call Build/Configure/Default,, \
|
||||
)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)"
|
||||
$(MAKE) -C $(PKG_BUILD_DIR)
|
||||
endef
|
||||
|
||||
define Package/smartmontools/install
|
||||
|
@ -1,33 +0,0 @@
|
||||
--- a/configure.in
|
||||
+++ b/configure.in
|
||||
@@ -88,18 +88,18 @@
|
||||
AC_CHECK_FUNCS([uname])
|
||||
|
||||
# Check whether snprintf appends null char and returns expected length on overflow
|
||||
-AH_TEMPLATE(HAVE_WORKING_SNPRINTF, [Define to 1 if the `snprintf' function is sane])
|
||||
-AC_MSG_CHECKING([for working snprintf])
|
||||
-AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
||||
- int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
||||
- [libc_have_working_snprintf=yes],
|
||||
- [libc_have_working_snprintf=no],
|
||||
- [libc_have_working_snprintf=no])
|
||||
-AC_SUBST(libc_have_working_snprintf)
|
||||
-if test "$libc_have_working_snprintf" = "yes"; then
|
||||
- AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
||||
-fi
|
||||
-AC_MSG_RESULT([$libc_have_working_snprintf])
|
||||
+#AH_TEMPLATE(HAVE_WORKING_SNPRINTF, [Define to 1 if the `snprintf' function is sane])
|
||||
+#AC_MSG_CHECKING([for working snprintf])
|
||||
+#AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <stdio.h>]], [[ char buf[]="ABCDEFGHI";
|
||||
+# int i=snprintf(buf,8,"12345678"); return !(!buf[7] && i==8); ]])],
|
||||
+# [libc_have_working_snprintf=yes],
|
||||
+# [libc_have_working_snprintf=no],
|
||||
+# [libc_have_working_snprintf=no])
|
||||
+#AC_SUBST(libc_have_working_snprintf)
|
||||
+#if test "$libc_have_working_snprintf" = "yes"; then
|
||||
+# AC_DEFINE(HAVE_WORKING_SNPRINTF)
|
||||
+#fi
|
||||
+#AC_MSG_RESULT([$libc_have_working_snprintf])
|
||||
|
||||
# check for __attribute__((packed))
|
||||
AH_TEMPLATE(HAVE_ATTR_PACKED, [Define to 1 if C++ compiler supports __attribute__((packed))])
|
Loading…
x
Reference in New Issue
Block a user