fix libnet build on osx
git-svn-id: svn://svn.openwrt.org/openwrt/packages@6799 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
94b2dc4dbb
commit
09daa5f167
@ -35,6 +35,16 @@ ifeq ($(CONFIG_BIG_ENDIAN),y)
|
|||||||
ENDIANESS:=big
|
ENDIANESS:=big
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--with-pf_packet=yes
|
||||||
|
|
||||||
|
CONFIGURE_VARS += \
|
||||||
|
ac_cv_libnet_endianess=$(ENDIANESS) \
|
||||||
|
ac_libnet_have_pf_packet=yes \
|
||||||
|
LL_INT_TYPE=linux
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
(cd $(PKG_BUILD_DIR); touch \
|
(cd $(PKG_BUILD_DIR); touch \
|
||||||
configure.in \
|
configure.in \
|
||||||
@ -43,19 +53,13 @@ define Build/Configure
|
|||||||
Makefile.in \
|
Makefile.in \
|
||||||
configure \
|
configure \
|
||||||
);
|
);
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default)
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--with-pf_packet=yes \
|
|
||||||
, \
|
|
||||||
ac_cv_libnet_endianess=$(ENDIANESS) \
|
|
||||||
ac_libnet_have_pf_packet=yes \
|
|
||||||
ac_libnet_have_packet_socket=yes \
|
|
||||||
)
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Compile
|
define Build/Compile
|
||||||
|
# pass CFLAGS again to override -O2 set by configure
|
||||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||||
|
CFLAGS="$(TARGET_CFLAGS)" \
|
||||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||||
all install
|
all install
|
||||||
endef
|
endef
|
||||||
|
35
libs/libnet-1.1.x/patches/150-portability.patch
Normal file
35
libs/libnet-1.1.x/patches/150-portability.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
diff -ur libnet.old/configure libnet.dev/configure
|
||||||
|
--- libnet.old/configure 2007-04-01 17:48:16.000000000 +0200
|
||||||
|
+++ libnet.dev/configure 2007-04-01 18:43:46.000000000 +0200
|
||||||
|
@@ -19537,7 +19537,15 @@
|
||||||
|
echo "$as_me:$LINENO: checking link-layer packet interface type" >&5
|
||||||
|
echo $ECHO_N "checking link-layer packet interface type... $ECHO_C" >&6
|
||||||
|
|
||||||
|
-if test -r /dev/bpf0 ; then
|
||||||
|
+if test -n "$LL_INT_TYPE"; then
|
||||||
|
+ case $LIBOBJS in
|
||||||
|
+ "libnet_link_$LL_INT_TYPE.$ac_objext" | \
|
||||||
|
+ *" libnet_link_$LL_INT_TYPE.$ac_objext" | \
|
||||||
|
+ "libnet_link_$LL_INT_TYPE.$ac_objext "* | \
|
||||||
|
+ *" libnet_link_$LL_INT_TYPE.$ac_objext "* ) ;;
|
||||||
|
+ *) LIBOBJS="$LIBOBJS libnet_link_$LL_INT_TYPE.$ac_objext" ;;
|
||||||
|
+esac
|
||||||
|
+elif test -r /dev/bpf0 ; then
|
||||||
|
case $LIBOBJS in
|
||||||
|
"libnet_link_bpf.$ac_objext" | \
|
||||||
|
*" libnet_link_bpf.$ac_objext" | \
|
||||||
|
diff -ur libnet.old/configure.in libnet.dev/configure.in
|
||||||
|
--- libnet.old/configure.in 2007-04-01 17:48:16.000000000 +0200
|
||||||
|
+++ libnet.dev/configure.in 2007-04-01 18:44:29.000000000 +0200
|
||||||
|
@@ -67,7 +67,10 @@
|
||||||
|
dnl
|
||||||
|
AC_MSG_CHECKING(link-layer packet interface type)
|
||||||
|
|
||||||
|
-if test -r /dev/bpf0 ; then
|
||||||
|
+if test -n "$LL_INT_TYPE"; then
|
||||||
|
+ AC_LIBOBJ($LL_INT_TYPE)
|
||||||
|
+ AC_MSG_RESULT(found $LL_INT_TYPE (cached))
|
||||||
|
+elif test -r /dev/bpf0 ; then
|
||||||
|
AC_LIBOBJ([libnet_link_bpf])
|
||||||
|
AC_MSG_RESULT(found bpf)
|
||||||
|
elif test -r /usr/include/net/pfilt.h ; then
|
Loading…
x
Reference in New Issue
Block a user