[packages] coreutils: update to 8.16

git-svn-id: svn://svn.openwrt.org/openwrt/packages@32156 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
luka 2012-06-10 01:32:23 +00:00
parent a2a85d11c8
commit 0a1267638a
3 changed files with 30 additions and 29 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2008-2010 OpenWrt.org # Copyright (C) 2008-2012 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,26 +8,28 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=coreutils PKG_NAME:=coreutils
PKG_VERSION:=8.8 PKG_VERSION:=8.16
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/coreutils PKG_SOURCE_URL:=@GNU/coreutils
PKG_MD5SUM:=bad596d9654e299eedea0eaf93f178fa PKG_MD5SUM:=89b06f91634208dceba7b36ad1f9e8b9
PKG_BUILD_DEPENDS:=libpthread PKG_BUILD_DEPENDS:=libpthread
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk
COREUTILS_APPLETS:=\ COREUTILS_APPLETS := \
base64 basename cat chcon chgrp chmod chown chroot cksum comm cp \ base64 basename cat chcon chgrp chmod chown chroot cksum comm cp csplit \
csplit cut date dd dir dircolors dirname du echo env expand expr \ cut date dd dir dircolors dirname du echo env expand expr factor \
factor false fmt fold groups head hostid id install join kill link \ false fmt fold groups head hostid id install join kill link ln logname \
ln logname ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup nproc \ ls md5sum mkdir mkfifo mknod mktemp mv nice nl nohup nproc od paste \
od paste pathchk pinky pr printenv printf ptx pwd readlink rm rmdir \ pathchk pinky pr printenv printf ptx pwd readlink realpath rm rmdir \
runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred shuf \ runcon seq sha1sum sha224sum sha256sum sha384sum sha512sum shred \
sleep sort split stat stdbuf stty su sum sync tac tail tee test timeout \ shuf sleep sort split stat stdbuf stty sum sync tac tail tee test \
touch tr true truncate tsort tty uname unexpand uniq unlink uptime users \ timeout touch tr true truncate tsort tty uname unexpand uniq unlink \
vdir wc who whoami yes uptime users vdir wc who whoami yes
define Package/coreutils/Default define Package/coreutils/Default
SECTION:=utils SECTION:=utils
@ -43,9 +45,9 @@ define Package/coreutils
endef endef
define Package/coreutils/description define Package/coreutils/description
Full versions of standard GNU utilities. Normally, you would not Full versions of standard GNU utilities. Normally, you would not use this
use this package, since the functionality in BusyBox is more than package, since the functionality in BusyBox is more than sufficient and
sufficient and much smaller. smaller.
endef endef
define GenPlugin define GenPlugin
@ -56,9 +58,8 @@ define GenPlugin
endef endef
define Package/$(1)/description define Package/$(1)/description
Full version of standard GNU $(2) utility. Normally, you would not Full version of standard GNU $(2) utility. Normally, you would not use this
use this package, since the functionality in BusyBox is more than package, since the functionality in BusyBox is more than sufficient.
sufficient.
endef endef
endef endef

View File

@ -11,7 +11,7 @@
ChangeLog-2005 \ ChangeLog-2005 \
--- a/Makefile.in --- a/Makefile.in
+++ b/Makefile.in +++ b/Makefile.in
@@ -1238,7 +1238,7 @@ top_srcdir = @top_srcdir@ @@ -1639,7 +1639,7 @@ top_srcdir = @top_srcdir@
# Some tests always need root privileges, others need them only sometimes. # Some tests always need root privileges, others need them only sometimes.
ALL_RECURSIVE_TARGETS = install-root check-root distcheck-hook ALL_RECURSIVE_TARGETS = install-root check-root distcheck-hook

View File

@ -1,6 +1,6 @@
--- a/lib/pthread.in.h --- a/lib/pthread.in.h
+++ b/lib/pthread.in.h +++ b/lib/pthread.in.h
@@ -225,6 +225,9 @@ @@ -232,6 +232,9 @@ pthread_mutex_unlock (pthread_mutex_t *m
/* Approximate spinlocks with mutexes. */ /* Approximate spinlocks with mutexes. */