Upgrade wpa_supplicant to 0.5.5 (#841)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@5157 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2006-10-16 09:31:21 +00:00
parent 481004df21
commit 0a4aea9952
3 changed files with 2 additions and 41 deletions

View File

@ -9,9 +9,9 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=wpa_supplicant
PKG_VERSION:=0.4.9
PKG_VERSION:=0.5.5
PKG_RELEASE:=1
PKG_MD5SUM:=98498c152cbfc388c306fd9bbf7d57d4
PKG_MD5SUM:=482dd85949c82aa15309e5ab3d2cf5c3
PKG_SOURCE_URL:=http://hostap.epitest.fi/releases
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@ -71,6 +71,3 @@ endef
$(eval $(call BuildPackage,wpa-supplicant))
$(eval $(call BuildPackage,wpa-cli))

View File

@ -1,24 +0,0 @@
--- wpa_supplicant-0.3.8/Makefile.orig 2005-05-22 12:37:28.000000000 +0200
+++ wpa_supplicant-0.3.8/Makefile 2005-05-22 12:40:04.000000000 +0200
@@ -304,7 +304,7 @@
OBJS += wpa_supplicant.o wpa.o l2_packet.o drivers.o
wpa_supplicant: .config $(OBJS)
- $(CC) -o wpa_supplicant $(OBJS) $(LIBS)
+ $(CC) $(LDFLAGS) -o wpa_supplicant $(OBJS) $(LIBS)
eapol_test: .config $(OBJS_t)
$(CC) -o eapol_test $(OBJS_t) $(LIBS)
@@ -313,10 +313,10 @@
$(CC) -o preauth_test $(OBJS_t2) $(LIBS)
wpa_passphrase: $(OBJS_p)
- $(CC) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
+ $(CC) $(LDFLAGS) -o wpa_passphrase $(OBJS_p) $(LIBS_p)
wpa_cli: $(OBJS_c)
- $(CC) -o wpa_cli $(OBJS_c) $(LIBS_c)
+ $(CC) $(LDFLAGS) -o wpa_cli $(OBJS_c) $(LIBS_c)
win_if_list: win_if_list.c
$(CC) -o $@ win_if_list.c $(CFLAGS) $(LIBS_w)

View File

@ -1,12 +0,0 @@
--- wpa_supplicant-0.3.8/Makefile.orig 2005-02-14 02:55:47.000000000 +0100
+++ wpa_supplicant-0.3.8/Makefile 2005-05-21 21:06:03.000000000 +0200
@@ -3,7 +3,8 @@
endif
ifndef CFLAGS
-CFLAGS = -MMD -O2 -Wall -g
+OPT_FLAGS = -O2 -g
+CFLAGS = -MMD $(OPT_FLAGS) -Wall
endif
# Include directories for CVS version