Fix fcgi compilation

git-svn-id: svn://svn.openwrt.org/openwrt/packages@8513 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2007-08-28 09:20:02 +00:00
parent 9cc0e31013
commit 0c2b5d38a1
2 changed files with 45 additions and 0 deletions

View File

@ -15,3 +15,24 @@ Index: fcgi-2.4.0/include/fcgio.h
// Use a buffer. The only reasons that a buffer would be useful is
// to support the use of the unget()/putback() or seek() methods. Using
diff -urN fcgi-2.4.0/libfcgi/fcgio.cpp fcgi-2.4.0.new/libfcgi/fcgio.cpp
--- fcgi-2.4.0/libfcgi/fcgio.cpp 2002-02-24 21:12:22.000000000 +0100
+++ fcgi-2.4.0.new/libfcgi/fcgio.cpp 2007-08-28 11:22:22.000000000 +0200
@@ -89,7 +89,7 @@
}
// uflow() removes the char, underflow() doesn't
-int fcgi_streambuf::uflow()
+short int fcgi_streambuf::uflow()
{
int rv = underflow();
if (this->bufsize) gbump(1);
@@ -97,7 +97,7 @@
}
// Note that the expected behaviour when there is no buffer varies
-int fcgi_streambuf::underflow()
+short int fcgi_streambuf::underflow()
{
if (this->bufsize)
{

View File

@ -0,0 +1,24 @@
diff -urN fcgi-2.4.0/Makefile.am fcgi-2.4.0.new/Makefile.am
--- fcgi-2.4.0/Makefile.am 2001-12-22 14:05:39.000000000 +0100
+++ fcgi-2.4.0.new/Makefile.am 2007-08-28 11:05:10.000000000 +0200
@@ -4,7 +4,7 @@
# $Id: Makefile.am,v 1.7 2001/12/22 13:05:39 robs Exp $
#
-SUBDIRS = libfcgi cgi-fcgi examples include
+SUBDIRS = libfcgi cgi-fcgi include
include_HEADERS = fcgi_config.h
diff -urN fcgi-2.4.0/Makefile.in fcgi-2.4.0.new/Makefile.in
--- fcgi-2.4.0/Makefile.in 2003-01-19 18:21:15.000000000 +0100
+++ fcgi-2.4.0.new/Makefile.in 2007-08-28 11:04:55.000000000 +0200
@@ -93,7 +93,7 @@
am__quote = @am__quote@
install_sh = @install_sh@
-SUBDIRS = libfcgi cgi-fcgi examples include
+SUBDIRS = libfcgi cgi-fcgi include
include_HEADERS = fcgi_config.h