[package] update strace to 4.5.19 (#6280)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@18654 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-12-05 01:06:58 +00:00
parent ff2edfb590
commit 0d7ec9722e
2 changed files with 4 additions and 38 deletions

View File

@ -8,16 +8,15 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=strace
PKG_RELEASE:=2
PKG_RELEASE:=1
OLD_KERNEL=$(findstring y,$(foreach v,23 24 25 26,$(CONFIG_LINUX_2_6_$(v))))
ifneq ($(OLD_KERNEL),)
ifeq ($(CONFIG_LINUX_2_6_25),y)
PKG_VERSION:=4.5.16
PKG_MD5SUM:=77f66d09aa82981bb6d65fa19a2c1ba9
PATCH_DIR:=patches-4.5.16
else
PKG_VERSION:=4.5.18
PKG_MD5SUM:=e9449fcee97e6a8ed73934c883c870e0
PKG_VERSION:=4.5.19
PKG_MD5SUM:=2415e435d61e40315a298c80aced0cda
endif
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2

View File

@ -1,33 +0,0 @@
--- a/linux/arm/syscallent.h
+++ b/linux/arm/syscallent.h
@@ -431,7 +431,7 @@
{ 5, 0, printargs, "SYS_398" }, /* 398 */
{ 5, 0, printargs, "SYS_399" }, /* 399 */
-#if SYS_socket_subcall != 400
+#if defined(SYS_socket_subcall) && (SYS_socket_subcall != 400)
#error fix me
#endif
{ 8, 0, printargs, "socket_subcall"}, /* 400 */
@@ -453,7 +453,7 @@
{ 5, TN, sys_sendmsg, "sendmsg" }, /* 416 */
{ 5, TN, sys_recvmsg, "recvmsg" }, /* 417 */
-#if SYS_ipc_subcall != 418
+#if defined(SYS_ipc_subcall) && (SYS_ipc_subcall != 418)
#error fix me
#endif
{ 4, 0, printargs, "ipc_subcall" }, /* 418 */
--- a/system.c
+++ b/system.c
@@ -70,10 +70,6 @@
#include <linux/capability.h>
#endif
-#ifdef SYS_cacheflush
-#include <asm/cachectl.h>
-#endif
-
#ifdef HAVE_LINUX_USTNAME_H
#include <linux/utsname.h>
#endif