Update dibbler to 0.6.0, should fix (#1756)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7357 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
5572708bfb
commit
0d93fe4b6c
@ -9,7 +9,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=dibbler
|
||||
PKG_VERSION:=0.5.0
|
||||
PKG_VERSION:=0.6.0
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
|
||||
|
@ -1,55 +0,0 @@
|
||||
diff -ruN dibbler-0.5.0-old/Makefile dibbler-0.5.0-new/Makefile
|
||||
--- dibbler-0.5.0-old/Makefile 2006-10-06 00:58:22.000000000 +0200
|
||||
+++ dibbler-0.5.0-new/Makefile 2007-01-31 18:03:24.000000000 +0100
|
||||
@@ -50,7 +50,8 @@
|
||||
-L$(MISC) -lMisc \
|
||||
-L$(MESSAGES) -lMsg \
|
||||
-lClntOptions -lOptions -lLowLevel \
|
||||
- -L$(POSLIB) $(CLNTPOSLIB)
|
||||
+ -L$(POSLIB) $(CLNTPOSLIB) \
|
||||
+ $(CLNT_LIBS)
|
||||
|
||||
ifndef MOD_CLNT_DISABLE_DNSUPDATE
|
||||
CLNTPOSLIB=-lposlib
|
||||
@@ -81,7 +82,9 @@
|
||||
-L$(OPTIONS) -lOptions \
|
||||
-L$(LOWLEVEL) -lLowLevel \
|
||||
-L$(IFACEMGR) -lIfaceMgr \
|
||||
- -L$(POSLIB) $(SRVPOSLIB)
|
||||
+ -L$(POSLIB) $(SRVPOSLIB) \
|
||||
+ $(SRV_LIBS)
|
||||
+
|
||||
|
||||
ifndef MOD_SRV_DISABLE_DNSUPDATE
|
||||
SRVPOSLIB=-lposlib
|
||||
@@ -104,7 +107,8 @@
|
||||
-L$(MESSAGES) -lMsg \
|
||||
-L$(MISC) -lMisc \
|
||||
-L$(OPTIONS) -lOptions \
|
||||
- -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions
|
||||
+ -lMisc -lIfaceMgr -lLowLevel -lRelTransMgr -lRelCfgMgr -lRelMsg -lRelOptions -lOptions \
|
||||
+ $(SRV_LIBS)
|
||||
|
||||
objs: includes
|
||||
@for dir in $(COMMONSUBDIRS); do \
|
||||
diff -ruN dibbler-0.5.0-old/Makefile.inc dibbler-0.5.0-new/Makefile.inc
|
||||
--- dibbler-0.5.0-old/Makefile.inc 2006-08-22 02:11:49.000000000 +0200
|
||||
+++ dibbler-0.5.0-new/Makefile.inc 2007-01-31 17:43:07.000000000 +0100
|
||||
@@ -5,7 +5,7 @@
|
||||
BISONPP = $(PREFIX)/bison++/bison++ -S $(PREFIX)/bison++/bison.cc -H $(PREFIX)/bison++/bison.h
|
||||
|
||||
# === compiler options ===
|
||||
-COPTS = -D$(ARCH) $(PORT_CFLAGS) $(XMLCFLAGS) -I $(INCDIR) $(DEBUGINFO) -Wall -funsigned-char -O0 $(PEDANTIC)
|
||||
+COPTS = -D$(ARCH) $(PORT_CFLAGS) $(XMLCFLAGS) -I $(INCDIR) $(DEBUGINFO) -Wall -funsigned-char $(PEDANTIC)
|
||||
OPTS = -ftemplate-depth-40 $(COPTS) $(CFLAGS) $(CXXFLAGS)
|
||||
|
||||
# === linker options ===
|
||||
@@ -124,7 +124,7 @@
|
||||
|
||||
%.a: objs
|
||||
@echo "[LIB ] $(SUBDIR)/$@"
|
||||
- ar cr $@ $(OBJECTS)
|
||||
+ $(AR) cr $@ $(OBJECTS)
|
||||
|
||||
all: libs
|
||||
|
@ -1,12 +0,0 @@
|
||||
diff -ruN dibbler-0.5.0-old/Makefile.inc dibbler-0.5.0-new/Makefile.inc
|
||||
--- dibbler-0.5.0-old/Makefile.inc 2006-08-22 02:11:49.000000000 +0200
|
||||
+++ dibbler-0.5.0-new/Makefile.inc 2007-01-31 17:43:07.000000000 +0100
|
||||
@@ -64,7 +64,7 @@
|
||||
#XMLLIBS = `pkg-config libxml-2.0 --libs`
|
||||
|
||||
# === do not modify anything below ===
|
||||
-MAKEFLAGS += -s
|
||||
+#MAKEFLAGS += -s
|
||||
VERSION = `$(TOPDIR)/test/xtract_version`
|
||||
INST_WORKDIR = $(DESTDIR)'/var/lib/dibbler'
|
||||
INST_MANDIR = $(DESTDIR)'/usr/local/man'
|
@ -1,11 +0,0 @@
|
||||
diff -ruN dibbler-0.5.0-old/Port-linux/utils.h dibbler-0.5.0-new/Port-linux/utils.h
|
||||
--- dibbler-0.5.0-old/Port-linux/utils.h 2006-01-12 01:23:35.000000000 +0100
|
||||
+++ dibbler-0.5.0-new/Port-linux/utils.h 2007-01-31 17:44:42.000000000 +0100
|
||||
@@ -2,6 +2,7 @@
|
||||
#define __UTILS_H__ 1
|
||||
|
||||
#include <asm/types.h>
|
||||
+#include <linux/types.h>
|
||||
#include <linux/inetdevice.h>
|
||||
#include <resolv.h>
|
||||
|
Loading…
x
Reference in New Issue
Block a user