[package] babeld: upstream release 1.1.3

New option: -u (keep unfeasible routes), called "keep_unfeasible" in UCI.

git-svn-id: svn://svn.openwrt.org/openwrt/packages@27933 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
kerneis 2011-08-08 13:23:37 +00:00
parent 263a36402f
commit 0f5933c38c
4 changed files with 8 additions and 23 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=babeld
PKG_VERSION:=1.1.0
PKG_RELEASE:=3
PKG_VERSION:=1.1.3
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.pps.jussieu.fr/~jch/software/files/
PKG_MD5SUM:=0627cdc9a5ce77a032c4399c3fa64bd1
PKG_MD5SUM:=673a813e7e8fe0818fbb062a896646d2
include $(INCLUDE_DIR)/package.mk

View File

@ -20,6 +20,8 @@ config general
# option 'debug' '0'
# Listen for connections from a front-end, e.g. on port 33123.
## option 'local_server' '33123'
# Keep unfeasible routes
## option 'keep_unfeasible' 'false'
# Use the given kernel routing table for routes inserted by babeld.
## option 'export_table' '0'
# Export routes from the given kernel routing table.
@ -41,9 +43,9 @@ config interface wlan
# option 'split_horizon' 'auto'
# The default is 96 for wired interfaces, and 256 for wireless ones
## option 'rxcost' '256'
# The default is specified with the -h and -H command-line flags.
# The default is specified with the -h and -H command-line flags.
## option 'hello_interval' '4'
# This can be set to a fairly large value, unless significant
# This can be set to a fairly large value, unless significant
# packet loss is expected. The default is four times the hello
# interval.
## option 'update_interval' '16'

View File

@ -109,6 +109,7 @@ babel_config() {
append_parm "$cfg" 'duplication_priority' '-A'
append_parm "$cfg" 'debug' '-d'
append_parm "$cfg" 'local_server' '-g'
append_parm "$cfg" 'keep_unfeasible' '-u'
append_parm "$cfg" 'export_table' '-t'
append_parm "$cfg" 'import_table' '-T'
append_parm "$cfg" 'conf_file' '-c'

View File

@ -1,18 +0,0 @@
Sat Mar 5 19:13:54 CET 2011 Gabriel Kerneis <kerneis@pps.jussieu.fr>
* Fix unique id in local_notify_route
diff -rN -u old-babeld/local.c new-babeld/local.c
--- old-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
+++ new-babeld/local.c 2011-03-14 14:37:03.000000000 +0100
@@ -197,11 +197,10 @@
return;
rc = snprintf(buf, 512,
- "%s route %s-%s-%lx prefix %s installed %s "
+ "%s route %s-%lx prefix %s installed %s "
"id %s metric %d refmetric %d via %s if %s\n",
local_kind(kind),
format_prefix(route->src->prefix, route->src->plen),
- format_eui64(route->src->id),
(unsigned long)route->neigh,
format_prefix(route->src->prefix, route->src->plen),
route->installed ? "yes" : "no",