[packages] libnetfilter-queue: update to v0.0.16, add dependency on kmod-nfnetlink-queue
git-svn-id: svn://svn.openwrt.org/openwrt/packages@14316 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
a3305c6908
commit
0f9b25a750
@ -7,13 +7,15 @@
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=libnetfilter_queue
|
||||
PKG_VERSION:=0.0.13
|
||||
PKG_VERSION:=0.0.16
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=ftp://ftp.netfilter.org/pub/libnetfilter_queue/
|
||||
PKG_MD5SUM:=660cbfd3dc8c10bf9b1803cd2b688256
|
||||
PKG_MD5SUM:=b36664e6cd39edbfe46b416a86118add
|
||||
|
||||
PKG_FIXUP:=libtool
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
@ -21,15 +23,14 @@ include $(INCLUDE_DIR)/package.mk
|
||||
define Package/libnetfilter-queue
|
||||
SECTION:=libs
|
||||
CATEGORY:=Libraries
|
||||
DEPENDS:=@LINUX_2_6 +libnfnetlink
|
||||
TITLE:=libnetfilter_queue
|
||||
URL:=http://www1.cs.columbia.edu/~angelos/libnetfilter_queue.html
|
||||
DEPENDS:=@LINUX_2_6 +libnfnetlink +kmod-nfnetlink-queue
|
||||
TITLE:=API to packets queued by the kernel packet filter
|
||||
URL:=http://www.netfilter.org/projects/libnetfilter_queue/
|
||||
endef
|
||||
|
||||
define Package/libnetfilter-queue/description
|
||||
libnetfilter_queue is a userspace library providing an API to packets
|
||||
that have been queued by the kernel packet filter. It is is part of a system
|
||||
that deprecates the old ip_queue / libipq mechanism.
|
||||
libnetfilter_queue is a userspace library providing an API to packets
|
||||
that have been queued by the kernel packet filter.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += $(FPIC)
|
||||
@ -62,7 +63,7 @@ define Build/InstallDev
|
||||
|
||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||
$(INSTALL_DATA) \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/* \
|
||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnetfilter_queue.pc \
|
||||
$(1)/usr/lib/pkgconfig/
|
||||
endef
|
||||
|
||||
|
@ -1,24 +0,0 @@
|
||||
diff -urN libnetfilter_queue-0.0.13/Makefile.am libnetfilter_queue-0.0.13.new/Makefile.am
|
||||
--- libnetfilter_queue-0.0.13/Makefile.am 2006-12-21 12:33:43.000000000 +0100
|
||||
+++ libnetfilter_queue-0.0.13.new/Makefile.am 2008-02-05 11:50:33.000000000 +0100
|
||||
@@ -2,7 +2,7 @@
|
||||
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
-SUBDIRS = include src utils
|
||||
+SUBDIRS = include src
|
||||
|
||||
man_MANS = #nfnetlink_queue.3 nfnetlink_queue.7
|
||||
|
||||
diff -urN libnetfilter_queue-0.0.13/Makefile.in libnetfilter_queue-0.0.13.new/Makefile.in
|
||||
--- libnetfilter_queue-0.0.13/Makefile.in 2006-12-21 12:40:47.000000000 +0100
|
||||
+++ libnetfilter_queue-0.0.13.new/Makefile.in 2008-02-05 11:50:27.000000000 +0100
|
||||
@@ -149,7 +149,7 @@
|
||||
|
||||
EXTRA_DIST = $(man_MANS)
|
||||
|
||||
-SUBDIRS = include src utils
|
||||
+SUBDIRS = include src
|
||||
|
||||
man_MANS = #nfnetlink_queue.3 nfnetlink_queue.7
|
||||
|
Loading…
x
Reference in New Issue
Block a user