more perl packages

git-svn-id: svn://svn.openwrt.org/openwrt/packages@11628 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
matteo 2008-07-03 12:31:32 +00:00
parent 61173f388a
commit 0fdbb66a65
11 changed files with 396 additions and 5 deletions

View File

@ -0,0 +1,42 @@
# $Id: Makefile 4033 2006-06-21 02:32:39Z nbd $
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-compress-bzip2
PKG_VERSION:=2.09
PKG_RELEASE:=2
PKG_MD5SUM:=1699fde3e86f2a036f135ae606d456bf
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/A/AR/ARJAY
PKG_SOURCE:=Compress-Bzip2-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/Compress-Bzip2-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-compress-bzip2
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Perl interface to bzip2 compression library
URL:=http://search.cpan.org/~arjay/Compress-Bzip2-2.09/
DEPENDS:=perl
endef
define Build/Configure
$(call perlmod/Configure,,BUILD_BZLIB=0)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-compress-bzip2/install
$(call perlmod/Install,$(1),Compress auto/Compress)
endef
$(eval $(call BuildPackage,perl-compress-bzip2))

42
lang/perl-dbi/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-dbi
PKG_VERSION:=1.604
PKG_RELEASE:=1
PKG_MD5SUM:=358511d60eb3daba913d49236c469802
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/T/TI/TIMB/
PKG_SOURCE:=DBI-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/DBI-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-dbi
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Database independent interface for Perl
URL:=http://search.cpan.org/~timb/DBI/
DEPENDS:=perl
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-dbi/install
$(call perlmod/Install,$(1),DB* auto/DBI,DBI/W32ODBC.pm auto/DBI/*.h)
endef
$(eval $(call BuildPackage,perl-dbi))

View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-html-parser
PKG_VERSION:=3.56
PKG_RELEASE:=1
PKG_MD5SUM:=bddc432e5ed9df4d4153a62234f04fc2
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/G/GA/GAAS
PKG_SOURCE:=HTML-Parser-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Parser-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-html-parser
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=A collection of modules that parse HTML text documents
URL:=http://search.cpan.org/~gaas/HTML-Parser/
DEPENDS:=perl perl-html-tagset perl-uri
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-html-parser/install
$(call perlmod/Install,$(1),HTML auto/HTML)
endef
$(eval $(call BuildPackage,perl-html-parser))

View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-html-tagset
PKG_VERSION:=3.20
PKG_RELEASE:=1
PKG_MD5SUM:=d2bfa18fe1904df7f683e96611e87437
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/P/PE/PETDANCE
PKG_SOURCE:=HTML-Tagset-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tagset-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-html-tagset
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Data tables pertaining to HTML
URL:=http://search.cpan.org/~petdance/HTML-Tagset/
DEPENDS:=perl
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-html-tagset/install
$(call perlmod/Install,$(1),HTML)
endef
$(eval $(call BuildPackage,perl-html-tagset))

View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-html-tree
PKG_VERSION:=3.23
PKG_RELEASE:=2
PKG_MD5SUM:=6352f50be402301f79b580dd235d7762
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/P/PE/PETEK
PKG_SOURCE:=HTML-Tree-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/HTML-Tree-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-html-tree
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=represent and create HTML syntax trees
URL:=http://search.cpan.org/~petdance/HTML-Tree/
DEPENDS:=perl perl-html-parser perl-html-tagset
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-html-tree/install
$(call perlmod/Install,$(1),HTML)
endef
$(eval $(call BuildPackage,perl-html-tree))

View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-lockfile-simple
PKG_VERSION:=0.206
PKG_RELEASE:=1
PKG_MD5SUM:=d8966c3fb799aefcaaf80f845057a1fa
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/J/JV/JV
PKG_SOURCE:=LockFile-Simple-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/LockFile-Simple-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-lockfile-simple
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Simple advisory file locking
URL:=http://search.cpan.org/~ram/LockFile-Simple/
DEPENDS:=perl
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-lockfile-simple/install
$(call perlmod/Install,$(1),LockFile auto/LockFile)
endef
$(eval $(call BuildPackage,perl-lockfile-simple))

42
lang/perl-uri/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-uri
PKG_VERSION:=1.36
PKG_RELEASE:=1
PKG_MD5SUM:=a97bbdd38b31c6b2672fdc3060fae34b
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/G/GA/GAAS
PKG_SOURCE:=URI-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/URI-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-uri
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Manipulates and accesses URI strings
URL:=http://search.cpan.org/dist/URI/
DEPENDS:=perl
endef
define Build/Configure
$(call perlmod/Configure,,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-uri/install
$(call perlmod/Install,$(1),URI URI.pm)
endef
$(eval $(call BuildPackage,perl-uri))

View File

@ -0,0 +1,42 @@
# $Id: Makefile 4033 2006-06-21 02:32:39Z nbd $
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-www-curl
PKG_VERSION:=4.00
PKG_RELEASE:=1
PKG_MD5SUM:=f34eb29f59a811869a4f77bfc0df2f5d
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/S/SZ/SZBALINT
PKG_SOURCE:=WWW-Curl-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/WWW-Curl-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-www-curl
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=Perl bindings to libcurl
URL:=http://search.cpan.org/~crisb/WWW-Curl-3.02/
DEPENDS:=libcurl perl
endef
define Build/Configure
$(call perlmod/Configure,$(STAGING_DIR)/usr/include,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-www-curl/install
$(call perlmod/Install,$(1),WWW/Curl WWW/Curl.pm auto/WWW/Curl)
endef
$(eval $(call BuildPackage,perl-www-curl))

View File

@ -0,0 +1,11 @@
--- WWW-Curl-4.00.config/Makefile.PL 2008-04-21 23:18:39.000000000 +0200
+++ WWW-Curl-4.00/Makefile.PL 2008-04-21 23:18:52.000000000 +0200
@@ -11,7 +11,7 @@
no_index directory => 'template';
# This is a hack. If you have libcurl installed, just specify curl.h below
# and comment out this line.
-requires_external_bin 'curl-config';
+#requires_external_bin 'curl-config';
# This utility helper generates the constants function from curl.h
# It is normally only used by the maintainer, but if you're curl is older

42
lang/perl-www/Makefile Normal file
View File

@ -0,0 +1,42 @@
# $Id$
include $(TOPDIR)/rules.mk
PKG_NAME:=perl-www
PKG_VERSION:=5.812
PKG_RELEASE:=1
PKG_MD5SUM:=86c6121170efe55fc0d33cdc967561bc
PKG_SOURCE_URL:=http://search.cpan.org/CPAN/authors/id/G/GA/GAAS
PKG_SOURCE:=libwww-perl-$(PKG_VERSION).tar.gz
PKG_CAT:=zcat
PKG_BUILD_DIR:=$(BUILD_DIR)/perl/libwww-perl-$(PKG_VERSION)
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
include $(INCLUDE_DIR)/package.mk
include ../perl/perlmod.mk
define Package/perl-www
SUBMENU:=Perl
SECTION:=lang
CATEGORY:=Languages
TITLE:=WWW client/server library for Perl (aka LWP)
URL:=http://search.cpan.org/dist/libwww-perl/
DEPENDS:=perl perl-html-parser perl-uri
endef
define Build/Configure
$(call perlmod/Configure,-n,)
endef
define Build/Compile
$(call perlmod/Compile,,)
endef
define Package/perl-www/install
$(call perlmod/Install,$(1),File HTML HTTP LWP LWP.pm Net WWW)
endef
$(eval $(call BuildPackage,perl-www))

View File

@ -33,16 +33,12 @@ define Package/perl/Default
URL:=http://www.perl.com/
endef
define Package/perl/Default/description
Perl rocks
endef
define Package/microperl
$(call Package/perl/Default)
TITLE+=(minimal version)
endef
define Package/perl/description
define Package/microperl/description
$(call Package/perl/Default/description)
A perl package without operating-specific functions such as readdir.
endef
@ -84,6 +80,12 @@ $(call Package/perl/Default)
MAINTAINER:=Peter Colberg <peter@petercolberg.org>
endef
define Package/perl/description
Perl is a stable, cross platform programming language.
It is used for mission critical projects in the public and private sectors
and is widely used to program web applications of all needs.
endef
define Build/perl/Configure
@echo
@echo "===> Stage 1: Configure host perl"