[packages] libaudiofile: update to 0.2.7
git-svn-id: svn://svn.openwrt.org/openwrt/packages@21020 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
561a63252a
commit
103c9ea6a2
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2006-2008 OpenWrt.org
|
# Copyright (C) 2006-2010 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -7,19 +7,21 @@
|
|||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libaudiofile
|
PKG_NAME:=audiofile
|
||||||
PKG_VERSION:=0.2.6
|
PKG_VERSION:=0.2.7
|
||||||
PKG_RELEASE:=2
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.cti.ecp.fr/~beauxir5/peercast
|
PKG_SOURCE_URL:= \
|
||||||
PKG_MD5SUM:=460f848ce5f4a33ae66b15a4fb7720ec
|
http://github.com/downloads/mpruett/audiofile/ \
|
||||||
|
http://www.68k.org/~michael/audiofile/
|
||||||
|
PKG_MD5SUM:=a39be317a7b1971b408805dc5e371862
|
||||||
|
|
||||||
PKG_FIXUP:=libtool
|
PKG_FIXUP:=libtool
|
||||||
|
PKG_INSTALL=1
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
PKG_INSTALL=1
|
|
||||||
|
|
||||||
define Package/libaudiofile
|
define Package/libaudiofile
|
||||||
SECTION:=libs
|
SECTION:=libs
|
||||||
CATEGORY:=Libraries
|
CATEGORY:=Libraries
|
||||||
@ -28,24 +30,21 @@ define Package/libaudiofile
|
|||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/libaudiofile/description
|
define Package/libaudiofile/description
|
||||||
The audiofile library allows the processing of audio data to and from audio
|
The audiofile library allows the processing of audio data to and from audio
|
||||||
files of many common formats (currently AIFF, AIFF-C, WAVE, NeXT/Sun, BICS,
|
files of many common formats (currently AIFF, AIFF-C, WAVE, NeXT/Sun, BICS,
|
||||||
and raw data).
|
and raw data).
|
||||||
endef
|
endef
|
||||||
|
|
||||||
TARGET_CFLAGS += $(FPIC)
|
CONFIGURE_ARGS+= \
|
||||||
|
--enable-shared \
|
||||||
|
--enable-static \
|
||||||
|
--with-build-cc="$(HOSTCC)" \
|
||||||
|
|
||||||
define Build/Configure
|
TARGET_CFLAGS+= $(FPIC) -std=c99
|
||||||
$(call Build/Configure/Default, \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--with-build-cc="$(HOSTCC)" \
|
|
||||||
)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
$(INSTALL_DIR) $(2)/bin
|
$(INSTALL_DIR) $(2)/bin
|
||||||
$(INSTALL_BIN) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/bin/audiofile-config \
|
$(PKG_INSTALL_DIR)/usr/bin/audiofile-config \
|
||||||
$(2)/bin/
|
$(2)/bin/
|
||||||
$(SED) \
|
$(SED) \
|
||||||
@ -53,7 +52,7 @@ define Build/InstallDev
|
|||||||
$(2)/bin/audiofile-config
|
$(2)/bin/audiofile-config
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
$(INSTALL_DIR) $(1)/usr/include
|
||||||
$(INSTALL_DATA) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/include/{af_vfs,audiofile,aupvlist}.h \
|
$(PKG_INSTALL_DIR)/usr/include/{af_vfs,audiofile,aupvlist}.h \
|
||||||
$(1)/usr/include/
|
$(1)/usr/include/
|
||||||
|
|
||||||
@ -63,7 +62,7 @@ define Build/InstallDev
|
|||||||
$(1)/usr/lib/
|
$(1)/usr/lib/
|
||||||
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
|
||||||
$(INSTALL_DATA) \
|
$(CP) \
|
||||||
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/audiofile.pc \
|
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/audiofile.pc \
|
||||||
$(1)/usr/lib/pkgconfig/
|
$(1)/usr/lib/pkgconfig/
|
||||||
endef
|
endef
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- libaudiofile-0.2.6/audiofile-config.in.orig 2004-03-06 07:39:23.000000000 +0100
|
--- a/audiofile-config.in
|
||||||
+++ libaudiofile-0.2.6/audiofile-config.in 2005-12-13 14:15:52.000000000 +0100
|
+++ b/audiofile-config.in
|
||||||
@@ -45,7 +45,9 @@
|
@@ -45,7 +45,9 @@ while test $# -gt 0; do
|
||||||
echo $includes
|
echo $includes
|
||||||
;;
|
;;
|
||||||
--libs)
|
--libs)
|
||||||
|
Loading…
x
Reference in New Issue
Block a user