[packages] vnstat: update to 1.11, drop obsolete patch
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27116 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9bce58293d
commit
106cfcd372
@ -1,5 +1,5 @@
|
||||
#
|
||||
# Copyright (C) 2006-2010 OpenWrt.org
|
||||
# Copyright (C) 2006-2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vnstat
|
||||
PKG_VERSION:=1.10
|
||||
PKG_RELEASE:=3
|
||||
PKG_VERSION:=1.11
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://humdi.net/vnstat
|
||||
PKG_MD5SUM:=95421d968689130590348ceb80ff74a8
|
||||
PKG_MD5SUM:=a5a113f9176cd61fb954f2ba297f5fdb
|
||||
|
||||
PKG_INSTALL:=1
|
||||
|
||||
|
@ -19,7 +19,7 @@
|
||||
@@ -127,12 +127,12 @@ bsdinstall:
|
||||
|
||||
# install binaries
|
||||
install -dm 755 $(DESTDIR)/var/db/vnstat
|
||||
install -d -m 755 $(DESTDIR)/var/db/vnstat
|
||||
- install -s -m 755 src/vnstat $(BIN_BSD)
|
||||
- install -s -m 755 src/vnstatd $(SBIN_BSD)
|
||||
+ install -m 755 src/vnstat $(BIN_BSD)
|
||||
|
@ -1,33 +0,0 @@
|
||||
vnstat's makefile uses the '-D' option which is only part of GNU install, thus compiling vnstat for OpenWrt on FreeBSD or Mac OS X fails because of the missing option.
|
||||
|
||||
Attached is a patch to have the install target separately create the destination directory before installing the vnstat.conf file to $(DEST)/etc. Additionally it also removes an erroneous tab character in the Makefile.
|
||||
|
||||
The patch is meant to go in feeds/packages/net/vnstat/patches/ directory.
|
||||
|
||||
TRAC Ticket: https://dev.openwrt.org/attachment/ticket/7718/
|
||||
|
||||
Signed-off-by: Joe Roback <joe@roback.cc>
|
||||
|
||||
Index: vnstat-1.10/Makefile
|
||||
===================================================================
|
||||
--- a/Makefile 2010-08-06 23:32:29.000000000 -0600
|
||||
+++ b/Makefile 2010-08-06 23:35:27.000000000 -0600
|
||||
@@ -43,7 +43,8 @@
|
||||
# install default config if such doesn't exist
|
||||
@if [ ! -f "$(DESTDIR)/etc/vnstat.conf" ]; \
|
||||
then echo "Installing config to $(DESTDIR)/etc/vnstat.conf"; \
|
||||
- install -D -m 644 cfg/vnstat.conf $(DESTDIR)/etc/vnstat.conf; \
|
||||
+ install -d -m 755 $(DESTDIR)/etc; \
|
||||
+ install -m 644 cfg/vnstat.conf $(DESTDIR)/etc/vnstat.conf; \
|
||||
fi
|
||||
|
||||
# install everything else
|
||||
@@ -63,7 +64,7 @@
|
||||
then echo install -m 644 man/vnstati.1 $(MAN)/man1; \
|
||||
install -m 644 man/vnstati.1 $(MAN)/man1; \
|
||||
fi
|
||||
-
|
||||
+
|
||||
@if [ -f $(MAN)/man1/vnstat.1.gz ]; \
|
||||
then gzip -f9 $(MAN)/man1/vnstat.1; \
|
||||
gzip -f9 $(MAN)/man1/vnstatd.1; \
|
Loading…
x
Reference in New Issue
Block a user