[package] update vpnc to 0.5.3 (#5648)

git-svn-id: svn://svn.openwrt.org/openwrt/packages@17192 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2009-08-09 10:33:55 +00:00
parent 93345fb2f8
commit 109bd4846d
4 changed files with 22 additions and 23 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=vpnc PKG_NAME:=vpnc
PKG_VERSION:=0.5.1 PKG_VERSION:=0.5.3
PKG_RELEASE:=1 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/ PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
PKG_MD5SUM:=7a8e94dbe94f39a4fd89b72e0125f66f PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
include $(INCLUDE_DIR)/package.mk include $(INCLUDE_DIR)/package.mk

View File

@ -1,7 +1,7 @@
--- a/Makefile --- a/Makefile
+++ b/Makefile +++ b/Makefile
@@ -20,7 +20,7 @@ @@ -20,7 +20,7 @@
# $Id: Makefile 236 2007-09-05 20:40:59Z Joerg Mayer $ # $Id: Makefile 312 2008-06-15 18:09:42Z Joerg Mayer $
DESTDIR= DESTDIR=
-PREFIX=/usr/local -PREFIX=/usr/local
@ -9,7 +9,7 @@
ETCDIR=/etc/vpnc ETCDIR=/etc/vpnc
BINDIR=$(PREFIX)/bin BINDIR=$(PREFIX)/bin
SBINDIR=$(PREFIX)/sbin SBINDIR=$(PREFIX)/sbin
@@ -50,14 +50,11 @@ @@ -51,14 +51,11 @@ RELEASE_VERSION := $(shell cat VERSION)
#OPENSSLLIBS = -lcrypto #OPENSSLLIBS = -lcrypto
CC=gcc CC=gcc

View File

@ -1,16 +1,16 @@
--- a/vpnc-script --- a/vpnc-script.in
+++ b/vpnc-script +++ b/vpnc-script.in
@@ -95,7 +95,7 @@ @@ -97,7 +97,7 @@ do_ifconfig() {
# =========== tunnel interface handling ====================================
do_ifconfig() {
- ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
+ ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
}
destroy_tun_device() {
@@ -490,6 +490,18 @@
fi fi
# Point to point interface require a netmask of 255.255.255.255 on some systems
- ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
+ ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
if [ -n "$INTERNAL_IP4_NETMASK" ]; then
set_network_route $INTERNAL_IP4_NETADDR $INTERNAL_IP4_NETMASK $INTERNAL_IP4_NETMASKLEN
@@ -503,6 +503,18 @@ do_disconnect() {
destroy_tun_device
} }
+start_vpn_nat() { +start_vpn_nat() {
@ -28,7 +28,7 @@
#### Main #### Main
if [ -z "$reason" ]; then if [ -z "$reason" ]; then
@@ -503,8 +515,10 @@ @@ -516,8 +528,10 @@ case "$reason" in
;; ;;
connect) connect)
do_connect do_connect

View File

@ -1,12 +1,11 @@
diff -urN vpnc-0.5.1/Makefile vpnc-0.5.1.new/Makefile --- a/Makefile
--- vpnc-0.5.1/Makefile 2007-09-06 22:05:15.000000000 +0200 +++ b/Makefile
+++ vpnc-0.5.1.new/Makefile 2008-07-05 15:30:04.000000000 +0200 @@ -69,7 +69,7 @@ vpnc : $(OBJS) vpnc.o
@@ -71,7 +71,7 @@
$(CC) -o $@ $^ $(LDFLAGS) $(CC) -o $@ $^ $(LDFLAGS)
vpnc.8 : vpnc.8.template makeman.pl vpnc vpnc.8 : vpnc.8.template makeman.pl vpnc
- ./makeman.pl - ./makeman.pl
+ touch vpnc.8 + touch vpnc.8
cisco-decrypt : cisco-decrypt.o config.o supp.o sysdep.o vpnc-debug.o vpnc-script : vpnc-script.in
$(CC) -o $@ $^ $(LDFLAGS) sed -e 's,@''PREFIX''@,$(PREFIX),g' $< > $@ && chmod 755 $@