[package] update vpnc to 0.5.3 (#5648)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@17192 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
93345fb2f8
commit
109bd4846d
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=vpnc
|
||||
PKG_VERSION:=0.5.1
|
||||
PKG_VERSION:=0.5.3
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://www.unix-ag.uni-kl.de/~massar/vpnc/
|
||||
PKG_MD5SUM:=7a8e94dbe94f39a4fd89b72e0125f66f
|
||||
PKG_MD5SUM:=4378f9551d5b077e1770bbe09995afb3
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
|
@ -1,7 +1,7 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -20,7 +20,7 @@
|
||||
# $Id: Makefile 236 2007-09-05 20:40:59Z Joerg Mayer $
|
||||
# $Id: Makefile 312 2008-06-15 18:09:42Z Joerg Mayer $
|
||||
|
||||
DESTDIR=
|
||||
-PREFIX=/usr/local
|
||||
@ -9,7 +9,7 @@
|
||||
ETCDIR=/etc/vpnc
|
||||
BINDIR=$(PREFIX)/bin
|
||||
SBINDIR=$(PREFIX)/sbin
|
||||
@@ -50,14 +50,11 @@
|
||||
@@ -51,14 +51,11 @@ RELEASE_VERSION := $(shell cat VERSION)
|
||||
#OPENSSLLIBS = -lcrypto
|
||||
|
||||
CC=gcc
|
||||
|
@ -1,16 +1,16 @@
|
||||
--- a/vpnc-script
|
||||
+++ b/vpnc-script
|
||||
@@ -95,7 +95,7 @@
|
||||
# =========== tunnel interface handling ====================================
|
||||
|
||||
do_ifconfig() {
|
||||
- ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
|
||||
+ ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu 1412 up
|
||||
}
|
||||
|
||||
destroy_tun_device() {
|
||||
@@ -490,6 +490,18 @@
|
||||
--- a/vpnc-script.in
|
||||
+++ b/vpnc-script.in
|
||||
@@ -97,7 +97,7 @@ do_ifconfig() {
|
||||
fi
|
||||
|
||||
# Point to point interface require a netmask of 255.255.255.255 on some systems
|
||||
- ifconfig "$TUNDEV" inet "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
|
||||
+ ifconfig "$TUNDEV" "$INTERNAL_IP4_ADDRESS" $ifconfig_syntax_ptp "$INTERNAL_IP4_ADDRESS" netmask 255.255.255.255 mtu ${MTU} up
|
||||
|
||||
if [ -n "$INTERNAL_IP4_NETMASK" ]; then
|
||||
set_network_route $INTERNAL_IP4_NETADDR $INTERNAL_IP4_NETMASK $INTERNAL_IP4_NETMASKLEN
|
||||
@@ -503,6 +503,18 @@ do_disconnect() {
|
||||
destroy_tun_device
|
||||
}
|
||||
|
||||
+start_vpn_nat() {
|
||||
@ -28,7 +28,7 @@
|
||||
#### Main
|
||||
|
||||
if [ -z "$reason" ]; then
|
||||
@@ -503,8 +515,10 @@
|
||||
@@ -516,8 +528,10 @@ case "$reason" in
|
||||
;;
|
||||
connect)
|
||||
do_connect
|
||||
|
@ -1,12 +1,11 @@
|
||||
diff -urN vpnc-0.5.1/Makefile vpnc-0.5.1.new/Makefile
|
||||
--- vpnc-0.5.1/Makefile 2007-09-06 22:05:15.000000000 +0200
|
||||
+++ vpnc-0.5.1.new/Makefile 2008-07-05 15:30:04.000000000 +0200
|
||||
@@ -71,7 +71,7 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -69,7 +69,7 @@ vpnc : $(OBJS) vpnc.o
|
||||
$(CC) -o $@ $^ $(LDFLAGS)
|
||||
|
||||
vpnc.8 : vpnc.8.template makeman.pl vpnc
|
||||
- ./makeman.pl
|
||||
+ touch vpnc.8
|
||||
|
||||
cisco-decrypt : cisco-decrypt.o config.o supp.o sysdep.o vpnc-debug.o
|
||||
$(CC) -o $@ $^ $(LDFLAGS)
|
||||
vpnc-script : vpnc-script.in
|
||||
sed -e 's,@''PREFIX''@,$(PREFIX),g' $< > $@ && chmod 755 $@
|
||||
|
Loading…
x
Reference in New Issue
Block a user