rtorrent: moved to github
git-svn-id: svn://svn.openwrt.org/openwrt/packages@41205 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f5e4d4d0a4
commit
111693ae3f
@ -1,92 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2007-2013 OpenWrt.org
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=rtorrent
|
|
||||||
PKG_VERSION:=0.9.3-git
|
|
||||||
PKG_RELEASE:=$(PKG_SOURCE_VERSION)-1
|
|
||||||
|
|
||||||
PKG_SOURCE_PROTO:=git
|
|
||||||
PKG_SOURCE_URL:=https://github.com/rakshasa/rtorrent.git
|
|
||||||
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
PKG_SOURCE_VERSION:=82a68420f4d90098e00cc92f082f10a8079e9800
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_BUILD_PARALLEL:=1
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/rtorrent/Default
|
|
||||||
SUBMENU:=BitTorrent
|
|
||||||
SECTION:=net
|
|
||||||
CATEGORY:=Network
|
|
||||||
TITLE:=BitTorrent client for ncurses
|
|
||||||
URL:=http://libtorrent.rakshasa.no/
|
|
||||||
DEPENDS:=+libcurl +libtorrent +libncursesw +libsigcxx +libpthread
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent/Default/description
|
|
||||||
rTorrent is a BitTorrent client for ncurses, using the libtorrent library.
|
|
||||||
The client and library is written in C++ with emphasis on speed and
|
|
||||||
efficiency, while delivering equivalent features to those found in GUI based
|
|
||||||
clients in an ncurses client.
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent
|
|
||||||
$(call Package/rtorrent/Default)
|
|
||||||
VARIANT:=norpc
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent/description
|
|
||||||
$(call Package/rtorrent/Default/description)
|
|
||||||
This package is built without xmlrpc support
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent-rpc
|
|
||||||
$(call Package/rtorrent/Default)
|
|
||||||
VARIANT:=rpc
|
|
||||||
DEPENDS+=+xmlrpc-c-server
|
|
||||||
TITLE+=(with rpc support)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent-rpc/description
|
|
||||||
$(call Package/rtorrent/Default/description)
|
|
||||||
This package is built with xmlrpc support
|
|
||||||
endef
|
|
||||||
|
|
||||||
TARGET_LDFLAGS += -lpthread -Wl,-rpath-link=$(STAGING_DIR)/usr/lib
|
|
||||||
|
|
||||||
CONFIGURE_ARGS+= \
|
|
||||||
--enable-shared \
|
|
||||||
--disable-static \
|
|
||||||
--disable-debug
|
|
||||||
|
|
||||||
ifeq ($(BUILD_VARIANT),rpc)
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--with-xmlrpc-c
|
|
||||||
endif
|
|
||||||
|
|
||||||
|
|
||||||
define Build/Configure
|
|
||||||
( cd $(PKG_BUILD_DIR); ./autogen.sh );
|
|
||||||
$(call Build/Configure/Default)
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/rtorrent/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/rtorrent $(1)/usr/bin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
Package/rtorrent-rpc/install = $(Package/rtorrent/install)
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,rtorrent))
|
|
||||||
$(eval $(call BuildPackage,rtorrent-rpc))
|
|
@ -1,30 +0,0 @@
|
|||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -4,7 +4,6 @@ AC_DEFINE(API_VERSION, 8, api version)
|
|
||||||
|
|
||||||
AM_INIT_AUTOMAKE
|
|
||||||
AC_CONFIG_HEADERS(config.h)
|
|
||||||
-AM_PATH_CPPUNIT(1.9.6)
|
|
||||||
|
|
||||||
AC_PROG_CXX
|
|
||||||
AC_PROG_LIBTOOL
|
|
||||||
--- a/scripts/common.m4
|
|
||||||
+++ b/scripts/common.m4
|
|
||||||
@@ -223,7 +223,7 @@ dnl Need to fix this so that it uses t
|
|
||||||
AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
|
||||||
AC_MSG_CHECKING(for execinfo.h)
|
|
||||||
|
|
||||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
|
||||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
||||||
#include <execinfo.h>
|
|
||||||
int main() { backtrace((void**)0, 0); backtrace_symbols((char**)0, 0); return 0;}
|
|
||||||
])],
|
|
||||||
@@ -238,7 +238,7 @@ AC_DEFUN([TORRENT_CHECK_EXECINFO], [
|
|
||||||
AC_DEFUN([TORRENT_CHECK_ALIGNED], [
|
|
||||||
AC_MSG_CHECKING(the byte alignment)
|
|
||||||
|
|
||||||
- AC_RUN_IFELSE([AC_LANG_SOURCE([
|
|
||||||
+ AC_LINK_IFELSE([AC_LANG_SOURCE([
|
|
||||||
#include <inttypes.h>
|
|
||||||
int main() {
|
|
||||||
char buf@<:@8@:>@ = { 0, 0, 0, 0, 1, 0, 0, 0 };
|
|
@ -1,11 +0,0 @@
|
|||||||
--- a/src/display/canvas.h
|
|
||||||
+++ b/src/display/canvas.h
|
|
||||||
@@ -48,7 +48,7 @@ class Canvas {
|
|
||||||
public:
|
|
||||||
typedef std::vector<Attributes> attributes_list;
|
|
||||||
|
|
||||||
- Canvas(int x = 0, int y = 0, int width = 0, int height = 0);
|
|
||||||
+ Canvas(int x = 0, int y = 0, int width = 1, int height = 1);
|
|
||||||
~Canvas() { delwin(m_window); }
|
|
||||||
|
|
||||||
void refresh() { wnoutrefresh(m_window); }
|
|
Loading…
x
Reference in New Issue
Block a user