packages: add md5deep, a program to compute, match, and audit hashsets (closes: #9100)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@29282 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
24ded30357
commit
1120674045
40
utils/md5deep/Makefile
Normal file
40
utils/md5deep/Makefile
Normal file
@ -0,0 +1,40 @@
|
||||
#
|
||||
# Copyright (C) 2011 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=md5deep
|
||||
PKG_VERSION:=3.7
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/$(PKG_NAME)
|
||||
PKG_MD5SUM:=d103b738721c54a9bf535470b63d49dc
|
||||
|
||||
PKG_FIXUP:=autoreconf
|
||||
PKG_INSTALL:=1
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
define Package/md5deep
|
||||
SECTION:=utils
|
||||
CATEGORY:=Utilities
|
||||
TITLE:=A program to compute, match and audit hashsets
|
||||
URL:=http://md5deep.sourceforge.net/
|
||||
endef
|
||||
|
||||
define Package/md5deep/description
|
||||
md5deep is a set of programs to compute MD5, SHA-1, SHA-256, Tiger, or
|
||||
Whirlpool message digests on an arbitrary number of files.
|
||||
endef
|
||||
|
||||
define Package/md5deep/install
|
||||
$(INSTALL_DIR) $(1)/usr/bin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/{hash,md5,sha1,sha256,tiger,whirlpool}deep $(1)/usr/bin/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,md5deep))
|
20
utils/md5deep/patches/101-cross_compile.patch
Normal file
20
utils/md5deep/patches/101-cross_compile.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -19,17 +19,6 @@ AC_PROG_INSTALL
|
||||
AC_CONFIG_FILES([Makefile hashdeep/Makefile md5deep/Makefile])
|
||||
AM_CONFIG_HEADER([config.h])
|
||||
|
||||
-# Bring additional directories where things might be found into our
|
||||
-# search path. I don't know why autoconf doesn't do this by default
|
||||
-for spfx in /usr/local /opt/local /sw ; do
|
||||
- echo checking ${spfx}/include
|
||||
- if test -d ${spfx}/include; then
|
||||
- CFLAGS="-I${spfx}/include $CFLAGS"
|
||||
- CPPFLAGS="-I${spfx}/include $CPPFLAGS"
|
||||
- LDFLAGS="-L${spfx}/lib $LDFLAGS"
|
||||
- fi
|
||||
-done
|
||||
-
|
||||
# Checks for header files.
|
||||
AC_HEADER_DIRENT
|
||||
AC_HEADER_STDC
|
Loading…
x
Reference in New Issue
Block a user