[packages] unbound: update to 1.4.22, drop libldns depends per upstream, update named.cache, refresh patches
Signed-off-by: Stephen Walker <stephendwalker+openwrt@gmail.com> git-svn-id: svn://svn.openwrt.org/openwrt/packages@40658 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
f7edb750d3
commit
11349c8778
@ -1,5 +1,5 @@
|
|||||||
#
|
#
|
||||||
# Copyright (C) 2010-2012 OpenWrt.org
|
# Copyright (C) 2010-2014 OpenWrt.org
|
||||||
#
|
#
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=unbound
|
PKG_NAME:=unbound
|
||||||
PKG_VERSION:=1.4.21
|
PKG_VERSION:=1.4.22
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://www.unbound.net/downloads
|
PKG_SOURCE_URL:=http://www.unbound.net/downloads
|
||||||
PKG_MD5SUM:=0aa8db06ea784bf7879060bd1f6551c8
|
PKG_MD5SUM:=59728c74fef8783f8bad1d7451eba97f
|
||||||
|
|
||||||
PKG_BUILD_DEPENDS:=libexpat
|
PKG_BUILD_DEPENDS:=libexpat
|
||||||
PKG_BUILD_PARALLEL:=1
|
PKG_BUILD_PARALLEL:=1
|
||||||
@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/package.mk
|
|||||||
define Package/unbound/Default
|
define Package/unbound/Default
|
||||||
TITLE:=A validating, recursive & caching DNS resolver
|
TITLE:=A validating, recursive & caching DNS resolver
|
||||||
URL:=http://www.unbound.net/
|
URL:=http://www.unbound.net/
|
||||||
DEPENDS:=+libldns
|
DEPENDS:=+libopenssl
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/unbound
|
define Package/unbound
|
||||||
@ -108,7 +108,6 @@ CONFIGURE_ARGS += \
|
|||||||
--disable-ecdsa \
|
--disable-ecdsa \
|
||||||
--disable-gost \
|
--disable-gost \
|
||||||
--enable-allsymbols \
|
--enable-allsymbols \
|
||||||
--with-ldns="$(STAGING_DIR)/usr" \
|
|
||||||
--with-libexpat="$(STAGING_DIR)/usr" \
|
--with-libexpat="$(STAGING_DIR)/usr" \
|
||||||
--with-ssl="$(STAGING_DIR)/usr" \
|
--with-ssl="$(STAGING_DIR)/usr" \
|
||||||
--without-pthreads
|
--without-pthreads
|
||||||
|
@ -9,8 +9,8 @@
|
|||||||
; on server FTP.INTERNIC.NET
|
; on server FTP.INTERNIC.NET
|
||||||
; -OR- RS.INTERNIC.NET
|
; -OR- RS.INTERNIC.NET
|
||||||
;
|
;
|
||||||
; last update: Jun 8, 2011
|
; last update: Mar 26, 2014
|
||||||
; related version of root zone: 2011060800
|
; related version of root zone: 2014032601
|
||||||
;
|
;
|
||||||
; formerly NS.INTERNIC.NET
|
; formerly NS.INTERNIC.NET
|
||||||
;
|
;
|
||||||
@ -27,11 +27,12 @@ B.ROOT-SERVERS.NET. 3600000 A 192.228.79.201
|
|||||||
;
|
;
|
||||||
. 3600000 NS C.ROOT-SERVERS.NET.
|
. 3600000 NS C.ROOT-SERVERS.NET.
|
||||||
C.ROOT-SERVERS.NET. 3600000 A 192.33.4.12
|
C.ROOT-SERVERS.NET. 3600000 A 192.33.4.12
|
||||||
|
C.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2::C
|
||||||
;
|
;
|
||||||
; FORMERLY TERP.UMD.EDU
|
; FORMERLY TERP.UMD.EDU
|
||||||
;
|
;
|
||||||
. 3600000 NS D.ROOT-SERVERS.NET.
|
. 3600000 NS D.ROOT-SERVERS.NET.
|
||||||
D.ROOT-SERVERS.NET. 3600000 A 128.8.10.90
|
D.ROOT-SERVERS.NET. 3600000 A 199.7.91.13
|
||||||
D.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2D::D
|
D.ROOT-SERVERS.NET. 3600000 AAAA 2001:500:2D::D
|
||||||
;
|
;
|
||||||
; FORMERLY NS.NASA.GOV
|
; FORMERLY NS.NASA.GOV
|
||||||
|
@ -29,7 +29,7 @@
|
|||||||
|
|
||||||
# buffer size for UDP port 53 incoming (SO_RCVBUF socket option).
|
# buffer size for UDP port 53 incoming (SO_RCVBUF socket option).
|
||||||
# 0 is system default. Use 4m to catch query spikes for busy servers.
|
# 0 is system default. Use 4m to catch query spikes for busy servers.
|
||||||
@@ -96,18 +101,22 @@ server:
|
@@ -99,18 +104,22 @@ server:
|
||||||
# buffer size for handling DNS data. No messages larger than this
|
# buffer size for handling DNS data. No messages larger than this
|
||||||
# size can be sent or received, by UDP or TCP. In bytes.
|
# size can be sent or received, by UDP or TCP. In bytes.
|
||||||
# msg-buffer-size: 65552
|
# msg-buffer-size: 65552
|
||||||
@ -52,7 +52,7 @@
|
|||||||
|
|
||||||
# if very busy, 50% queries run to completion, 50% get timeout in msec
|
# if very busy, 50% queries run to completion, 50% get timeout in msec
|
||||||
# jostle-timeout: 200
|
# jostle-timeout: 200
|
||||||
@@ -115,11 +124,13 @@ server:
|
@@ -121,11 +130,13 @@ server:
|
||||||
# the amount of memory to use for the RRset cache.
|
# the amount of memory to use for the RRset cache.
|
||||||
# plain value in bytes or you can append k, m or G. default is "4Mb".
|
# plain value in bytes or you can append k, m or G. default is "4Mb".
|
||||||
# rrset-cache-size: 4m
|
# rrset-cache-size: 4m
|
||||||
@ -66,7 +66,7 @@
|
|||||||
|
|
||||||
# the time to live (TTL) value lower bound, in seconds. Default 0.
|
# the time to live (TTL) value lower bound, in seconds. Default 0.
|
||||||
# If more than an hour could easily give trouble due to stale data.
|
# If more than an hour could easily give trouble due to stale data.
|
||||||
@@ -137,9 +148,11 @@ server:
|
@@ -143,9 +154,11 @@ server:
|
||||||
# the number of slabs must be a power of 2.
|
# the number of slabs must be a power of 2.
|
||||||
# more slabs reduce lock contention, but fragment memory usage.
|
# more slabs reduce lock contention, but fragment memory usage.
|
||||||
# infra-cache-slabs: 4
|
# infra-cache-slabs: 4
|
||||||
@ -78,7 +78,7 @@
|
|||||||
|
|
||||||
# Enable IPv4, "yes" or "no".
|
# Enable IPv4, "yes" or "no".
|
||||||
# do-ip4: yes
|
# do-ip4: yes
|
||||||
@@ -170,6 +183,8 @@ server:
|
@@ -178,6 +191,8 @@ server:
|
||||||
# access-control: ::0/0 refuse
|
# access-control: ::0/0 refuse
|
||||||
# access-control: ::1 allow
|
# access-control: ::1 allow
|
||||||
# access-control: ::ffff:127.0.0.1 allow
|
# access-control: ::ffff:127.0.0.1 allow
|
||||||
@ -87,7 +87,7 @@
|
|||||||
|
|
||||||
# if given, a chroot(2) is done to the given directory.
|
# if given, a chroot(2) is done to the given directory.
|
||||||
# i.e. you can chroot to the working directory, for example,
|
# i.e. you can chroot to the working directory, for example,
|
||||||
@@ -200,6 +215,7 @@ server:
|
@@ -208,6 +223,7 @@ server:
|
||||||
# and the given username is assumed. Default is user "unbound".
|
# and the given username is assumed. Default is user "unbound".
|
||||||
# If you give "" no privileges are dropped.
|
# If you give "" no privileges are dropped.
|
||||||
# username: "@UNBOUND_USERNAME@"
|
# username: "@UNBOUND_USERNAME@"
|
||||||
@ -95,7 +95,7 @@
|
|||||||
|
|
||||||
# the working directory. The relative files in this config are
|
# the working directory. The relative files in this config are
|
||||||
# relative to this directory. If you give "" the working directory
|
# relative to this directory. If you give "" the working directory
|
||||||
@@ -222,10 +238,12 @@ server:
|
@@ -230,10 +246,12 @@ server:
|
||||||
|
|
||||||
# the pid file. Can be an absolute path outside of chroot/work dir.
|
# the pid file. Can be an absolute path outside of chroot/work dir.
|
||||||
# pidfile: "@UNBOUND_PIDFILE@"
|
# pidfile: "@UNBOUND_PIDFILE@"
|
||||||
@ -108,7 +108,7 @@
|
|||||||
|
|
||||||
# enable to not answer id.server and hostname.bind queries.
|
# enable to not answer id.server and hostname.bind queries.
|
||||||
# hide-identity: no
|
# hide-identity: no
|
||||||
@@ -248,12 +266,15 @@ server:
|
@@ -256,12 +274,15 @@ server:
|
||||||
# positive value: fetch that many targets opportunistically.
|
# positive value: fetch that many targets opportunistically.
|
||||||
# Enclose the list of numbers between quotes ("").
|
# Enclose the list of numbers between quotes ("").
|
||||||
# target-fetch-policy: "3 2 1 0 0"
|
# target-fetch-policy: "3 2 1 0 0"
|
||||||
@ -124,7 +124,7 @@
|
|||||||
|
|
||||||
# Harden against out of zone rrsets, to avoid spoofing attempts.
|
# Harden against out of zone rrsets, to avoid spoofing attempts.
|
||||||
# harden-glue: yes
|
# harden-glue: yes
|
||||||
@@ -334,7 +355,7 @@ server:
|
@@ -342,7 +363,7 @@ server:
|
||||||
# you start unbound (i.e. in the system boot scripts). And enable:
|
# you start unbound (i.e. in the system boot scripts). And enable:
|
||||||
# Please note usage of unbound-anchor root anchor is at your own risk
|
# Please note usage of unbound-anchor root anchor is at your own risk
|
||||||
# and under the terms of our LICENSE (see that file in the source).
|
# and under the terms of our LICENSE (see that file in the source).
|
||||||
@ -133,7 +133,7 @@
|
|||||||
|
|
||||||
# File with DLV trusted keys. Same format as trust-anchor-file.
|
# File with DLV trusted keys. Same format as trust-anchor-file.
|
||||||
# There can be only one DLV configured, it is trusted from root down.
|
# There can be only one DLV configured, it is trusted from root down.
|
||||||
@@ -420,15 +441,18 @@ server:
|
@@ -428,15 +449,18 @@ server:
|
||||||
# the amount of memory to use for the key cache.
|
# the amount of memory to use for the key cache.
|
||||||
# plain value in bytes or you can append k, m or G. default is "4Mb".
|
# plain value in bytes or you can append k, m or G. default is "4Mb".
|
||||||
# key-cache-size: 4m
|
# key-cache-size: 4m
|
||||||
|
Loading…
x
Reference in New Issue
Block a user