[package] shorewall-core: add package
New package shorewall-core, current stable release 4.5.7 The Shoreline Firewall, is high-level tool for configuring Netfilter. This package provides the core Shorewall libraries installed in /usr/share/shorewall/, which are required for the rest of the Shorewall packages to work. Signed-off-by: Edy Corak <info@loenshotel.de> git-svn-id: svn://svn.openwrt.org/openwrt/packages@33797 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
7b1a366235
commit
1185fa326e
59
net/shorewall-core/Makefile
Normal file
59
net/shorewall-core/Makefile
Normal file
@ -0,0 +1,59 @@
|
|||||||
|
#
|
||||||
|
# Copyright (C) 2008-2012 OpenWrt.org
|
||||||
|
#
|
||||||
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
|
# See /LICENSE for more information.
|
||||||
|
#
|
||||||
|
|
||||||
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
|
PKG_NAME:=shorewall-core
|
||||||
|
PKG_VERSION:=4.5.7
|
||||||
|
PKG_DIRECTORY:=4.5.7
|
||||||
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
|
PKG_SOURCE_URL:=http://www.shorewall.net/pub/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://www1.shorewall.net/pub/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://slovakia.shorewall.net/pub/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://shorewall.de/pub/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://www.shorewall.com.au/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://shorewall.infohiiway.com/pub/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/ \
|
||||||
|
http://www.shorewall.com.ar/pub/shorewall/shorewall/4.5/shorewall-$(PKG_DIRECTORY)/
|
||||||
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||||
|
PKG_MD5SUM:=ed3880b96a22e16cafc68d2e0f976b3a
|
||||||
|
|
||||||
|
include $(INCLUDE_DIR)/package.mk
|
||||||
|
|
||||||
|
define Package/shorewall-core
|
||||||
|
SECTION:=net
|
||||||
|
CATEGORY:=Network
|
||||||
|
DEPENDS:=+ip +iptables +perl +perlbase-digest
|
||||||
|
TITLE:=Shorewall Core
|
||||||
|
URL:=http://www.shorewall.net/
|
||||||
|
SUBMENU:=Firewall
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/shorewall-core/description
|
||||||
|
The Shoreline Firewall, is high-level tool for configuring Netfilter.
|
||||||
|
This package provides the core Shorewall libraries installed in /usr/share/shorewall/,
|
||||||
|
which are required for the rest of the Shorewall packages to work.
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/shorewall-core/conffiles
|
||||||
|
/usr/share/shorewall/shorewallrc
|
||||||
|
endef
|
||||||
|
|
||||||
|
CONFIGURE_ARGS += \
|
||||||
|
vendor=linux
|
||||||
|
|
||||||
|
define Build/Compile
|
||||||
|
DESTDIR=$(PKG_INSTALL_DIR) $(PKG_BUILD_DIR)/install.sh
|
||||||
|
endef
|
||||||
|
|
||||||
|
define Package/shorewall-core/install
|
||||||
|
$(INSTALL_DIR) $(1)/usr/share
|
||||||
|
$(CP) $(PKG_INSTALL_DIR)/usr/share/shorewall $(1)/usr/share
|
||||||
|
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib/shorewall/wait4ifup $(1)/usr/share/shorewall
|
||||||
|
endef
|
||||||
|
|
||||||
|
$(eval $(call BuildPackage,shorewall-core))
|
11
net/shorewall-core/patches/100-shorewallrc.default.patch
Normal file
11
net/shorewall-core/patches/100-shorewallrc.default.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- a/shorewallrc.default 2012-08-08 16:29:23.000000000 +0200
|
||||||
|
+++ b/shorewallrc.default 2012-08-13 10:15:46.769381221 +0200
|
||||||
|
@@ -2,7 +2,7 @@
|
||||||
|
# Default Shorewall 4.5 rc file
|
||||||
|
#
|
||||||
|
HOST=linux #Generic Linux
|
||||||
|
-BUILD= #Default is to detect the build system
|
||||||
|
+BUILD=linux #Default is to detect the build system
|
||||||
|
PREFIX=/usr #Top-level directory for shared files, libraries, etc.
|
||||||
|
SHAREDIR=${PREFIX}/share #Directory for arch-neutral files.
|
||||||
|
LIBEXECDIR=${PREFIX}/share #Directory for executable scripts.
|
20
net/shorewall-core/patches/110-lib.common.patch
Normal file
20
net/shorewall-core/patches/110-lib.common.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
--- a/lib.common 2012-08-08 16:29:23.000000000 +0200
|
||||||
|
+++ b/lib.common 2012-08-13 10:14:23.574529864 +0200
|
||||||
|
@@ -372,7 +372,7 @@
|
||||||
|
|
||||||
|
[ -z "$MODULESDIR" ] && \
|
||||||
|
uname=$(uname -r) && \
|
||||||
|
- MODULESDIR=/lib/modules/$uname/kernel/net/ipv${g_family}/netfilter:/lib/modules/$uname/kernel/net/netfilter:/lib/modules/$uname/kernel/net/sched:/lib/modules/$uname/extra:/lib/modules/$uname/extra/ipset
|
||||||
|
+ MODULESDIR=/lib/modules/$uname/kernel/net/ipv${g_family}/netfilter:/lib/modules/$uname/kernel/net/netfilter:/lib/modules/$uname/kernel/net/sched:/lib/modules/$uname/extra:/lib/modules/$uname/extra/ipset:/lib/modules/$uname
|
||||||
|
|
||||||
|
[ -d /sys/module/ ] || MODULES=$(lsmod | cut -d ' ' -f1)
|
||||||
|
|
||||||
|
@@ -411,7 +411,7 @@
|
||||||
|
|
||||||
|
[ -z "$MODULESDIR" ] && \
|
||||||
|
uname=$(uname -r) && \
|
||||||
|
- MODULESDIR=/lib/modules/$uname/kernel/net/ipv${g_family}/netfilter:/lib/modules/$uname/kernel/net/netfilter:/lib/modules/$uname/kernel/net/sched:/lib/modules/$uname/extra:/lib/modules/$uname/extra/ipset
|
||||||
|
+ MODULESDIR=/lib/modules/$uname/kernel/net/ipv${g_family}/netfilter:/lib/modules/$uname/kernel/net/netfilter:/lib/modules/$uname/kernel/net/sched:/lib/modules/$uname/extra:/lib/modules/$uname/extra/ipset:/lib/modules/$uname
|
||||||
|
|
||||||
|
for directory in $(split $MODULESDIR); do
|
||||||
|
[ -d $directory ] && moduledirectories="$moduledirectories $directory"
|
Loading…
x
Reference in New Issue
Block a user