ntfsprogs: obsoleted
git-svn-id: svn://svn.openwrt.org/openwrt/packages@42137 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
ef59d5fa55
commit
120bfea35f
@ -1,63 +0,0 @@
|
|||||||
#
|
|
||||||
# Copyright (C) 2010-2011 OpenWrt.org
|
|
||||||
# Copyright (C) 2010 Gianluigi Tiesi <sherpya@netfarm.it>
|
|
||||||
#
|
|
||||||
# This is free software, licensed under the GNU General Public License v2.
|
|
||||||
# See /LICENSE for more information.
|
|
||||||
#
|
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
|
||||||
|
|
||||||
PKG_NAME:=ntfsprogs
|
|
||||||
PKG_VERSION:=2.0.0
|
|
||||||
PKG_RELEASE:=2
|
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
|
||||||
PKG_SOURCE_URL:=@SF/linux-ntfs
|
|
||||||
PKG_MD5SUM:=2c402b647bb7aeb1d3f8ce1cc354fd68
|
|
||||||
|
|
||||||
PKG_FIXUP:=autoreconf
|
|
||||||
PKG_INSTALL:=1
|
|
||||||
PKG_BUILD_DEPENDS:=libgcrypt
|
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/package.mk
|
|
||||||
|
|
||||||
define Package/ntfsprogs
|
|
||||||
SECTION:=utils
|
|
||||||
CATEGORY:=Utilities
|
|
||||||
SUBMENU:=Filesystem
|
|
||||||
TITLE:=Linux-NTFS
|
|
||||||
DEPENDS:=+libuuid
|
|
||||||
URL:=http://www.linux-ntfs.org/
|
|
||||||
MAINTAINER:=Gianluigi Tiesi <sherpya@netfarm.it>
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ntfsprogs/description
|
|
||||||
Tools for managing NTFS volumes from Linux
|
|
||||||
endef
|
|
||||||
|
|
||||||
CONFIGURE_ARGS += \
|
|
||||||
--enable-shared \
|
|
||||||
--enable-static \
|
|
||||||
--with-uuid \
|
|
||||||
--disable-crypto \
|
|
||||||
--disable-gnome-vfs \
|
|
||||||
--disable-ntfsmount
|
|
||||||
|
|
||||||
define Build/InstallDev
|
|
||||||
$(INSTALL_DIR) $(1)/usr/include
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/ntfs $(1)/usr/include/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs.{la,a,so*} $(1)/usr/lib/
|
|
||||||
endef
|
|
||||||
|
|
||||||
define Package/ntfsprogs/install
|
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libntfs.so.* $(1)/usr/lib/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/ntfsfix $(1)/usr/bin/
|
|
||||||
$(INSTALL_DIR) $(1)/usr/sbin
|
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
|
|
||||||
endef
|
|
||||||
|
|
||||||
$(eval $(call BuildPackage,ntfsprogs))
|
|
@ -1,52 +0,0 @@
|
|||||||
--- a/libntfs/Makefile.am
|
|
||||||
+++ b/libntfs/Makefile.am
|
|
||||||
@@ -38,8 +38,8 @@ libntfs_la_CFLAGS = $(LIBNTFS_CFLAGS) \
|
|
||||||
-DLTVERSION_LIBNTFS=\"$(LTVERSION_LIBNTFS)\"
|
|
||||||
|
|
||||||
if ENABLE_CRYPTO
|
|
||||||
-libntfs_la_LDFLAGS += `libgnutls-config --libs` `pkg-config --libs libconfig`
|
|
||||||
-libntfs_la_CFLAGS += `libgnutls-config --cflags` `pkg-config --cflags libconfig`
|
|
||||||
+libntfs_la_LDFLAGS += $(GNUTLS_LIBS) $(libconfig_LIBS)
|
|
||||||
+libntfs_la_CFLAGS += $(GNUTLS_CFLAGS) $(libconfig_CFLAGS)
|
|
||||||
endif
|
|
||||||
|
|
||||||
libntfs_la_SOURCES = \
|
|
||||||
--- a/libntfs/Makefile.in
|
|
||||||
+++ b/libntfs/Makefile.in
|
|
||||||
@@ -61,8 +61,8 @@ POST_UNINSTALL = :
|
|
||||||
build_triplet = @build@
|
|
||||||
host_triplet = @host@
|
|
||||||
target_triplet = @target@
|
|
||||||
-@ENABLE_CRYPTO_TRUE@am__append_1 = `libgnutls-config --libs` `pkg-config --libs libconfig`
|
|
||||||
-@ENABLE_CRYPTO_TRUE@am__append_2 = `libgnutls-config --cflags` `pkg-config --cflags libconfig`
|
|
||||||
+@ENABLE_CRYPTO_TRUE@am__append_1 = $(GNUTLS_LIBS) $(libconfig_LIBS)
|
|
||||||
+@ENABLE_CRYPTO_TRUE@am__append_2 = $(GNUTLS_CFLAGS) $(libconfig_CFLAGS)
|
|
||||||
subdir = libntfs
|
|
||||||
DIST_COMMON = $(srcdir)/Makefile.am $(srcdir)/Makefile.in \
|
|
||||||
$(srcdir)/libntfs-gnomevfs.8.in $(srcdir)/libntfs.8.in \
|
|
||||||
--- a/ntfsprogs/Makefile.am
|
|
||||||
+++ b/ntfsprogs/Makefile.am
|
|
||||||
@@ -125,8 +125,8 @@ ntfsdump_logfile_LDFLAGS= $(AM_LFLAGS)
|
|
||||||
if ENABLE_CRYPTO
|
|
||||||
ntfsdecrypt_SOURCES = ntfsdecrypt.c utils.c utils.h
|
|
||||||
ntfsdecrypt_LDADD = $(AM_LIBS)
|
|
||||||
-ntfsdecrypt_LDFLAGS = $(AM_LFLAGS) `libgnutls-config --libs`
|
|
||||||
-ntfsdecrypt_CFLAGS = `libgnutls-config --cflags`
|
|
||||||
+ntfsdecrypt_LDFLAGS = $(AM_LFLAGS) $(GNUTLS_LIBS)
|
|
||||||
+ntfsdecrypt_CFLAGS = $(GNUTLS_CFLAGS)
|
|
||||||
endif
|
|
||||||
|
|
||||||
# Extra targets
|
|
||||||
--- a/ntfsprogs/Makefile.in
|
|
||||||
+++ b/ntfsprogs/Makefile.in
|
|
||||||
@@ -449,8 +449,8 @@ ntfsdump_logfile_LDADD = $(AM_LIBS)
|
|
||||||
ntfsdump_logfile_LDFLAGS = $(AM_LFLAGS)
|
|
||||||
@ENABLE_CRYPTO_TRUE@ntfsdecrypt_SOURCES = ntfsdecrypt.c utils.c utils.h
|
|
||||||
@ENABLE_CRYPTO_TRUE@ntfsdecrypt_LDADD = $(AM_LIBS)
|
|
||||||
-@ENABLE_CRYPTO_TRUE@ntfsdecrypt_LDFLAGS = $(AM_LFLAGS) `libgnutls-config --libs`
|
|
||||||
-@ENABLE_CRYPTO_TRUE@ntfsdecrypt_CFLAGS = `libgnutls-config --cflags`
|
|
||||||
+@ENABLE_CRYPTO_TRUE@ntfsdecrypt_LDFLAGS = $(AM_LFLAGS) $(GNUTLS_LIBS)
|
|
||||||
+@ENABLE_CRYPTO_TRUE@ntfsdecrypt_CFLAGS = $(GNUTLS_CFLAGS)
|
|
||||||
all: all-am
|
|
||||||
|
|
||||||
.SUFFIXES:
|
|
Loading…
x
Reference in New Issue
Block a user