rename pptpd patches, add a patch to use target optimization flags, tidy up Makefile
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5313 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
8ef216d77b
commit
1256219045
@ -4,7 +4,7 @@
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
# See /LICENSE for more information.
|
||||
#
|
||||
# $Id:$
|
||||
# $Id$
|
||||
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
@ -17,7 +17,6 @@ PKG_SOURCE_URL:=@SF/poptop
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_CAT:=zcat
|
||||
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
@ -28,37 +27,33 @@ define Package/pptpd
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+kmod-ppp +kmod-gre
|
||||
TITLE:=PopTop pptp server
|
||||
DESCRIPTION:=PopTop pptp server
|
||||
endef
|
||||
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, --with-bcrelay)
|
||||
$(call Build/Configure/Default, --with-bcrelay)
|
||||
endef
|
||||
|
||||
define Build/Compile
|
||||
$(call Build/Compile/Default, \
|
||||
CFLAGS="$(TARGET_CFLAGS) -DSBINDIR=\\\"/usr/sbin\\\"" \
|
||||
$(call Build/Compile/Default, \
|
||||
COPTS="\$$$$(EXTRA_CFLAGS)" \
|
||||
DESTDIR="$(PKG_INSTALL_DIR)" \
|
||||
INSTALL="install" \
|
||||
all install \
|
||||
)
|
||||
)
|
||||
endef
|
||||
|
||||
define Package/pptpd/install
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
|
||||
install -d -m0755 $(1)/usr/lib/pptpd
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
|
||||
install -d -m0755 $(1)/etc
|
||||
install -m0644 ./files/pptpd.conf $(1)/etc/
|
||||
install -d -m0755 $(1)/etc/init.d
|
||||
install -m0755 ./files/pptpd.init $(1)/etc/init.d/pptpd
|
||||
install -d -m0755 $(1)/etc/ppp
|
||||
install -m0644 ./files/options.pptpd $(1)/etc/ppp/
|
||||
install -d -m0755 $(1)/usr/sbin
|
||||
install -d -m0755 $(1)/usr/lib/pptpd
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpd $(1)/usr/sbin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/sbin/pptpctrl $(1)/usr/sbin/
|
||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pptpd/* $(1)/usr/lib/pptpd
|
||||
$(STRIP) $1/usr/sbin/*
|
||||
$(STRIP) $1/usr/lib/pptpd/*
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,pptpd))
|
||||
|
12
net/pptpd/patches/03-opt_flags.patch
Normal file
12
net/pptpd/patches/03-opt_flags.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -ruN pptpd-1.3.0-old/Makefile.in pptpd-1.3.0-new/Makefile.in
|
||||
--- pptpd-1.3.0-old/Makefile.in 2005-08-03 09:47:42.000000000 +0200
|
||||
+++ pptpd-1.3.0-new/Makefile.in 2006-10-27 18:22:00.000000000 +0200
|
||||
@@ -106,7 +106,7 @@
|
||||
AWK = @AWK@
|
||||
CC = @CC@
|
||||
CCDEPMODE = @CCDEPMODE@
|
||||
-CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
|
||||
+CFLAGS = $(COPTS) -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
|
||||
CPP = @CPP@
|
||||
CPPFLAGS = @CPPFLAGS@
|
||||
CYGPATH_W = @CYGPATH_W@
|
Loading…
x
Reference in New Issue
Block a user