sslh: Bump to v1.14
Disabled support for sslh 1.12's config file feature to avoid libconfig dependency; Redundant as we use UCI-based config file instead. Signed-off-by: Jonathan McCrohan <jmccrohan@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/3080/ Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/packages@34933 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
4e924b5213
commit
1312393aff
@ -8,12 +8,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=sslh
|
||||
PKG_VERSION:=1.10
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=1.14
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://rutschle.net/tech/
|
||||
PKG_MD5SUM:=bc34e9a4770d634633e70589c72708cc
|
||||
PKG_MD5SUM:=36e64bd6c7d0a299d5acd1109988099b
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -34,6 +34,7 @@ define Build/Compile
|
||||
$(MAKE) -C $(PKG_BUILD_DIR) \
|
||||
CC="$(TARGET_CC)" \
|
||||
CFLAGS="$(TARGET_CFLAGS)" \
|
||||
USELIBCONFIG= \
|
||||
USELIBWRAP= \
|
||||
all
|
||||
endef
|
||||
|
@ -42,6 +42,11 @@ start_instance() {
|
||||
config_get_bool verbosed "${section}" verbose 0
|
||||
[ "${verbosed}" -ne 0 ] && append args "-v"
|
||||
|
||||
# Defaults were removed for --user and --pidfile options
|
||||
# in sslh 1.11; Define them here instead.
|
||||
append args "--user nobody"
|
||||
append args "--pidfile /var/run/sslh.pid"
|
||||
|
||||
# XXX: allow more that one instance to run simultaneously
|
||||
SERVICE_MATCH_NAME=1 SERVICE_NAME="sslh-dummy-$$" \
|
||||
service_start /usr/sbin/sslh ${args}
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -32,16 +32,12 @@ all: sslh $(MAN) echosrv
|
||||
@@ -37,16 +37,12 @@ all: sslh $(MAN) echosrv
|
||||
$(CC) $(CFLAGS) -D'VERSION=$(VERSION)' -c $<
|
||||
|
||||
|
||||
@ -16,9 +16,9 @@
|
||||
- #strip sslh-select
|
||||
-
|
||||
echosrv: $(OBJS) echosrv.o
|
||||
$(CC) $(CFLAGS) -o echosrv echosrv.o common.o $(LIBS)
|
||||
$(CC) $(CFLAGS) -o echosrv echosrv.o probe.o common.o $(LIBS)
|
||||
|
||||
@@ -65,7 +61,7 @@ uninstall:
|
||||
@@ -77,7 +73,7 @@ uninstall:
|
||||
update-rc.d sslh remove
|
||||
|
||||
clean:
|
||||
@ -26,4 +26,4 @@
|
||||
+ rm -f sslh-fork echosrv $(MAN) *.o *.gcov *.gcno *.gcda *.png *.html *.css *.info
|
||||
|
||||
tags:
|
||||
ctags -T *.[ch]
|
||||
ctags --globals -T *.[ch]
|
||||
|
Loading…
x
Reference in New Issue
Block a user