[package] update fxload to 2008-10-13 (#5465)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@16806 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c708b73901
commit
14c937af41
@ -1,4 +1,4 @@
|
||||
#
|
||||
#
|
||||
# Copyright (C) 2006 OpenWrt.org
|
||||
#
|
||||
# This is free software, licensed under the GNU General Public License v2.
|
||||
@ -9,12 +9,12 @@ include $(TOPDIR)/rules.mk
|
||||
include $(INCLUDE_DIR)/kernel.mk
|
||||
|
||||
PKG_NAME:=fxload
|
||||
PKG_VERSION:=2002_04_11
|
||||
PKG_VERSION:=2008_10_13
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=@SF/linux-hotplug
|
||||
PKG_MD5SUM:=cafd71a5bff0c57bcd248273b2541c05
|
||||
PKG_MD5SUM:=4477a2457f064228bef4a93ba2f21692
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -34,9 +34,9 @@ endef
|
||||
|
||||
define Package/fxload/install
|
||||
$(INSTALL_DIR) $(1)/sbin
|
||||
$(CP) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin/
|
||||
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(PKG_NAME) $(1)/sbin/
|
||||
$(INSTALL_DIR) $(1)/usr/share/usb
|
||||
$(CP) $(PKG_BUILD_DIR)/a3load.hex $(1)/usr/share/usb
|
||||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/a3load.hex $(1)/usr/share/usb/
|
||||
endef
|
||||
|
||||
$(eval $(call BuildPackage,fxload))
|
||||
|
@ -1,10 +1,10 @@
|
||||
--- fxload-2002_04_11/ezusb.c.old 2006-12-18 18:51:26.000000000 -0700
|
||||
+++ fxload-2002_04_11/ezusb.c 2006-12-18 18:51:59.000000000 -0700
|
||||
@@ -29,8 +29,14 @@
|
||||
--- a/ezusb.c
|
||||
+++ b/ezusb.c
|
||||
@@ -30,8 +30,14 @@
|
||||
# include <sys/ioctl.h>
|
||||
|
||||
# include <linux/version.h>
|
||||
-# include <linux/usb.h>
|
||||
-# include <linux/usb/ch9.h>
|
||||
+typedef unsigned long kernel_ulong_t;
|
||||
+
|
||||
+#ifndef BITS_PER_LONG
|
||||
@ -12,7 +12,7 @@
|
||||
+#endif
|
||||
+
|
||||
# include <linux/usbdevice_fs.h>
|
||||
+# include <linux/usb.h>
|
||||
+# include <linux/usb/ch9.h>
|
||||
|
||||
# include "ezusb.h"
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user