libtheora: update to 1.1.1

Remove the patch against Makefile.in since the build is set up to do
autoreconf anyways.

[florian: make it apply cleanly, split patches so we know what they do]

Signed-off-by: Andy Leiserson <andy@leiserson.org>
Signed-off-by: Florian Fainelli <florian@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@34512 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2012-12-05 17:31:10 +00:00
parent 9cc40e2c5b
commit 15021a8200
3 changed files with 36 additions and 34 deletions

View File

@ -1,5 +1,5 @@
# #
# Copyright (C) 2008 OpenWrt.org # Copyright (C) 2008-2012 OpenWrt.org
# #
# This is free software, licensed under the GNU General Public License v2. # This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information. # See /LICENSE for more information.
@ -8,11 +8,11 @@
include $(TOPDIR)/rules.mk include $(TOPDIR)/rules.mk
PKG_NAME:=libtheora PKG_NAME:=libtheora
PKG_VERSION:=1.0 PKG_VERSION:=1.1.1
PKG_RELEASE:=3 PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://downloads.xiph.org/releases/theora/ PKG_SOURCE_URL:=http://downloads.xiph.org/releases/theora/
PKG_MD5SUM:=c963937053f45a7878954bed37ceb182 PKG_MD5SUM:=292ab65cedd5021d6b7ddd117e07cd8e
PKG_FIXUP:=autoreconf PKG_FIXUP:=autoreconf
PKG_BUILD_DEPENDS:=libvorbis PKG_BUILD_DEPENDS:=libvorbis

View File

@ -1,6 +1,7 @@
--- a/Makefile.am diff -urN libtheora-1.1.1/Makefile.am libtheora-1.1.1.new/Makefile.am
+++ b/Makefile.am --- libtheora-1.1.1/Makefile.am 2009-07-14 01:55:02.000000000 +0200
@@ -8,7 +8,7 @@ else +++ libtheora-1.1.1.new/Makefile.am 2012-12-05 14:21:06.103521554 +0100
@@ -8,7 +8,7 @@
EXAMPLES_DIR = EXAMPLES_DIR =
endif endif
@ -9,37 +10,24 @@
# we include the whole debian/ dir in EXTRA_DIST because there's a problem # we include the whole debian/ dir in EXTRA_DIST because there's a problem
--- a/Makefile.in diff -urN libtheora-1.1.1/Makefile.in libtheora-1.1.1.new/Makefile.in
+++ b/Makefile.in --- libtheora-1.1.1/Makefile.in 2009-10-01 20:04:07.000000000 +0200
@@ -80,7 +80,7 @@ pkgconfigDATA_INSTALL = $(INSTALL_DATA) +++ libtheora-1.1.1.new/Makefile.in 2012-12-05 14:21:18.239521864 +0100
DATA = $(pkgconfig_DATA) @@ -164,7 +164,7 @@
ETAGS = etags
CTAGS = ctags
-DIST_SUBDIRS = lib include doc tests m4 examples
+DIST_SUBDIRS = lib include m4
DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
distdir = $(PACKAGE)-$(VERSION)
top_distdir = $(distdir)
@@ -262,7 +262,7 @@ target_vendor = @target_vendor@
AUTOMAKE_OPTIONS = foreign 1.6 dist-zip dist-bzip2
@THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
@THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples @THEORA_ENABLE_EXAMPLES_TRUE@EXAMPLES_DIR = examples
@THEORA_ENABLE_EXAMPLES_FALSE@EXAMPLES_DIR =
-SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR) -SUBDIRS = lib include doc tests m4 $(EXAMPLES_DIR)
+SUBDIRS = lib include m4 $(EXAMPLES_DIR) +SUBDIRS = lib include m4 $(EXAMPLES_DIR)
# we include the whole debian/ dir in EXTRA_DIST because there's a problem # we include the whole debian/ dir in EXTRA_DIST because there's a problem
# with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am # with autotools and HFS+ MacOSX file systems that caused debian/Makefile.am
--- a/configure.ac @@ -200,7 +200,7 @@
+++ b/configure.ac missing mkinstalldirs theora-uninstalled.pc.in theora.pc.in \
@@ -310,11 +310,6 @@ fi theoradec-uninstalled.pc.in theoradec.pc.in \
dnl check for SDL theoraenc-uninstalled.pc.in theoraenc.pc.in
HAVE_SDL=no -DIST_SUBDIRS = lib include doc tests m4 examples
+DIST_SUBDIRS = lib include m4 examples
-AM_PATH_SDL(,[ all: config.h
- HAVE_SDL=yes $(MAKE) $(AM_MAKEFLAGS) all-recursive
- SDL_LIBS=`$SDL_CONFIG --libs`
-],AC_MSG_WARN([*** Unable to find SDL -- Not compiling example players ***]))
-
dnl check for OSS
HAVE_OSS=no

View File

@ -0,0 +1,14 @@
--- libtheora-1.1.1/configure.ac 2009-10-01 20:00:33.000000000 +0200
+++ libtheora-1.1.1.new/configure.ac 2012-12-05 14:22:26.319523608 +0100
@@ -313,11 +313,6 @@
dnl check for SDL
HAVE_SDL=no
-AM_PATH_SDL(,[
- HAVE_SDL=yes
- SDL_LIBS=`$SDL_CONFIG --libs`
-],AC_MSG_WARN([*** Unable to find SDL -- Not compiling example players ***]))
-
dnl check for OSS
HAVE_OSS=no
AC_CHECK_HEADERS([sys/soundcard.h soundcard.h machine/soundcard.h],[