[packages]: openssh update to 6.2p1
git-svn-id: svn://svn.openwrt.org/openwrt/packages@36157 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
9e1dfdd62f
commit
1507ec8b6a
@ -8,7 +8,7 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=openssh
|
||||
PKG_VERSION:=6.1p1
|
||||
PKG_VERSION:=6.2p1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
@ -16,7 +16,7 @@ PKG_SOURCE_URL:=ftp://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
|
||||
ftp://openbsd.wiretapped.net/pub/OpenBSD/OpenSSH/portable/ \
|
||||
ftp://ftp.belnet.be/packages/openbsd/OpenSSH/portable/ \
|
||||
ftp://ftp.de.openbsd.org/pub/unix/OpenBSD/OpenSSH/portable/
|
||||
PKG_MD5SUM:=3345cbf4efe90ffb06a78670ab2d05d5
|
||||
PKG_MD5SUM:=7b2d9dd75b5cf267ea1737ec75500316
|
||||
|
||||
PKG_BUILD_DEPENDS:=libopenssl
|
||||
|
||||
|
@ -1,12 +1,15 @@
|
||||
diff --git a/cipher.c b/cipher.c
|
||||
index 9ca1d00..a6c1324 100644
|
||||
--- a/cipher.c
|
||||
+++ b/cipher.c
|
||||
@@ -73,7 +73,9 @@ struct Cipher {
|
||||
|
||||
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, 1, EVP_des_ede3_cbc },
|
||||
{ "blowfish-cbc", SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_bf_cbc },
|
||||
@@ -74,8 +74,10 @@ struct Cipher {
|
||||
{ "3des-cbc", SSH_CIPHER_SSH2, 8, 24, 0, 0, 0, 1, EVP_des_ede3_cbc },
|
||||
{ "blowfish-cbc",
|
||||
SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 1, EVP_bf_cbc },
|
||||
+#ifndef OPENSSL_NO_CAST
|
||||
{ "cast128-cbc", SSH_CIPHER_SSH2, 8, 16, 0, 1, EVP_cast5_cbc },
|
||||
{ "cast128-cbc",
|
||||
SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 1, EVP_cast5_cbc },
|
||||
+#endif
|
||||
{ "arcfour", SSH_CIPHER_SSH2, 8, 16, 0, 0, EVP_rc4 },
|
||||
{ "arcfour128", SSH_CIPHER_SSH2, 8, 16, 1536, 0, EVP_rc4 },
|
||||
{ "arcfour256", SSH_CIPHER_SSH2, 8, 32, 1536, 0, EVP_rc4 },
|
||||
{ "arcfour", SSH_CIPHER_SSH2, 8, 16, 0, 0, 0, 0, EVP_rc4 },
|
||||
{ "arcfour128", SSH_CIPHER_SSH2, 8, 16, 0, 0, 1536, 0, EVP_rc4 },
|
||||
{ "arcfour256", SSH_CIPHER_SSH2, 8, 32, 0, 0, 1536, 0, EVP_rc4 },
|
||||
|
@ -1,13 +1,25 @@
|
||||
diff --git a/mac.c b/mac.c
|
||||
index 3f2dc6f..73d2d4e 100644
|
||||
--- a/mac.c
|
||||
+++ b/mac.c
|
||||
@@ -67,8 +67,10 @@ struct {
|
||||
@@ -68,8 +68,10 @@ struct {
|
||||
#endif
|
||||
{ "hmac-md5", SSH_EVP, EVP_md5, 0, -1, -1 },
|
||||
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, -1, -1 },
|
||||
{ "hmac-md5", SSH_EVP, EVP_md5, 0, 0, 0, 0 },
|
||||
{ "hmac-md5-96", SSH_EVP, EVP_md5, 96, 0, 0, 0 },
|
||||
+#ifndef OPENSSL_NO_RIPEMD
|
||||
{ "hmac-ripemd160", SSH_EVP, EVP_ripemd160, 0, -1, -1 },
|
||||
{ "hmac-ripemd160@openssh.com", SSH_EVP, EVP_ripemd160, 0, -1, -1 },
|
||||
{ "hmac-ripemd160", SSH_EVP, EVP_ripemd160, 0, 0, 0, 0 },
|
||||
{ "hmac-ripemd160@openssh.com", SSH_EVP, EVP_ripemd160, 0, 0, 0, 0 },
|
||||
+#endif
|
||||
{ "umac-64@openssh.com", SSH_UMAC, NULL, 0, 128, 64 },
|
||||
{ NULL, 0, NULL, 0, -1, -1 }
|
||||
};
|
||||
{ "umac-64@openssh.com", SSH_UMAC, NULL, 0, 128, 64, 0 },
|
||||
{ "umac-128@openssh.com", SSH_UMAC128, NULL, 0, 128, 128, 0 },
|
||||
|
||||
@@ -82,7 +84,9 @@ struct {
|
||||
#endif
|
||||
{ "hmac-md5-etm@openssh.com", SSH_EVP, EVP_md5, 0, 0, 0, 1 },
|
||||
{ "hmac-md5-96-etm@openssh.com", SSH_EVP, EVP_md5, 96, 0, 0, 1 },
|
||||
+#ifndef OPENSSL_NO_RIPEMD
|
||||
{ "hmac-ripemd160-etm@openssh.com", SSH_EVP, EVP_ripemd160, 0, 0, 0, 1 },
|
||||
+#endif
|
||||
{ "umac-64-etm@openssh.com", SSH_UMAC, NULL, 0, 128, 64, 1 },
|
||||
{ "umac-128-etm@openssh.com", SSH_UMAC128, NULL, 0, 128, 128, 1 },
|
||||
|
||||
|
Loading…
x
Reference in New Issue
Block a user