Update ccrypt package to 1.10

A new version 1.10 of ccrypt encryption tools package has been published in
late 2012. The old version 1.9 dates back to 2009.

Link to changelog: http://ccrypt.sourceforge.net/ChangeLog

October 18, 2012: Release 1.10. This release fixes a number of minor
portability issues and minor bugs. The ccrypt core functionality has been
factored into a convenience library libccrypt.a. A ccguess program was added
to assist in the recovery of mistyped keys. Improved error checking and fixed
minor compiler warnings. Minor improvements to emacs support, and added a
--disable-emacs configuration option. Thanks to bornlibra23 and Johannes
Ruscheinski for bug reports.

I have tested the version 1.10 on ar71xx/wndr3700.

A patch to update ccrypt to 1.10 is included.

Signed-off-by: hannu.nyman@iki.fi
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@35635 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
juhosg 2013-02-17 11:24:25 +00:00
parent b5027f427a
commit 15469568db
2 changed files with 25 additions and 40 deletions

View File

@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ccrypt
PKG_VERSION:=1.9
PKG_RELEASE:=2
PKG_VERSION:=1.10
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SF/ccrypt
PKG_MD5SUM:=c3f78019d7a166dd66f1d4b1390c62c2
PKG_MD5SUM:=44ddd763465c254df83f5d38851d04d7
PKG_FIXUP:=autoreconf

View File

@ -1,6 +1,6 @@
--- a/configure.ac
+++ b/configure.ac
@@ -106,17 +106,6 @@ AC_MSG_RESULT($UINT32_TYPE)
@@ -123,17 +123,6 @@ AC_MSG_RESULT($UINT32_TYPE)
AC_DEFINE_UNQUOTED(UINT32_TYPE,$UINT32_TYPE,unsigned 32 bit integer type)
dnl ----------------------------------------------------------------------
@ -12,16 +12,16 @@
-
-AM_GNU_GETTEXT
-AM_GNU_GETTEXT_VERSION([0.14.3])
-IT_PROG_INTLTOOL([0.34.2], [no-xml])
-IT_PO_SUBDIR(po)
-
-dnl ----------------------------------------------------------------------
dnl Libtool (needed by intl/)
AC_PROG_LIBTOOL
@@ -135,9 +124,7 @@ AC_SUBST(TAR)
LT_INIT
@@ -153,9 +142,7 @@ AC_SUBST(TAR)
dnl ----------------------------------------------------------------------
AC_OUTPUT([doc/ccrypt.1
AC_CONFIG_FILES([doc/ccrypt.1
doc/ccguess.1
- po/Makefile.in
m4/Makefile
- intl/Makefile
@ -30,25 +30,19 @@
emacs/Makefile
--- a/Makefile.am
+++ b/Makefile.am
@@ -4,11 +4,10 @@
@@ -4,7 +4,7 @@
## Process this file with automake to produce Makefile.in
-SUBDIRS = m4 po intl src emacs doc check
+SUBDIRS = m4 src emacs doc check
-EXTRA_DIST = m4/ChangeLog config.rpath README-WIN intltool-extract.in \
- intltool-merge.in intltool-update.in
-DISTCLEANFILES = intltool-extract intltool-merge intltool-update
+EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
+DISTCLEANFILES =
EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
TAR = @TAR@
--- a/Makefile.in
+++ b/Makefile.in
@@ -37,7 +37,7 @@ build_triplet = @build@
host_triplet = @host@
@@ -36,7 +36,7 @@ host_triplet = @host@
subdir = .
DIST_COMMON = README $(am__configure_deps) $(srcdir)/Makefile.am \
$(srcdir)/Makefile.in $(srcdir)/config.h.in \
- $(top_srcdir)/configure $(top_srcdir)/intl/Makefile.in \
@ -56,49 +50,40 @@
ABOUT-NLS AUTHORS COPYING ChangeLog INSTALL NEWS config.guess \
config.rpath config.sub depcomp elisp-comp install-sh \
ltmain.sh missing mkinstalldirs
@@ -64,7 +64,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
configure.lineno configure.status.lineno
@@ -66,7 +66,7 @@ am__CONFIG_DISTCLEAN_FILES = config.stat
configure.lineno config.status.lineno
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = config.h
-CONFIG_CLEAN_FILES = intl/Makefile
+CONFIG_CLEAN_FILES =
CONFIG_CLEAN_VPATH_FILES =
SOURCES =
DIST_SOURCES =
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
@@ -251,11 +251,10 @@ sbindir = @sbindir@
sharedstatedir = @sharedstatedir@
sysconfdir = @sysconfdir@
target_alias = @target_alias@
@@ -277,7 +277,7 @@ target_alias = @target_alias@
top_build_prefix = @top_build_prefix@
top_builddir = @top_builddir@
top_srcdir = @top_srcdir@
-SUBDIRS = m4 po intl src emacs doc check
-EXTRA_DIST = m4/ChangeLog config.rpath README-WIN intltool-extract.in \
- intltool-merge.in intltool-update.in
+SUBDIRS = m4 src emacs doc check
+EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
-DISTCLEANFILES = intltool-extract intltool-merge intltool-update
+DISTCLEANFILES =
EXTRA_DIST = m4/ChangeLog config.rpath README-WIN
ACLOCAL_AMFLAGS = -I m4
all: config.h
$(MAKE) $(AM_MAKEFLAGS) all-recursive
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -17,7 +17,7 @@ ccrypt_DEPENDENCIES = @EXTRA_OBJS@
@@ -56,4 +56,4 @@ uninstall-local:
# internationalization stuff
localedir = $(datadir)/locale
INCLUDES = -I../intl -I$(top_srcdir)/intl -DLOCALEDIR=\"$(localedir)\"
-LIBS = @LIBINTL@ @LIBS@
+LIBS = @LIBS@
maketables: maketables.c
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -170,7 +170,7 @@ LDFLAGS = @LDFLAGS@
@@ -159,7 +159,7 @@ LDFLAGS = @LDFLAGS@
LIBICONV = @LIBICONV@
LIBINTL = @LIBINTL@
LIBOBJS = @LIBOBJS@
-LIBS = @LIBINTL@ @LIBS@
+LIBS = @LIBS@
LIBTOOL = @LIBTOOL@
LIPO = @LIPO@
LN_S = @LN_S@
LTLIBICONV = @LTLIBICONV@