Update rp-pppoe to 3.9 (#3649)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11688 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
e473ab3f9c
commit
181641d8b2
@ -9,15 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=rp-pppoe
|
||||
PKG_VERSION:=3.8
|
||||
PKG_VERSION:=3.9
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE_URL:=http://roaringpenguin.com/files/download
|
||||
PKG_MD5SUM:=0e32760f498f9cde44081ee6aafc823b
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
PKG_MD5SUM:=7693f289c3babcfe211a9deef9118c6f
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -26,30 +23,55 @@ define Package/rp-pppoe/Default
|
||||
CATEGORY:=Network
|
||||
DEPENDS:=+ppp
|
||||
TITLE:=PPPoE (PPP over Ethernet)
|
||||
URL:=http://roaringpenguin.com/penguin/pppoe/
|
||||
URL:=http://roaringpenguin.com/products/pppoe
|
||||
SUBMENU:=dial-in/up
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe/Default/description
|
||||
Dubbed RP-PPPoE, this open-source product is ideal for Linux users with
|
||||
a DSL "modem" whose Internet service provider uses PPPoE.
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-client
|
||||
$(call Package/rp-pppoe/Default)
|
||||
TITLE+= client
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-client/description
|
||||
$(call Package/rp-pppoe/Default/description)
|
||||
This package contains pppoe-connect.
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-relay
|
||||
$(call Package/rp-pppoe/Default)
|
||||
TITLE+= relay
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-relay/description
|
||||
$(call Package/rp-pppoe/Default/description)
|
||||
This package contains pppoe-relay.
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-server
|
||||
$(call Package/rp-pppoe/Default)
|
||||
TITLE+= server
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-server/description
|
||||
$(call Package/rp-pppoe/Default/description)
|
||||
This package contains pppoe-server.
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-sniff
|
||||
$(call Package/rp-pppoe/Default)
|
||||
TITLE+= sniffer
|
||||
endef
|
||||
|
||||
define Package/rp-pppoe-sniff/description
|
||||
$(call Package/rp-pppoe/Default/description)
|
||||
This package contains pppoe-sniff.
|
||||
endef
|
||||
|
||||
TARGET_CFLAGS += -I$(PKG_BUILD_DIR)/src/libevent
|
||||
CONFIGURE_PATH := ./src
|
||||
CONFIGURE_ARGS += ac_cv_path_PPPD=/usr/sbin/pppd
|
||||
|
@ -1,9 +1,8 @@
|
||||
diff -ur pppoe.old/src/configure pppoe.dev/src/configure
|
||||
--- pppoe.old/src/configure 2006-04-02 16:29:42.000000000 +0200
|
||||
+++ pppoe.dev/src/configure 2006-12-08 22:27:13.753685216 +0100
|
||||
@@ -5744,7 +5744,7 @@
|
||||
echo "$as_me:$LINENO: checking packing order of bit fields" >&5
|
||||
echo $ECHO_N "checking packing order of bit fields... $ECHO_C" >&6
|
||||
--- a/src/configure
|
||||
+++ b/src/configure
|
||||
@@ -6303,7 +6303,7 @@
|
||||
{ echo "$as_me:$LINENO: checking packing order of bit fields" >&5
|
||||
echo $ECHO_N "checking packing order of bit fields... $ECHO_C" >&6; }
|
||||
if test "$cross_compiling" = yes; then
|
||||
- $ECHO "no defaults for cross-compiling"; exit 0
|
||||
+ rpppoe_cv_pack_bitfields="$ac_cv_pack_bitfields"
|
||||
|
Loading…
x
Reference in New Issue
Block a user