update libgphoto2 to v2.3.1 (closes: #1105), add dependency on libiconv
git-svn-id: svn://svn.openwrt.org/openwrt/packages@5942 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
bc0ed84180
commit
18b1e228b3
@ -9,12 +9,12 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=libgphoto2
|
||||
PKG_VERSION:=2.2.1
|
||||
PKG_VERSION:=2.3.1
|
||||
PKG_RELEASE:=1
|
||||
|
||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=@SF/gphoto
|
||||
PKG_MD5SUM:=69827311733e39fafa9f77bb05e55b77
|
||||
PKG_MD5SUM:=37f85e34e5b6031ddf6cac8b8782ac4f
|
||||
PKG_CAT:=bzcat
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||
@ -31,7 +31,7 @@ endef
|
||||
|
||||
define Package/libgphoto2
|
||||
$(call Package/libgphoto2/Default)
|
||||
DEPENDS:=+libusb +libexif +libjpeg +libpthread +libltdl
|
||||
DEPENDS:=+libusb +libexif +libjpeg +libpthread +libltdl +libiconv
|
||||
TITLE:=The basic library of the gphoto2 program.
|
||||
MENU:=1
|
||||
endef
|
||||
@ -52,6 +52,8 @@ define Build/Configure
|
||||
--without-libiconv-prefix \
|
||||
--without-libintl-prefix \
|
||||
, \
|
||||
CPPFLAGS="$$$$CPPFLAGS -I$(STAGING_DIR)/usr/lib/libiconv/include" \
|
||||
LDFLAGS="$$$$LDFLAGS -L$(STAGING_DIR)/usr/lib/libiconv/lib" \
|
||||
LIBEXIF_CFLAGS="$$$$CPPFLAGS" \
|
||||
LIBEXIF_LIBS="$$$$LDFLAGS -lexif" \
|
||||
LIBUSB_CFLAGS="$$$$CPPFLAGS" \
|
||||
|
@ -1,45 +0,0 @@
|
||||
--- libgphoto2-2.2.1-old/camlibs/sonix/library.c 2006-04-18 18:54:18.000000000 -0700
|
||||
+++ libgphoto2-2.2.1/camlibs/sonix/library.c 2006-07-31 09:02:45.000000000 -0700
|
||||
@@ -41,7 +41,7 @@
|
||||
#else
|
||||
# define _(String) (String)
|
||||
# define N_(String) (String)
|
||||
-# define ngettext(String1,String2,Count) ((Count==1)?String1:String)
|
||||
+# define ngettext(String1,String2,Count) ((Count==1)?String1:String2)
|
||||
#endif
|
||||
|
||||
#include <gphoto2-port.h>
|
||||
|
||||
--- libgphoto2-2.2.1-old/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c 2006-06-03 08:38:12.000000000 -0700
|
||||
+++ libgphoto2-2.2.1/libgphoto2_port/libgphoto2_port/gphoto2-port-info-list.c 2006-07-31 09:04:36.000000000 -0700
|
||||
@@ -51,6 +51,7 @@
|
||||
# define dgettext(Domain,Message) (Message)
|
||||
# define dcgettext(Domain,Message,Type) (Message)
|
||||
# define bindtextdomain(Domain,Directory) (Domain)
|
||||
+# define bind_textdomain_codeset(Domain,Codeset) (Codeset)
|
||||
# define _(String) (String)
|
||||
# define N_(String) (String)
|
||||
#endif
|
||||
@@ -79,7 +80,7 @@
|
||||
|
||||
const char*
|
||||
gp_port_message_codeset (const char *codeset) {
|
||||
- return bind_textdomain_codeset (GETTEXT_PACKAGE, codeset);
|
||||
+ return codeset;
|
||||
}
|
||||
|
||||
/**
|
||||
|
||||
--- libgphoto2-2.2.1-old/packaging/generic/print-camera-list.c 2006-04-18 18:54:05.000000000 -0700
|
||||
+++ libgphoto2-2.2.1/packaging/generic/print-camera-list.c 2006-07-31 09:02:45.000000000 -0700
|
||||
@@ -48,8 +48,8 @@
|
||||
#include <time.h>
|
||||
#include <string.h>
|
||||
|
||||
-#include <gphoto2/gphoto2-camera.h>
|
||||
-#include <gphoto2/gphoto2-port-log.h>
|
||||
+#include <libgphoto2/gphoto2-camera.h>
|
||||
+#include <libgphoto2_port/gphoto2-port-log.h>
|
||||
|
||||
#ifndef TRUE
|
||||
#define TRUE (0==0)
|
@ -1,24 +0,0 @@
|
||||
diff -ur libgphoto.old/Makefile.am libgphoto.dev/Makefile.am
|
||||
--- libgphoto.old/Makefile.am 2006-04-19 03:54:32.000000000 +0200
|
||||
+++ libgphoto.dev/Makefile.am 2006-10-03 14:40:18.000000000 +0200
|
||||
@@ -8,7 +8,7 @@
|
||||
EXTRA_DIST = HACKING MAINTAINERS makefile.os2 os2mak.inc TESTERS CHANGES
|
||||
|
||||
# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
|
||||
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests po packaging doc
|
||||
+SUBDIRS = @subdirs@ libgphoto2 camlibs po packaging doc
|
||||
|
||||
doc_DATA = AUTHORS COPYING README CHANGES NEWS
|
||||
|
||||
diff -ur libgphoto.old/Makefile.in libgphoto.dev/Makefile.in
|
||||
--- libgphoto.old/Makefile.in 2006-06-19 21:15:59.000000000 +0200
|
||||
+++ libgphoto.dev/Makefile.in 2006-10-03 14:40:23.000000000 +0200
|
||||
@@ -297,7 +297,7 @@
|
||||
EXTRA_DIST = HACKING MAINTAINERS makefile.os2 os2mak.inc TESTERS CHANGES
|
||||
|
||||
# Note: @subdirs@ lists all the directories from AC_CONFIG_SUBDIRS()
|
||||
-SUBDIRS = @subdirs@ libgphoto2 camlibs tests po packaging doc
|
||||
+SUBDIRS = @subdirs@ libgphoto2 camlibs po packaging doc
|
||||
doc_DATA = AUTHORS COPYING README CHANGES NEWS
|
||||
|
||||
########################################################################
|
Loading…
x
Reference in New Issue
Block a user