[packages] quagga, quagga-old: use "cat" as default pager and "head -n" as pager for limited amount of lines (#9814)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@27790 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
d83f7da152
commit
18d3d8d889
@ -10,12 +10,12 @@ include $(TOPDIR)/rules.mk
|
|||||||
PKG_NAME:=quagga
|
PKG_NAME:=quagga
|
||||||
ifneq ($(CONFIG_QUAGGA_OLD),)
|
ifneq ($(CONFIG_QUAGGA_OLD),)
|
||||||
PKG_VERSION:=0.98.6
|
PKG_VERSION:=0.98.6
|
||||||
PKG_RELEASE:=9
|
PKG_RELEASE:=10
|
||||||
PKG_MD5SUM:=b0d4132039953a0214256873b7d23d68
|
PKG_MD5SUM:=b0d4132039953a0214256873b7d23d68
|
||||||
PATCH_DIR:=./patches-old
|
PATCH_DIR:=./patches-old
|
||||||
else
|
else
|
||||||
PKG_VERSION:=0.99.18
|
PKG_VERSION:=0.99.18
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=2
|
||||||
PKG_MD5SUM:=59e306e93a4a1ce16760f20e9075d473
|
PKG_MD5SUM:=59e306e93a4a1ce16760f20e9075d473
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
29
net/quagga/patches-old/170-use-supported-pagers.patch
Normal file
29
net/quagga/patches-old/170-use-supported-pagers.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- a/vtysh/vtysh.c
|
||||||
|
+++ b/vtysh/vtysh.c
|
||||||
|
@@ -243,7 +243,7 @@ vtysh_pager_init ()
|
||||||
|
if (pager_defined)
|
||||||
|
vtysh_pager_name = strdup (pager_defined);
|
||||||
|
else
|
||||||
|
- vtysh_pager_name = strdup ("more");
|
||||||
|
+ vtysh_pager_name = strdup ("cat");
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Command execution over the vty interface. */
|
||||||
|
@@ -1745,7 +1745,7 @@ DEFUN (vtysh_terminal_length,
|
||||||
|
{
|
||||||
|
int lines;
|
||||||
|
char *endptr = NULL;
|
||||||
|
- char default_pager[10];
|
||||||
|
+ char default_pager[12];
|
||||||
|
|
||||||
|
lines = strtol (argv[0], &endptr, 10);
|
||||||
|
if (lines < 0 || lines > 512 || *endptr != '\0')
|
||||||
|
@@ -1762,7 +1762,7 @@ DEFUN (vtysh_terminal_length,
|
||||||
|
|
||||||
|
if (lines != 0)
|
||||||
|
{
|
||||||
|
- snprintf(default_pager, 10, "more -%i", lines);
|
||||||
|
+ snprintf(default_pager, 12, "head -n %i", lines);
|
||||||
|
vtysh_pager_name = strdup (default_pager);
|
||||||
|
}
|
||||||
|
|
29
net/quagga/patches/170-use-supported-pagers.patch
Normal file
29
net/quagga/patches/170-use-supported-pagers.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
--- a/vtysh/vtysh.c
|
||||||
|
+++ b/vtysh/vtysh.c
|
||||||
|
@@ -268,7 +268,7 @@ vtysh_pager_init (void)
|
||||||
|
if (pager_defined)
|
||||||
|
vtysh_pager_name = strdup (pager_defined);
|
||||||
|
else
|
||||||
|
- vtysh_pager_name = strdup ("more");
|
||||||
|
+ vtysh_pager_name = strdup ("cat");
|
||||||
|
}
|
||||||
|
|
||||||
|
/* Command execution over the vty interface. */
|
||||||
|
@@ -1866,7 +1866,7 @@ DEFUN (vtysh_terminal_length,
|
||||||
|
{
|
||||||
|
int lines;
|
||||||
|
char *endptr = NULL;
|
||||||
|
- char default_pager[10];
|
||||||
|
+ char default_pager[12];
|
||||||
|
|
||||||
|
lines = strtol (argv[0], &endptr, 10);
|
||||||
|
if (lines < 0 || lines > 512 || *endptr != '\0')
|
||||||
|
@@ -1883,7 +1883,7 @@ DEFUN (vtysh_terminal_length,
|
||||||
|
|
||||||
|
if (lines != 0)
|
||||||
|
{
|
||||||
|
- snprintf(default_pager, 10, "more -%i", lines);
|
||||||
|
+ snprintf(default_pager, 12, "head -n %i", lines);
|
||||||
|
vtysh_pager_name = strdup (default_pager);
|
||||||
|
}
|
||||||
|
|
Loading…
x
Reference in New Issue
Block a user