[package] add openconnect cisco vpn client, patch from Misha Koshelev

git-svn-id: svn://svn.openwrt.org/openwrt/packages@20316 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
florian 2010-03-20 12:12:57 +00:00
parent f12d068458
commit 1a77a9a31f
2 changed files with 66 additions and 0 deletions

55
net/openconnect/Makefile Normal file
View File

@ -0,0 +1,55 @@
#
# Copyright (C) 2006 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=openconnect
PKG_VERSION:=2.01
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.infradead.org/pub/openconnect/
PKG_MD5SUM:=8fa1f0883c136800dbb992e64a2d579e
include $(INCLUDE_DIR)/package.mk
define Package/openconnect
SECTION:=net
CATEGORY:=Network
DEPENDS:=+libxml2 +libopenssl +kmod-tun
TITLE:=VPN client for Cisco's AnyConnect SSL VPN
URL:=http://www.infradead.org/openconnect/
SUBMENU:=VPN
endef
define Package/openconnect/description
A VPN client compatible with Cisco's AnyConnect SSL VPN.
OpenConnect is a client for Cisco's AnyConnect SSL VPN, which is
supported by IOS 12.4(9)T or later on Cisco SR500, 870, 880, 1800, 2800,
3800, 7200 Series and Cisco 7301 Routers.
endef
define Build/Compile
$(call Build/Compile/Default, \
OPENSSL="$(STAGING_DIR)/usr" \
OFLAGS="$(TARGET_CFLAGS)" \
OS="Linux" \
STAGING_DIR="$(STAGING_DIR)" \
DESTDIR="$(PKG_INSTALL_DIR)" \
PREFIX=/usr \
all install \
)
endef
define Package/openconnect/install
$(INSTALL_DIR) $(1)/usr/bin
$(CP) $(PKG_INSTALL_DIR)/usr/bin/openconnect \
$(1)/usr/bin/
endef
$(eval $(call BuildPackage,openconnect))

View File

@ -0,0 +1,11 @@
--- openconnect-2.01/Makefile 2009-06-24 12:30:34.000000000 -0500
+++ openconnect-2.01.openwrt/Makefile 2009-09-20 18:06:39.000000000 -0500
@@ -15,7 +15,7 @@
# dir; there's no need to install it anywhere (we link it statically).
ifdef OPENSSL
SSL_CFLAGS += -I$(OPENSSL)/include
-SSL_LDFLAGS += -lz $(OPENSSL)/libssl.a $(OPENSSL)/libcrypto.a -ldl
+SSL_LDFLAGS += -lz $(OPENSSL)/lib/libssl.a $(OPENSSL)/lib/libcrypto.a -ldl
else
ifeq ($(wildcard /usr/include/openssl),)
$(error "No OpenSSL in /usr/include/openssl. Cannot continue");