remove the unneeded patches
git-svn-id: svn://svn.openwrt.org/openwrt/packages@7842 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
c59fab69e8
commit
1ab047cf24
@ -4,17 +4,17 @@
|
|||||||
# This is free software, licensed under the GNU General Public License v2.
|
# This is free software, licensed under the GNU General Public License v2.
|
||||||
# See /LICENSE for more information.
|
# See /LICENSE for more information.
|
||||||
#
|
#
|
||||||
# $ Id: $
|
# $Id$
|
||||||
|
|
||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=apr-util
|
PKG_NAME:=apr-util
|
||||||
PKG_VERSION:=0.9.13
|
PKG_VERSION:=1.2.8
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=http://apache.autinity.de/apr/
|
PKG_SOURCE_URL:=http://apache.autinity.de/apr/
|
||||||
PKG_MD5SUM:=31e3881af0d9546286b0057717cdb89b
|
PKG_MD5SUM:=a2e2e54d65e9eae961f7171335cf2550
|
||||||
PKG_CAT:=zcat
|
PKG_CAT:=zcat
|
||||||
|
|
||||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
|
||||||
@ -25,17 +25,21 @@ include $(INCLUDE_DIR)/package.mk
|
|||||||
define Package/apr-util
|
define Package/apr-util
|
||||||
SECTION:=utils
|
SECTION:=utils
|
||||||
CATEGORY:=Utilities
|
CATEGORY:=Utilities
|
||||||
DEPENDS:=+libexpat +apr
|
DEPENDS:=+libiconv +libexpat +apr
|
||||||
TITLE:=Apache Portable Runtime Library Util
|
TITLE:=Apache Portable Runtime Library Util
|
||||||
URL:=http://apr.apache.org/
|
URL:=http://apr.apache.org/
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/Configure
|
define Build/Configure
|
||||||
$(call Build/Configure/Default, \
|
$(call Build/Configure/Default, \
|
||||||
--with-apr="$(STAGING_DIR)/usr/bin/apr-config" \
|
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
||||||
|
--with-expat="$(STAGING_DIR)/usr" \
|
||||||
, \
|
, \
|
||||||
APR_BUILD_DIR="$(STAGING_DIR)/usr/share/build" \
|
ac_cv_file_dbd_apr_dbd_mysql_c=no \
|
||||||
|
APR_BUILD_DIR="$(STAGING_DIR)/usr/share/build-1" \
|
||||||
CFLAGS="-I$(STAGING_DIR)/usr/lib/libiconv/include/" \
|
CFLAGS="-I$(STAGING_DIR)/usr/lib/libiconv/include/" \
|
||||||
|
LDFLAGS="-ldl -L$(STAGING_DIR)/lib \
|
||||||
|
-L$(STAGING_DIR)/usr/lib" \
|
||||||
)
|
)
|
||||||
endef
|
endef
|
||||||
|
|
||||||
@ -47,27 +51,32 @@ endef
|
|||||||
|
|
||||||
define Build/InstallDev
|
define Build/InstallDev
|
||||||
mkdir -p $(STAGING_DIR)/usr/bin
|
mkdir -p $(STAGING_DIR)/usr/bin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-config \
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config \
|
||||||
$(STAGING_DIR)/usr/bin
|
$(STAGING_DIR)/usr/bin
|
||||||
mkdir -p $(STAGING_DIR)/usr/include/apr-0/
|
mkdir -p $(STAGING_DIR)/usr/include/apr-1/
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-0/* \
|
$(CP) $(PKG_INSTALL_DIR)/usr/include/apr-1/* \
|
||||||
$(STAGING_DIR)/usr/include/apr-0/
|
$(STAGING_DIR)/usr/include/apr-1/
|
||||||
mkdir -p $(STAGING_DIR)/usr/lib
|
mkdir -p $(STAGING_DIR)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*aprutil* \
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*aprutil* \
|
||||||
$(STAGING_DIR)/usr/lib/
|
$(STAGING_DIR)/usr/lib/
|
||||||
$(SED) "s,\"/usr\",$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/bin/apu-config
|
mkdir -p $(STAGING_DIR)/usr/lib/pkgconfig/
|
||||||
$(SED) "s,"libdir\=\'/usr/lib\'",libdir='$(STAGING_DIR)/usr/lib\'," $(STAGING_DIR)/usr/lib/libaprutil-0.la
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/apr-util-1.pc \
|
||||||
|
$(STAGING_DIR)/usr/lib/pkgconfig/
|
||||||
|
$(SED) "s,\"/usr\",$(STAGING_DIR)/usr," $(STAGING_DIR)/usr/bin/apu-1-config
|
||||||
|
$(SED) "s,bindir\=\"/usr/bin\",bindir\=\"$(STAGING_DIR)/usr/bin\"," $(STAGING_DIR)/usr/bin/apu-1-config
|
||||||
|
$(SED) "s,"libdir\=\'/usr/lib\'",libdir='$(STAGING_DIR)/usr/lib\'," $(STAGING_DIR)/usr/lib/libaprutil-1.la
|
||||||
|
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Build/UninstallDev
|
define Build/UninstallDev
|
||||||
-rm $(STAGING_DIR)/usr/bin/apu-config \
|
rm $(STAGING_DIR)/usr/bin/apu-1-config \
|
||||||
$(STAGING_DIR)/usr/include/apr-0/{apr_anylock.h,apr_base64.h,apr_buckets.h,apr_date.h,apr_dbm.h,apr_hooks.h,apr_ldap.h,apr_ldap_url.h,apr_md4.h,apr_md5.h,apr_optional.h,apr_optional_hooks.h,apr_queue.h,apr_reslist.h,apr_rmm.h,apr_sdbm.h,apr_sha1.h,apr_strmatch.h,apr_uri.h,apr_uuid.h,apr_xlate.h,apr_xml.h,apu_compat.h,apu.h,apu_version.h,apu_want.h} \
|
$(STAGING_DIR)/usr/lib/{*aprutil-1*,aprutil.exp}
|
||||||
$(STAGING_DIR)/usr/lib/*aprutil*
|
rm -rf $(STAGING_DIR)/usr/include/apr-1
|
||||||
endef
|
endef
|
||||||
|
|
||||||
define Package/apr-util/install
|
define Package/apr-util/install
|
||||||
$(INSTALL_DIR) $(1)/usr/bin
|
$(INSTALL_DIR) $(1)/usr/bin
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-config $(1)/usr/bin/
|
$(CP) $(PKG_INSTALL_DIR)/usr/bin/apu-1-config $(1)/usr/bin/
|
||||||
$(INSTALL_DIR) $(1)/usr/lib
|
$(INSTALL_DIR) $(1)/usr/lib
|
||||||
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
$(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
|
||||||
endef
|
endef
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff -ur apr-util-0.9.13-old/configure apr-util-0.9.13/configure
|
|
||||||
--- apr-util-0.9.13-old/configure 2006-11-29 13:01:46.000000000 +0100
|
|
||||||
+++ apr-util-0.9.13/configure 2007-05-15 02:12:29.000000000 +0200
|
|
||||||
@@ -2039,9 +2039,6 @@
|
|
||||||
{ (exit 1); exit 1; }; }
|
|
||||||
fi
|
|
||||||
|
|
||||||
- APR_BUILD_DIR="`$apr_config --installbuilddir`"
|
|
||||||
-
|
|
||||||
- APR_BUILD_DIR="`cd $APR_BUILD_DIR && pwd`"
|
|
||||||
|
|
||||||
APR_INCLUDES="`$apr_config --includes`"
|
|
||||||
APR_LIBS="`$apr_config --link-libtool --libs`"
|
|
@ -1,24 +0,0 @@
|
|||||||
diff -ur apr-util-0.9.13-old/xml/expat/aclocal.m4 apr-util-0.9.13/xml/expat/aclocal.m4
|
|
||||||
--- apr-util-0.9.13-old/xml/expat/aclocal.m4 2006-11-29 13:01:46.000000000 +0100
|
|
||||||
+++ apr-util-0.9.13/xml/expat/aclocal.m4 2007-05-15 10:38:44.000000000 +0200
|
|
||||||
@@ -69,7 +69,7 @@
|
|
||||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
|
||||||
|
|
||||||
# Always use our own libtool.
|
|
||||||
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
||||||
+LIBTOOL='$(SHELL) libtool'
|
|
||||||
AC_SUBST(LIBTOOL)dnl
|
|
||||||
|
|
||||||
# Prevent multiple expansion
|
|
||||||
diff -ur apr-util-0.9.13-old/xml/expat/configure apr-util-0.9.13/xml/expat/configure
|
|
||||||
--- apr-util-0.9.13-old/xml/expat/configure 2006-11-29 13:01:59.000000000 +0100
|
|
||||||
+++ apr-util-0.9.13/xml/expat/configure 2007-05-15 10:59:40.000000000 +0200
|
|
||||||
@@ -19162,7 +19162,7 @@
|
|
||||||
LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
|
|
||||||
|
|
||||||
# Always use our own libtool.
|
|
||||||
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
|
|
||||||
+LIBTOOL='$(SHELL) libtool'
|
|
||||||
|
|
||||||
# Prevent multiple expansion
|
|
||||||
|
|
@ -1,28 +0,0 @@
|
|||||||
diff -Nur apr-util-0.9.13-old/uri/Makefile.in apr-util-0.9.13/uri/Makefile.in
|
|
||||||
--- apr-util-0.9.13-old/uri/Makefile.in 2004-11-25 00:45:40.000000000 +0100
|
|
||||||
+++ apr-util-0.9.13/uri/Makefile.in 2007-05-15 14:05:15.000000000 +0200
|
|
||||||
@@ -15,4 +15,3 @@
|
|
||||||
apr_uri.lo: uri_delims.h apr_uri.c
|
|
||||||
|
|
||||||
uri_delims.h: gen_uri_delims
|
|
||||||
- ./gen_uri_delims > uri_delims.h
|
|
||||||
diff -Nur apr-util-0.9.13-old/uri/uri_delims.h apr-util-0.9.13/uri/uri_delims.h
|
|
||||||
--- apr-util-0.9.13-old/uri/uri_delims.h 1970-01-01 01:00:00.000000000 +0100
|
|
||||||
+++ apr-util-0.9.13/uri/uri_delims.h 2007-05-15 14:01:53.000000000 +0200
|
|
||||||
@@ -0,0 +1,16 @@
|
|
||||||
+/* this file is automatically generated by gen_uri_delims, do not edit */
|
|
||||||
+static const unsigned char uri_delims[256] = {
|
|
||||||
+ T_NUL,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,T_HASH,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,T_SLASH,0,0,0,0,0,0,0,0,0,0,T_COLON,0,
|
|
||||||
+ 0,0,0,T_QUESTION,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,
|
|
||||||
+ 0,0,0,0,0,0,0,0,0,0,0,0,0,0,0,0
|
|
||||||
+};
|
|
Loading…
x
Reference in New Issue
Block a user