curl: upgrade to 7.23.1

First patch version doesn't apply to current trunk, so please try this one.

Signed-off-by: Michael Heimpold <mhei@heimpold.de>

git-svn-id: svn://svn.openwrt.org/openwrt/packages@29787 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
jow 2012-01-19 01:20:53 +00:00
parent 099c9d1440
commit 1b0bbf873b
3 changed files with 2 additions and 146 deletions

View File

@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=curl
PKG_VERSION:=7.21.7
PKG_VERSION:=7.23.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@ -19,7 +19,7 @@ PKG_SOURCE_URL:=http://curl.haxx.se/download/ \
ftp://ftp.planetmirror.com/pub/curl/ \
http://www.mirrormonster.com/curl/download/ \
http://curl.mirrors.cyberservers.net/download/
PKG_MD5SUM:=5f6d50c4d4ee38c57fe37e3cff75adbd
PKG_MD5SUM:=0296d3196b4bf82c896a869b38dbc5f2
PKG_FIXUP:=libtool
PKG_BUILD_PARALLEL:=1

View File

@ -1,119 +0,0 @@
Index: curl-7.21.7/configure.ac
===================================================================
--- curl-7.21.7.orig/configure.ac
+++ curl-7.21.7/configure.ac
@@ -1522,15 +1522,6 @@ if test X"$OPT_SSL" != Xno; then
fi
if test "$OPENSSL_ENABLED" = "1"; then
- if test -n "$LIB_OPENSSL"; then
- dnl when the ssl shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to LD_LIBRARY_PATH
- dnl to prevent further configure tests to fail due to this
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_OPENSSL"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $LIB_OPENSSL to LD_LIBRARY_PATH])
- fi
CURL_CHECK_OPENSSL_API
fi
@@ -1759,17 +1750,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
if test "x$USE_GNUTLS" = "xyes"; then
AC_MSG_NOTICE([detected GnuTLS version $version])
-
- if test -n "$gtlslib"; then
- dnl when shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
- dnl due to this
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$gtlslib"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $gtlslib to LD_LIBRARY_PATH])
- fi
fi
fi
@@ -1869,18 +1849,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
CURL_LIBS="$CURL_LIBS -lpolarssl"
LIBS="$LIBS -lpolarssl"
-
- if test -n "$polarssllib"; then
- dnl when shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
- dnl due to this
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$polarssllib"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $polarssllib to LD_LIBRARY_PATH])
- fi
-
fi
fi dnl PolarSSL not disabled
@@ -1958,18 +1926,6 @@ if test "$OPENSSL_ENABLED" != "1"; then
CURL_LIBS="$CURL_LIBS -lcyassl -lm"
LIBS="$LIBS -lcyassl -lm"
-
- if test -n "$cyassllib"; then
- dnl when shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
- dnl due to this
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$cyassllib"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $cyassllib to LD_LIBRARY_PATH])
- fi
-
fi
fi dnl CyaSSL not disabled
@@ -2053,19 +2009,6 @@ if test "$OPENSSL_ENABLED" != "1" -a "$G
CPPFLAGS="$CLEANCPPFLAGS"
])
- if test "x$USE_NSS" = "xyes"; then
- AC_MSG_NOTICE([detected NSS version $version])
-
- dnl when shared libs were found in a path that the run-time
- dnl linker doesn't search through, we need to add it to
- dnl LD_LIBRARY_PATH to prevent further configure tests to fail
- dnl due to this
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$nssprefix/lib$libsuff"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $nssprefix/lib$libsuff to LD_LIBRARY_PATH])
- fi
-
fi
fi dnl NSS not disabled
@@ -2114,11 +2057,6 @@ if test "$curl_ssl_msg" = "$init_ssl_msg
AXTLS_ENABLED=1
USE_AXTLS="yes"
curl_ssl_msg="enabled (axTLS)"
-
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$LIB_AXTLS"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $LIB_AXTLS to LD_LIBRARY_PATH])
],[
LDFLAGS="$CLEANLDFLAGS"
CPPFLAGS="$CLEANCPPFLAGS"
@@ -2220,10 +2158,6 @@ if test X"$OPT_LIBSSH2" != Xno; then
dnl libssh2_session_handshake was added in 1.2.8
AC_CHECK_FUNCS( libssh2_version libssh2_init libssh2_exit \
libssh2_scp_send64 libssh2_session_handshake)
-
- LD_LIBRARY_PATH="$LD_LIBRARY_PATH:$DIR_SSH2"
- export LD_LIBRARY_PATH
- AC_MSG_NOTICE([Added $DIR_SSH2 to LD_LIBRARY_PATH])
fi
else
dnl no libssh2, revert back to clean variables

View File

@ -1,25 +0,0 @@
--- a/src/main.c
+++ b/src/main.c
@@ -936,7 +936,9 @@ static void help(void)
"Time needed to trig speed-limit abort. Defaults to 30",
" --ssl Try SSL/TLS (FTP, IMAP, POP3, SMTP)",
" --ssl-reqd Require SSL/TLS (FTP, IMAP, POP3, SMTP)",
+#ifndef OPENSSL_NO_SSL2
" -2/--sslv2 Use SSLv2 (SSL)",
+#endif
" -3/--sslv3 Use SSLv3 (SSL)",
" --stderr <file> Where to redirect stderr. - means stdout",
" --tcp-nodelay Use the TCP_NODELAY option",
@@ -2535,10 +2537,12 @@ static ParameterError getparameter(char
/* TLS version 1 */
config->ssl_version = CURL_SSLVERSION_TLSv1;
break;
+#ifndef OPENSSL_NO_SSL2
case '2':
/* SSL version 2 */
config->ssl_version = CURL_SSLVERSION_SSLv2;
break;
+#endif
case '3':
/* SSL version 3 */
config->ssl_version = CURL_SSLVERSION_SSLv3;