Upgrade apache to 2.2.9 (#3671)
git-svn-id: svn://svn.openwrt.org/openwrt/packages@11653 3c298f89-4303-0410-b956-a3cf2f4a3e73
This commit is contained in:
parent
de8b93b56b
commit
1c43ae7615
@ -9,17 +9,16 @@
|
||||
include $(TOPDIR)/rules.mk
|
||||
|
||||
PKG_NAME:=apache
|
||||
PKG_VERSION:=2.2.6
|
||||
PKG_RELEASE:=2
|
||||
PKG_VERSION:=2.2.9
|
||||
PKG_RELEASE:=1
|
||||
PKG_SOURCE_NAME:=httpd
|
||||
|
||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.gz
|
||||
PKG_SOURCE:=$(PKG_SOURCE_NAME)-$(PKG_VERSION).tar.bz2
|
||||
PKG_SOURCE_URL:=http://ftp.uni-erlangen.de/pub/mirrors/apache/httpd/ \
|
||||
http://apache.imsam.info/httpd/
|
||||
PKG_MD5SUM:=d050a49bd7532ec21c6bb593b3473a5d
|
||||
PKG_MD5SUM:=3afa8137dc1999be695a20b62fdf032b
|
||||
|
||||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_NAME)-$(PKG_VERSION)
|
||||
PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
|
||||
|
||||
include $(INCLUDE_DIR)/package.mk
|
||||
|
||||
@ -37,9 +36,15 @@ define Package/apache
|
||||
DEPENDS:=+libapr +libaprutil +zlib +libexpat +libpcre +libopenssl +libsqlite3
|
||||
endef
|
||||
|
||||
define Package/apache/description
|
||||
The Apache Web Server is a powerful and flexible HTTP/1.1 compliant
|
||||
web server. Originally designed as a replacement for the NCSA HTTP
|
||||
Server, it has grown to be the most popular web server on the Internet.
|
||||
endef
|
||||
|
||||
define Package/apache-server
|
||||
$(call Package/apache/Default)
|
||||
TITLE:=The apache server & and some tools
|
||||
TITLE:=The Apache Web Server and some tools
|
||||
DEPENDS:=apache
|
||||
endef
|
||||
|
||||
@ -78,6 +83,11 @@ define Package/apache-icons
|
||||
DEPENDS:=apache
|
||||
endef
|
||||
|
||||
define Package/apache-icons/description
|
||||
$(call Package/apache/description)
|
||||
This package contains the icons from Apache.
|
||||
endef
|
||||
|
||||
define Build/Configure
|
||||
$(call Build/Configure/Default, \
|
||||
--with-apr="$(STAGING_DIR)/usr/bin/apr-1-config" \
|
||||
|
@ -13,9 +13,9 @@
|
||||
# Configuration and logfile names: If the filenames you specify for many
|
||||
# of the server's control files begin with "/" (or "drive:/" for Win32), the
|
||||
# server will use that explicit path. If the filenames do *not* begin
|
||||
# with "/", the value of ServerRoot is prepended -- so "/var/log/foo.log"
|
||||
# with "/", the value of ServerRoot is prepended -- so "/var/log/foo_log"
|
||||
# with ServerRoot set to "/usr" will be interpreted by the
|
||||
# server as "/usr//var/log/foo.log".
|
||||
# server as "/usr//var/log/foo_log".
|
||||
|
||||
#
|
||||
# ServerRoot: The top of the directory tree under which the server's
|
||||
@ -53,6 +53,7 @@ Listen 80
|
||||
#
|
||||
|
||||
<IfModule !mpm_netware_module>
|
||||
<IfModule !mpm_winnt_module>
|
||||
#
|
||||
# If you wish httpd to run as a different user or group, you must run
|
||||
# httpd as root initially and it will switch.
|
||||
@ -63,6 +64,8 @@ Listen 80
|
||||
#
|
||||
User nobody
|
||||
Group nogroup
|
||||
|
||||
</IfModule>
|
||||
</IfModule>
|
||||
|
||||
# 'Main' server configuration
|
||||
@ -180,7 +183,7 @@ DocumentRoot "/usr/share/htdocs"
|
||||
# logged here. If you *do* define an error logfile for a <VirtualHost>
|
||||
# container, that host's errors will be logged there and not here.
|
||||
#
|
||||
ErrorLog /var/log/error_log
|
||||
ErrorLog "/var/log/error_log"
|
||||
|
||||
#
|
||||
# LogLevel: Control the number of messages logged to the error_log.
|
||||
@ -209,13 +212,13 @@ LogLevel debug
|
||||
# define per-<VirtualHost> access logfiles, transactions will be
|
||||
# logged therein and *not* in this file.
|
||||
#
|
||||
CustomLog /var/log/access_log common
|
||||
CustomLog "/var/log/access_log" common
|
||||
|
||||
#
|
||||
# If you prefer a logfile with access, agent, and referer information
|
||||
# (Combined Logfile Format) you can use the following directive.
|
||||
#
|
||||
#CustomLog /var/log/access_log combined
|
||||
#CustomLog "/var/log/access_log" combined
|
||||
</IfModule>
|
||||
|
||||
<IfModule alias_module>
|
||||
@ -364,37 +367,37 @@ EnableSendfile off
|
||||
# necessary.
|
||||
|
||||
# Server-pool management (MPM specific)
|
||||
## Include /etc/apache/extra/httpd-mpm.conf
|
||||
#Include /etc/apache/extra/httpd-mpm.conf
|
||||
|
||||
# Multi-language error messages
|
||||
## Include /etc/apache/extra/httpd-multilang-errordoc.conf
|
||||
#Include /etc/apache/extra/httpd-multilang-errordoc.conf
|
||||
|
||||
# Fancy directory listings
|
||||
## Include /etc/apache/extra/httpd-autoindex.conf
|
||||
#Include /etc/apache/extra/httpd-autoindex.conf
|
||||
|
||||
# Language settings
|
||||
## Include /etc/apache/extra/httpd-languages.conf
|
||||
#Include /etc/apache/extra/httpd-languages.conf
|
||||
|
||||
# User home directories
|
||||
## Include /etc/apache/extra/httpd-userdir.conf
|
||||
#Include /etc/apache/extra/httpd-userdir.conf
|
||||
|
||||
# Real-time info on requests and configuration
|
||||
## Include /etc/apache/extra/httpd-info.conf
|
||||
#Include /etc/apache/extra/httpd-info.conf
|
||||
|
||||
# Virtual hosts
|
||||
## Include /etc/apache/extra/httpd-vhosts.conf
|
||||
#Include /etc/apache/extra/httpd-vhosts.conf
|
||||
|
||||
# Local access to the Apache HTTP Server Manual
|
||||
## Include /etc/apache/extra/httpd-manual.conf
|
||||
#Include /etc/apache/extra/httpd-manual.conf
|
||||
|
||||
# Distributed authoring and versioning (WebDAV)
|
||||
## Include /etc/apache/extra/httpd-dav.conf
|
||||
#Include /etc/apache/extra/httpd-dav.conf
|
||||
|
||||
# Various default settings
|
||||
## Include /etc/apache/extra/httpd-default.conf
|
||||
#Include /etc/apache/extra/httpd-default.conf
|
||||
|
||||
# Secure (SSL/TLS) connections
|
||||
## Include /etc/apache/extra/httpd-ssl.conf
|
||||
#Include /etc/apache/extra/httpd-ssl.conf
|
||||
#
|
||||
# Note: The following must must be present to support
|
||||
# starting without SSL on platforms with no /dev/random equivalent
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- httpd-2.2.4.orig/server/Makefile.in 2007-07-02 03:30:22.000000000 +0200
|
||||
+++ httpd-2.2.4/server/Makefile.in 2007-07-02 03:47:35.000000000 +0200
|
||||
--- a/server/Makefile.in
|
||||
+++ b/server/Makefile.in
|
||||
@@ -26,7 +26,10 @@
|
||||
$(LINK) $(EXTRA_LDFLAGS) $(gen_test_char_OBJECTS) $(EXTRA_LIBS)
|
||||
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- httpd-2.2.4.orig/server/test_char.h 2007-07-02 03:30:22.000000000 +0200
|
||||
+++ httpd-2.2.4/server/test_char.h 2007-07-02 03:45:58.000000000 +0200
|
||||
--- /dev/null
|
||||
+++ b/server/test_char.h
|
||||
@@ -0,0 +1,23 @@
|
||||
+/* this file is automatically generated by gen_test_char, do not edit */
|
||||
+#define T_ESCAPE_SHELL_CMD (1)
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- httpd-2.2.4.orig/build/mkconfNW.awk 2007-07-02 03:30:22.000000000 +0200
|
||||
+++ httpd-2.2.4/build/mkconfNW.awk 2007-07-15 21:29:01.000000000 +0200
|
||||
@@ -23,7 +23,7 @@
|
||||
--- a/build/mkconfNW.awk
|
||||
+++ b/build/mkconfNW.awk
|
||||
@@ -24,7 +24,7 @@
|
||||
A["sysconfdir"] = "conf"
|
||||
A["iconsdir"] = "icons"
|
||||
A["manualdir"] = "manual"
|
||||
@ -9,8 +9,8 @@
|
||||
A["errordir"] = "error"
|
||||
A["proxycachedir"] = "proxy"
|
||||
|
||||
--- httpd-2.2.4.orig/config.layout 2007-07-02 03:30:22.000000000 +0200
|
||||
+++ httpd-2.2.4/config.layout 2007-07-15 22:03:15.000000000 +0200
|
||||
--- a/config.layout
|
||||
+++ b/config.layout
|
||||
@@ -28,8 +28,8 @@
|
||||
cgidir: ${datadir}/cgi-bin
|
||||
includedir: ${prefix}/include
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- httpd-2.2.4.orig/include/scoreboard.h 2007-07-02 03:30:23.000000000 +0200
|
||||
+++ httpd-2.2.4/include/scoreboard.h 2007-07-15 23:43:19.000000000 +0200
|
||||
--- a/include/scoreboard.h
|
||||
+++ b/include/scoreboard.h
|
||||
@@ -42,7 +42,7 @@
|
||||
|
||||
/* Scoreboard file, if there is one */
|
||||
|
Loading…
x
Reference in New Issue
Block a user